Problems copy and pasting RGB channels and layers

New Here ,
May 03, 2019 May 03, 2019

Copy link to clipboard

Copied

Hi,

I am using a MacBook pro running "mojave" 10.14.4 and using photoshop cc2019 20.0.4 and I can't copy paste channels or layers.  I first tried loading the 4 channels, red, green, blue and luminance and then I opened a new document.  I then did a command A on each channel and tried to paste to its selected channel.  No go!.  In fact when I copy all the paste command is grayed out.  I then selected one of the RGB files and right clicked the the channels and selected merge channels and this allowed me to use the rgb channels in a pic but I could not add the luminance channel as a layer.  Very frustrating.  Any suggestions would be appreciated.

Joe in Mobile

Views

3.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , May 03, 2019 May 03, 2019
Have you check the number of bit per channel? Have you tried to reset photoshop preferences?Please take a look here:Copy and Paste a channel in Photoshop CC

Likes

Translate

Translate
Advocate ,
May 03, 2019 May 03, 2019

Copy link to clipboard

Copied

What are you trying to achieve with this? Just asking to better be able to help you get to the final goal...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 03, 2019 May 03, 2019

Copy link to clipboard

Copied

i am shooting astro pics in mono with RGB and Lum filters.  Trying to combine them to edit them.

Joe in Mobile

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 03, 2019 May 03, 2019

Copy link to clipboard

Copied

Everything works fine on Win. I tried a couple of ways and all of them work as expected. You are missing something. Here are the steps:

  • Select proper layer in the Layers panel
  • Open Channels panel and click one of the three channels: Red, Green or Blue. Other channels will be hidden, only one channel should be visible
  • Use Select > Select All then Copy and Paste commands

Method number two:

  • Open Channels panel
  • Select - click on it - channel which you want to duplicate
  • Right click on channel and choose: Duplicate Channel
  • In the Duplicate Channel dialog you can give a name to duplicated instance and also to choose document in which you want to duplicate channel in the Destination section.

duplicate channel in ps.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 03, 2019 May 03, 2019

Copy link to clipboard

Copied

Have you check the number of bit per channel? Have you tried to reset photoshop preferences?

Please take a look here:

Copy and Paste a channel in Photoshop CC

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 05, 2019 May 05, 2019

Copy link to clipboard

Copied

I really appreciate everyone' s help.  As usual it was a user issue.   I would to the command-a but not the command-c.  I kept thinking that the select all was copying it.  Sheesh!  The light came on and I saw the error of my ways.  Thanks again everyone.  Let the astrophotography torment begin anew. 

Joe in Mobile

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 14, 2022 Jun 14, 2022

Copy link to clipboard

Copied

LATEST

If anyone is still having this problem in 2022 try switching to 16 bits and then switching back.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines