Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


PS CS6 on CC lags when using mouse after using tablet?

Explorer ,
Jun 08, 2013 Jun 08, 2013

Copy link to clipboard

Copied

Noticed that photoshop CS6 on Creative Cloud at least seems to lag when I try to move a layer around or a selection around with my mouse after I have used my tablet.  So what Im trying to say is that I can move selections around with my mouse or with my tablet and they move fine but when I do anything with my tablet and the go back to my mouse thats where I get the lagging movement.  If I then at that point try to move the selection with my tablet it doest lag around.  As I try different things with my mouse after I have used my tablet nothing else seems to lag just moving the selection with my mouse.  Any others having this issue or know what may be the cause?

Views

35.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
replies 100 Replies 100
Contributor ,
Oct 17, 2013 Oct 17, 2013

Copy link to clipboard

Copied

Back on our original topic for a moment, please let's not forget that Wacom should also have a look into this issue. I strongly encourage you to post also at the Wacom forums regarding this bug.

I can't find the link to the USA forums since I'm in Europe and when going to Wacom.com and clicking Product support > Forum, I get instantly redirected to the wacom.eu site, but for what it's worth, here is the thread I opened at the Intuos forum:

http://forum.wacom.eu/viewtopic.php?f=2&t=15969

This issue could be Adobe's fault, yes, but it might also be Wacom's (in fact, since they do the driver, they should be the ones to pinpoint the problem at least).

Wacom support staff seems pretty responsive, but so far, AFAIK, it's just the two of us (ook_22 and me) complaining about this specific issue at Wacom's site!

So please make sure to make yourselves heard on Wacom's forum too (it takes a minute to create a user, I know it's always a nuisance, but putting up with this mouse lag is worse in the medium and long run... and I don't know about you, but I plan on keeping on using Photoshop CC for a very long time).

I guess complaining to Wacom is the best way in order to get a solution for this problem. Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 17, 2013 Oct 17, 2013

Copy link to clipboard

Copied

Something similar to this happens on my Vista install of CS6 straight off of the discs. I will be drawing with the pen tool (using a mouse) and Photoshop will get super slow and lag quite a bit. At the point I pick up my Wacom tablet and draw the rest of the path with the tablet I can go back to using the mouse again. Almost instantly when I pick up the tablet the system is responsive. I happens on the Intuous 3 and the Intuous 5 and only in Photoshop CS6 and up I'm guessing (not running CC on that one yet). It doesn't matter the size of the file either, little 100 pixel wide web files or 1gb files for print. I paint with the pen, but draw paths with the mouse (old-skool).

Vista 64-bit - Dual AMD Opteron 4184 - 64gb RAM

Running 2 SSDs in a striped set for my Photoshop Swap file.

Windows Pagefile is off (because I have enough memory).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Oct 17, 2013 Oct 17, 2013

Copy link to clipboard

Copied

First, go turn the pagefile back on, and set it to at least 2 to 4 times your installed RAM.

You do not have enough memory (ever), and the OS needs a pagefile.

Whomever convinced you to disable the pagefile was sorely mistaken, or intentionally trying to make you mess up your system.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 17, 2013 Oct 17, 2013

Copy link to clipboard

Copied

So Chris, what do you think Windows would do with a 256gb pagefile? The system runs flawlessly other than the Adobe/Wacom driver issue. Thanks for the IT advice though.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Oct 17, 2013 Oct 17, 2013

Copy link to clipboard

Copied

If you think that turning off the pagefile is appropriate, then you probalby don't know how the OS uses pagefiles.

Yeah, you really should turn it back on - as it might be responsible for some of the issues on your system.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 17, 2013 Oct 17, 2013

Copy link to clipboard

Copied

Are you suggesting that the lag someone experiences using a mouse to draw a vector path on a 100k jpeg that mysteriously goes away when they use their Wacom tablet instead of the mouse, in Photoshop CS6, on a machine with 64gb of RAM, of which 32gb is assigned to Photoshop (that also has its own 256gb striped raided SSD swap file); is NOT in fact an issue with the compatibility of the drivers provided by Wacom and the built-in support for tablets in Photoshop; but rather an issue of the pagefile in Windows not being large enough to handle the vastly massive overhead required to draw the vector path on such a tiny image; and Adobe's official suggestion is that I add a 256gb pagefile to Windows?

Sounds ridiculous when you look at it. My peak commit charge with a 930mb Photoshop file open during a reduction in size of said Photoshop file from 13200px X 13700px to 1200px X 1200px is 9.34gb (that's 13.94% of my installed RAM). Suggesting that I add a 256gb pagefile to my system to rectify an issue that showed up in Photoshop CS6 (because it doesn't happen in CS5.5) is incorrect.

For the record according to the people who made Windows (where I got my information):

The 64-bit versions of Windows can support more RAM than the 32-bit versions of these products. When a lot of memory is added to a computer, a paging file may not be required.

They still recommend that you use one, so you can go through the memory dumps when an app like Firefox loads Adobe Flash Player and pages out of memory due to poor programming though. Luckily I've not had this same experience with Adobe Photoshop and because I'm using a server motherboard with ECC RAM I've not had bluescreens either.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Oct 17, 2013 Oct 17, 2013

Copy link to clipboard

Copied

Ouch, that is bad advice.  Even with lots of RAM, you can save a lot of that RAM using a paging file (otherwise a lot of unused data and code is sitting in RAM when it will never be loaded, and mmap operations are going to be painful).

The lack of a paging file can reduce performance on the system - but usually that performance loss occurs when loading applications.  I don't know if your delays are related - but you really don't have a good setup and really should re-enable the paging file.  Unless you're debugging the OS, there's no good reason to disable the system paging file.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 17, 2013 Oct 17, 2013

Copy link to clipboard

Copied

Even with lots of RAM, you can save a lot of that RAM using a paging file.

I agree.


On the speed, having a pagefile is slower (ms vs ns) than doing everything in memory. It does take longer to initially start the machine and load everything with the pagefile turned off (Windows sort of loses its head when things aren't configured as expected), but the system was much more responsive in my case (with it off) once I had all of my apps loaded... all with the exception of the vector path tool (every once in a while) in Photoshop. I've also disabled caching, prefetch, writebehind caching and a lot of the background tasks because I'm not concerned with the perception of speed in Windows, only with performance during renders (Lightwave, Modo, Premiere). I'm also running a significantly paired down install compared to what comes out of the box, so I'm not running the average machine (custom build and custom install).

The lack of a paging file can reduce performance on the system - but usually that performance loss occurs when loading applications.

Right. AND this is good advice... do NOT disable your pagefile people. I forgot this was in the context of general advice because someone will read my post and think... "Hey that sounds like a good idea." then hose their machine.


Even though your response about the pagefile was off of my original point (about it being a driver conflict in regard to the Wacom tablet) it did help me, because I had built the machine as a workstation and used it that way for several years, but have used it largely as a server (server motherboard and all) for a couple of weeks after I got my Mac and had forgotten I had disabled the pagefile. Enabling the pagefile definitely helps with serving the larger files and everything else related to the background tasks involved. Also I've switch the settings on that machine to priority for background tasks as well.


Back on topic (didn't mean to appear to hijack the thread)

The glitch with the path tool existed before I turned off my pagefile though, I didn't disable the pagefile until earlier this year when I trying to squeeze more performance out of my machine (before upgrading and buying a Mac). I do not experience the same issues with the path tool on the Mac. Love Photoshop by the way. Thanks Chris!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 18, 2013 Oct 18, 2013

Copy link to clipboard

Copied

Hey, I found out, that problem exists only with 64bit version of photoshop cs6, but with 32bit version it works fine.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 21, 2013 Oct 21, 2013

Copy link to clipboard

Copied

I Started photoshop cc trial today, and found out, that lag happens also with 32bit version of cc.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 24, 2013 Oct 24, 2013

Copy link to clipboard

Copied

I've been having this same issue with Photoshop CC (64 and 32 bit) for a little while now - it's incredibly annoying. Using my Wacom Intuos 3 in Photoshop seems to sabotage mouse functionality. All functions performed with the mouse, after using the tablet, start to lag really badly; this includes drawing, selecting and zooming.

Setup:

Windows 7 64-bit

Intel Core i7-3770K 3.5GHz

16GB memory

GeForce GTX 560Ti

Samsung SSD 256GB

Adobe Photoshop CC 64-bit

Wacom Intuos 3 - driver version 6.3.6-3

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 25, 2013 Oct 25, 2013

Copy link to clipboard

Copied

I recently upgraded from Win 8 Professional to Windows 8.1, in the hopes that something might improve.

But it has been just the opposite - not only the "mouse lag after switching from pen" is the same as before, but now the tablet driver exhibits some malfunctions and bugs that were not happening before.

I hope Wacom eventually release a driver update that fixes this annoying issue because it's seriously hurting the workflow of many people.

Thanks to everybody that also posted at the "Mouse click lag when switching from mouse to pen" thread at Wacom's support forum, I think it's the best way to remind them that a fix is needed, so please keep posting there too.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 11, 2013 Nov 11, 2013

Copy link to clipboard

Copied

Ok so after a long road with no real solutions, I today noticed that if when using my pen, I quickly (very quickly) remove it from the tablet without allowing the cursor to move then switch to mouse, I dont get the lag.  But if I casually remove the pen from the tablet then switch to the mouse I get the lag!  I tried this over and over.  It worked 100% of the time.  So at least for me I seem to have a solution although kind of annoying I have to do that but I guess if it works...  Anyone get a chance and give it a try, let me know what you find.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 12, 2013 Nov 12, 2013

Copy link to clipboard

Copied

Muxtun11, you're my hero!!! It works for me too!! Of course, it's still annoying, but not near as much as it was before, it's a great improvement over the previous situation. I've shared your trick on the Wacom forums.

Nonetheless, I truly hope Adobe, Wacom (or whoever) to do something in order to fix this problem. It has been making my life miserable for the last few months (since I bought my new intuos pro, in fact).

Again, thanks a lot for sharing this workaround, it is MUCH appreciated!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 12, 2013 Nov 12, 2013

Copy link to clipboard

Copied

It's bizzarre but amazingly this also works for me.  Difficult to do reliably while working but it does fix the problem.  Hopefully this will be a clue to those involved as to what might be causing it.

Great find!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 17, 2013 Nov 17, 2013

Copy link to clipboard

Copied

Yep this method works for me too. Hope there will be a fix out for this soon. Odd that neither Adobe nor Wacom seem to be acknowledging this problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 21, 2013 Nov 21, 2013

Copy link to clipboard

Copied

The quick removal of the pen works so that at least I don't have to reboot Photoshop or raise my blood pressure trying to transform a layer with the delay, but the problem is by no means gone. It completely kills my workflow when trying to work with photos. I first got this problem with the latest update to CS6, with the earlier versions I had no problems, so that's when something went wrong (I think I updated from 13.0.1.1 to 13.0.1.3). Right now I have the latest version of CC (64 bit). I'm using Windows 7 64 bit and Bamboo Pen & Touch with the latest driver.

I actually ordered Intuos Pro S a week ago and it's supposed to arrive next week, so I'll report if the problem persists with that. Not confident since I've seen people with Cintiqs and Intuos' having the same problem.

Edit: yep, still the same problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 04, 2013 Dec 04, 2013

Copy link to clipboard

Copied

So, after 6 months there is no any solution (except the solution from Muxtun11)?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 04, 2013 Dec 04, 2013

Copy link to clipboard

Copied

I asked Wacom if they can or can not reproduce this problem (mouse lag), since they knew about it but they weren't saying whether it was a bug or not, and I wanted them to give a clear answer.

But they did not answer - they just ignored the question.

I also asked them about other problem introduced in recent drivers (the reduced detection height for the pen when using the tablet in mouse mode, an absolute mess that makes the tablet useless except in pen mode).

But they did not answer either - they also ignored the question.

And these are just a few of the ongoing issues with their tablets. For some of their models, they even recommend using older versions of the drivers, but I have an Intuos Pro and I am stuck with the latest drivers. I believe that Wacom's drivers are falling behind the hardware quality of their products for some reason. The product is excellent, but the drivers have a lot of problems.

My perception of Wacom has radically changed over the course of the last few weeks. I started having a great respect for them, now I feel like I bought a crappy product. I hope sooner or later they change for the better, because as much as I hate to admit it, there seems to be no serious alternative to their products (but if anyone has a recommendation, please go ahead).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 26, 2014 Jan 26, 2014

Copy link to clipboard

Copied

I'm just now encountering this problem, and I was hoping I could find a solution here. I've been using CS6 for a while now with no issues, and decided to try out CC to see how I'd like it. I installed it and immediately ran into this issue; I can draw and use my mouse fine, then once I start using my pen my mouse lags for one second while Wacom_Tablet.exe shoots up in CPU usage.

I saw how old the thread was and had hoped a solution or a patch had been found, but apparently not. Has anyone made any headway talking to anyone on what could be causing this? CS6 continues working fine for me so I'll just keep using that, but I know it won't be long before I'll have to upgrade to CC and have to face this again.

System Specs:

-Photoshop CS6 x64 13.1.2 (WORKS FINE)

-Photoshop CC x64 14.2 (HAS PROBLEM)

-Win 7 Pro x64

-Core i7 860

-nVidia GTX 770

-16GB DDR3 Ram

-Logitech G700s mouse

-Cintiq 21UX 6.3.7-6 Driver

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 26, 2014 Jan 26, 2014

Copy link to clipboard

Copied

No unfortunately with the latest patch this issue has gotten even worse for me.  CC performace just gets more and more delayed the longer it's open "sometimes".  I really have no idea what is causing it anymore.  I'm going to resort to a tech support call next week as the application has become almost unusable for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jan 26, 2014 Jan 26, 2014

Copy link to clipboard

Copied

Same here. Latest Wacom drivers and Adobe PS updates did nothing to improve things.

Thanks to muxtun11 trick, I can get rid of the mouse lag without rebooting PS, but it's not a solution and after so many months, this bug has really hurt my workflow a lot.

The biggest problem, in my opinion, is that by now, Wacom has admitted the main bugs, but this one remains ignored (or at least I have not seen Wacom to acknowledge it). So, there's no way they can fix something that they don't even have on their radar.

If anyone ends up buying a different tablet brand, please let us know whether this issue happens too, or not (I guess it's more Wacom's fault than Adobe's, but who knows...).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 10, 2014 Feb 10, 2014

Copy link to clipboard

Copied

*Push.

It's amazing, how bad Adobes and Wacoms support has become.

This is a bug, which hurts the basic functions of most users work and they just don't care about it.

That's what happens when you have no competition.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 26, 2014 Feb 26, 2014

Copy link to clipboard

Copied

Just to add another voice to the crowd with this issue with PS CC.

I'm using a Wacom 21UX with latest drivers and the mouse lag gets triggered after using the Tablet. Incredibly frustrating... i'm installing CS6 to see if that is free of the issue because it's driving me mad.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 26, 2014 Feb 26, 2014

Copy link to clipboard

Copied

great topic!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines