Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Spot Healing Brush issue since latest update...

Explorer ,
Feb 24, 2020 Feb 24, 2020

Copy link to clipboard

Copied

My edits are remaining on screen until I click off the layer or move my image? Anyone else having this problem? Latest PS CC 2020 on Mac Catalina 10.15.3. 

 

See image:

 

IMG_0176.JPG

 

 

TOPICS
Bug, Mac, Problem or error

Views

4.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 3 Correct answers

Explorer , Feb 24, 2020 Feb 24, 2020
Just for your information... I spoke to Adobe. I changed the folder name in ~/Library/Preferences/Adobe Photoshop 2020 Settings to ~/Library/Preferences/old-Adobe Photoshop 2020 Settings That fixed the issue.

Likes

Translate

Translate
New Here , Feb 27, 2020 Feb 27, 2020
Hold down option key while selcting "go" in th th top bar on desktop then selct library.

Likes

Translate

Translate
New Here , Nov 22, 2020 Nov 22, 2020
Adobe support told me (via Facebook) to reset the spot healing brush. That fixed it for me. (sorry that the screenshot is in Dutch, but I think you'll get the idea of how to do this)

Likes

Translate

Translate
New Here ,
Apr 27, 2021 Apr 27, 2021

Copy link to clipboard

Copied

Same problem. I can't work like this. Sort it out for godsake.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Hi Adobe,

Same issue where the spot healing brush does not finish automatically and just leaves the black train on the screen.  It seems to be a screen refresh issue since any action that forces a screen refresh will complete the spot healing brush action. OS is Catalina 10.15.7 - PS 22.4.1

Renaming the preferences file did not help not resetting the tools.

Does work on some photos but not everywhere in the same photo.

This was working fine on my Mac until the latest PS 2021 update.

Thank you for your attention

Eric

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

I am having exactly the same issue with the healing brush.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 22, 2021 Sep 22, 2021

Copy link to clipboard

Copied

Make sure that "sample all layers" is selected. The setting should be:

Mode: Normal

Type: Content Aware

Check the box for Sample All Layers

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 23, 2021 Sep 23, 2021

Copy link to clipboard

Copied

Sigh. I so wish this had worked. But nothing to do. Even after a tool reset...

 

Capture d’écran 2021-09-23 à 11.46.03.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 24, 2021 Sep 24, 2021

Copy link to clipboard

Copied

@Betterburnout have you tried it with these settings and then changing tools? I've found that since the update and with these settings, the correction isn't always evident and appears exactly like your screenshot, but when I change tools or move to a different part of the image and then back, the correction has been made. It's bizarre.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 25, 2021 Sep 25, 2021

Copy link to clipboard

Copied

🙂 I'm going to try that. And I'll share the results. Thx

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 27, 2021 Sep 27, 2021

Copy link to clipboard

Copied

No, still this damn bug.
I can reset the tool, change the tool... it doesn't work. The effect is applied when I decide to move in the image eventually 😕

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 05, 2021 Jul 05, 2021

Copy link to clipboard

Copied

You are most likely running an iOS operating system that is unsupported. If you are running an iOS Op system that required a patch Photoshop will run terrible, the computer will drag, struggle to stay connected to the internet and your kernel task cpu usage will be through the roof. Go back down to the last iOS Op system that gave you no issues, download an older version of PS and it will work perfectly.

Weapon6

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 05, 2021 Jul 05, 2021

Copy link to clipboard

Copied

Thanks for the reply. I am running Catalina 10.15.7 so I am unclear if that is unsupported. The two issues I am having is the healing brush tool, and images not showing up when opened from LR. If you move the PS window the image shows up. Frustrating but easily dealt with. The healing brush is another matter. It will work on the background layer but not any other layer. On any other layer the black dots remain until you move to another tool. I have uninstalled and went back to an older version and it runs fine. This computer is only used for editing, is clean and has ample memory so it is frustrating. A fellow photographer has exactly the same machine (late 2013) set up identically and his runs just fine. 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 29, 2021 Aug 29, 2021

Copy link to clipboard

Copied

This is not a MacOS problem. It exists on Windows, too. 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 30, 2021 Aug 30, 2021

Copy link to clipboard

Copied

So let's definitely presume it's an Adobe problem.
I can't believe how long it takes to fix such an annoying problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 30, 2021 Aug 30, 2021

Copy link to clipboard

Copied

Hello, if you have the issue on 22.5, you could try to go to edit>Preferences>Technology previews and check "Deactivate Native Canvas" to see if it cures the issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 23, 2021 Sep 23, 2021

Copy link to clipboard

Copied

Thank you, I have tried, but without positive results.

 

Capture d’écran 2021-09-23 à 11.52.48.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 11, 2021 Jul 11, 2021

Copy link to clipboard

Copied

after applying 

in ~/Library/Preferences/Adobe Photoshop 2020 Settings to ~/Library/Preferences/old-Adobe Photoshop 2020 Settings

 

that partially fixed the issue. The edit black brush lines dissapear BUT not the first one applied in a series.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2