Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


What is the "Adobe CEP HTML Engine"? It`s using too much from my processor.

New Here ,
Dec 11, 2015 Dec 11, 2015

Copy link to clipboard

Copied

I`m trying out Photoshop CC from the past 10 days. It`s going well, but now, every time I open it, the workspace blinks white and the processor runs slow, avoiding the actual use of Photoshop.

In the Task Manager I've identified this 4 Processes called: "Adobe CEP HTML Engine", using lots of processors %. Closing them, I got back to Photoshop and it`s possible to work again, till the next file.

Every time I start PS or leave the workspace with no opened file, it starts all over again. Then I have to go back to Task Manager and finish the same processes again.

How to fix it for good? Is it related to Behance?

I`m using a Dell notebook, Core I7, 8Gb RAM, Win10 64.

Cheers.

TOPICS
FAQ

Views

156.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Dec 15, 2015 Dec 15, 2015

Copy link to clipboard

Copied

I'm also having this problem. It happens in Illustrator as well. It's really annoying and I couldn't find information about it on the net. Started with CC 2015.1 programs version.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 15, 2015 Dec 15, 2015

Copy link to clipboard

Copied

Using a Windows 10 x64 system with the latest version of PS CC (2015.1.1) but don't see that particular process. I see two instances of "Adobe CEF Helper (32-bit)" (which I believe is related to the CC Desktop App).

/shrug

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 04, 2016 Jan 04, 2016

Copy link to clipboard

Copied

Hi! I just solved it. It was constantly using 30% of my CPU.

The responsible file is "C:\Program Files\Adobe\Adobe Photoshop CC 2015\Required\CEP\CEPHtmlEngine\CEPHtmlEngine.exe"

Apparently, it enables html5 extensions/plug-ins in Photoshop.

Just go to Edit, Preferences, Plug-Ins and uncheck "Allow extensions to connecto to the internet" and most importantly "Load Extension Panels".

That did it for me. Cheers!

This solution has also helped many affected by this issue:

CEPHtmlEngine slows Computer (Mac) and solution.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Jan 05, 2016 Jan 05, 2016

Copy link to clipboard

Copied

But it disables the Start Screen. It's a workaround, not a solution.

In another posts, here in the forum, I learned that starting Ps, Ai etc as Administrator worked. So, in one of them, where Adobe staff was talking, I asked for the responsible files needing admin permissions. Here is the answer. I'll test it later to see if setting the right permissions in those folders will solve it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 15, 2016 Jan 15, 2016

Copy link to clipboard

Copied

I had a similar problem with Premiere Pro CC 2015 9.1.

And a similar solution.  Once I closed the "Libraries" panel, the app stopped trying to connect to the cloud repeatedly (or whatever that panel was doing) and CPU usage dropped.  It was using an entire core and really heating things up!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 19, 2016 Feb 19, 2016

Copy link to clipboard

Copied

THANK YOU!!!!

It was driving me crazy!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 02, 2016 Feb 02, 2016

Copy link to clipboard

Copied

It happens in DreamWeaver CC 2015 too...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 16, 2016 Feb 16, 2016

Copy link to clipboard

Copied

Did you ever find a solution? I'm struggling here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 16, 2016 Feb 16, 2016

Copy link to clipboard

Copied

I'm having the same problem with InDesign, Illustrator and Photoshop. I'm using OSX. The only solution I know of at the moment is to shut down all processes called "CEPHtmlEngine" (not CEPHtmlEngine Helper; those will shut down with the CEPHtmlEngine) by using the Activity Monitor.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 17, 2016 Feb 17, 2016

Copy link to clipboard

Copied

Same here, closing the libraries panel only works in premiere and after effects, indesign, illustrator and photoshop still open one 20% consuming CEPHtmlEngine Process each.

How do you end the process it just comes up again instantly for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 05, 2017 Jan 05, 2017

Copy link to clipboard

Copied

HenryWalkerWalker wrote:

Hi! I just solved it. It was constantly using 30% of my CPU.

The responsible file is "C:\Program Files\Adobe\Adobe Photoshop CC 2015\Required\CEP\CEPHtmlEngine\CEPHtmlEngine.exe"

Apparently, it enables html5 extensions/plug-ins in Photoshop.

Just go to Edit, Preferences, Plug-Ins and uncheck "Allow extensions to connecto to the internet" and most importantly "Load Extension Panels".

That did it for me. Cheers!

This solution has also helped many affected by this issue:

CEPHtmlEngine slows Computer (Mac) and solution.

SOLVED!

This worked for me. Thanks!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 05, 2017 Aug 05, 2017

Copy link to clipboard

Copied

HenryWalkerWalker

Your method seems to have worked for me...  Why oh why isn't this fixed?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 02, 2016 Feb 02, 2016

Copy link to clipboard

Copied

If you disable extensions via preferences you will notice that Libraries will disappear under the Windows menu and that tells you the source of the problem -the Libraries palette. Disabling  all extension though is overkill. The best thing to do is close the libraries panel , create a new workspace and save it. Now when Photoshop opens the library will be missing from the screen and the CPU activity will be normal. To use the library select it from the Windows menu.

Hope that helps

Terri

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 15, 2016 Feb 15, 2016

Copy link to clipboard

Copied

I have it too, using Premiere and After Effects CC on Win 10, it was using 40% until i closed the Libraries Panels. Please fix though!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 03, 2018 Jun 03, 2018

Copy link to clipboard

Copied

Thanks, Terri. That was just the ticket.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 18, 2016 Feb 18, 2016

Copy link to clipboard

Copied

Excellent - solved the problem, many thanks. ADOBE WHAT IS WRONG WITH YOU GUYS!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 23, 2016 Feb 23, 2016

Copy link to clipboard

Copied

If I untick "Show 'Start' Workspace When No Documents Are Open" in Preferences for Photoshop and Illustrator, the Adobe CEP HTML Engine stops using up CPU. But there's no option in Dreamweaver or Premiere so I'm stuck.

Edit: Closing the Libraries tab didn't work for me as others did.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 23, 2016 Feb 23, 2016

Copy link to clipboard

Copied

Dear All,

Could you please refer to this post and see whether it fixes your problem?

CEPHtmlEngine slows Computer (Mac) and solution.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 25, 2016 Feb 25, 2016

Copy link to clipboard

Copied

We are in the process of fixing this bug, but meanwhile, check out the solution in this forum post.

Re: CEPHtmlEngine issues

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 29, 2016 Feb 29, 2016

Copy link to clipboard

Copied

Any news on the official fix yet?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 02, 2016 Mar 02, 2016

Copy link to clipboard

Copied

Just want to add another voice to this chorus.  The issue exists running Premiere Pro 2015.2 under Windows 10.  (I did not notice it on either Windows 8.1 or 7, only on a new, clean install of 10.)

Closing the Libraries panel 'solved' the issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 03, 2016 Mar 03, 2016

Copy link to clipboard

Copied

The fix for Mac didnt work for me,

still have 20% Cpu usage for Indesign,Illustrator and photoshop each.


is the cloud going to be like this ? do i have to reserve 30% of the time using it for problem solving? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 03, 2016 Mar 03, 2016

Copy link to clipboard

Copied

I DO NOT understand why this isn't fixed yet? My company has been using Adobe software, primarily Photoshop, Indesign and Illustrator for years. Over 10 years to be exact. Now whenever I or any of my colleagues open an Adobe program I or they get a bunch of "Adobe CEP HTML Engine" processes in task manager. This has been tested with WIN7,8 and 10. With Photoshop the "Adobe CEP HTML Engine" takes a constant 30% of CPU. All the time. With Illustrator you get about 5 instances of "Adobe CEP HTML Engine" drawing CPU and memory.


There are a few workarounds. For Photoshop: disabling "Allow extensions to connect to the internet" and "start screen" from preferences cures the 30% CPU draw. For Illustrator I have yet to find a workaround that is good. Disabling the "start screen" in Illustrator helps, but still I'm left with a few "Adobe CEP HTML Engine" processes running.

Disabling "libraries" also helps, but does not fix the problem. I understand that for example libraries need the Adobe CEP HTML Engine to work, but the CPU and memory consumption is just too much.


BTW: disabling sync in Adobe Creative Cloud DOES NOT fix this. It helps a little bit, but is not a fix.

My question is: Why has this not been fixed yet? I'm sure _ALOT_ of people are suffering from this on a daily basis.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 04, 2016 Mar 04, 2016

Copy link to clipboard

Copied

Here is a solution for win users (maybe have to repeat if the problem comes back) (thanks to Manish)

End all Adobe processes including Creative Cloud (all sub processes), Core Sync, CCLibrary, Adobe Desktop services, Adobe UpdateNotifier, Adobe IPCBroker processes from task manager.

When its done (be sure, no other adobe process left i didnt mentioned, like acrobat updater, AGS etc)

Go to

c:\Users\<user_name>\AppData\Local\Adobe\OOBE\
(or type %LocalAppdata% in run window (Win btn+R))

************** DELETE Opm.db ******************

should work, have fun with your "liberated" CPU time

here, all the CEP HTML processes using 0,1-0,2% now (better than 9-10%), but yeah, still here.. and they are watching me... wáááááááááááá...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines