• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit Search
2

Why aren't my guides showing on the canvas in photoshop?

Contributor ,
Feb 12, 2020 Feb 12, 2020

Copy link to clipboard

Copied

I'm on a pc using photoshop v21.0.2.  When I pull a guide from the ruler onto the canvas, it only shows a little weird line and then disappears until I release it, which doesn't really help me place it exactly where I need it since I can't see where it is.  Any clue as to why it might be doing this? 

 

Thanks,

GS

 

Screenshot_19-PSguides.jpg

Views

2.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Feb 12, 2020 Feb 12, 2020

Hi

Resetting Preferences fixes thing that Reinstall does not. Go to Preferences > General > Reset Preferences on Quit, then quit and relaunch. Be sure to back up anything you've created, such as Brushes, Actions, Swatches, etc.

 

Will "New Guides from Shape" help at all?

~ Jane

 

14.png

 

 

Votes

Translate

Translate
Community Expert ,
Feb 12, 2020 Feb 12, 2020

Copy link to clipboard

Copied

Hi Graphic_Squirrel,

 

I'm sorry that I can't tell you why it's happening — it sounds like it might be an issue with your graphics card, though.

 

When I want to position a ruler guide exactly in Photoshop, I always use View > New Guide and type the number in so nothing is left to chance. In both InDesign and Illustrator, I can select the guide and not only see the position, but can type into the Control panel if I need to reposition it, but not in Photoshop. Photoshop gives me a screen tip, but if my mouse slips while dragging it, then I can't confirm that it's in the right place after the fact.

 

I hope another volunteer can tell you why this is happening. In the meantime, though, my method should help you position your guides where you want them to be until yours is working again.

 

You can also check to see that your graphics card is updated, reset preferences, and update to 21.0.3.

 

~ Jane

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 12, 2020 Feb 12, 2020

Copy link to clipboard

Copied

Thanks for your reply, Jane.  I did update, but it didn't help.  I have asked our IT department for help checking on the graphics card. 

Regarding your method, I need to be able to see where I am placing the guides.  For instance, if I have a circle on the canvas, I want to place a guide on the inside and the outside of the border.  Not sure how I could do that by entering numbers.  My guides are usually used for creating a template so I can copy the same design with different elements several times, keeping the scale consistent across the board. 

Hope I can figure this out.  I really don't want to have to reinstall.  But I have to have those guides working, so we'll see what happens. 

Will try to come back if/when I find an answer.

Thanks again!

GS

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 12, 2020 Feb 12, 2020

Copy link to clipboard

Copied

Hi

Resetting Preferences fixes thing that Reinstall does not. Go to Preferences > General > Reset Preferences on Quit, then quit and relaunch. Be sure to back up anything you've created, such as Brushes, Actions, Swatches, etc.

 

Will "New Guides from Shape" help at all?

~ Jane

 

14.png

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 12, 2020 Feb 12, 2020

Copy link to clipboard

Copied

They're back!  Resetting the prefs fixed the situation, though now I have a completely new interface.  Any clue on how to start the new version without the opening screen?  I just prefer to have the software ready to go.  I tried to do Legacy, but that didn't change anything. 

 

Oh, the guides from shapes didn't work for me because the circle isn't really a shape, just a color on a block.  The guides went to the outside of the block rather than the circle inside the block.  But that is a great new tool I wasn't aware of, so I will definitely find a use for it in the future. 

 

Thank you so much for your help!! 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 12, 2020 Feb 12, 2020

Copy link to clipboard

Copied

You're welcome, Graphic_Squirrel. I'm glad it's working now! 

 

To hide the opening screen, go to Preferences > General. Turn off Auto Show the Home Screen and turn on Use Legacy "New Document" Interface. Look throught the other preferences to see if there is anything else you need to reset.

 

~ Jane

 

7.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 12, 2020 Feb 12, 2020

Copy link to clipboard

Copied

Hello, Is there any scaling in windows?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 12, 2020 Feb 12, 2020

Copy link to clipboard

Copied

I'm not sure what the answer is, but I wanted to say thanks for starting to help me.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 19, 2023 Jan 19, 2023

Copy link to clipboard

Copied

Hi, in Windows please go to Settings/System/Display and report the Scale and Layout setting you see.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 18, 2023 Jan 18, 2023

Copy link to clipboard

Copied

Thank you all for your help.

I had this guide problem as well about 30 minutes ago.

However I will not be resetting my prefs again this week, as I just got my workspace situated about 60 minutes ago (having had to reset my preferences already this week). I guess Adobe just needed to make sure my workspace was all tidied up before dropping this guides thing on me.

 

Whether it's to make guides show up as they are supposed to,
or to mitigate all the weird patterns due to the shift from OpenGL API to Metal API, 
or to make the screen stop turning black everytime I select type...

I AM EXHAUSTED AT RESETTING MY PREFERENCES (and my entire workspace) every time Photoshop decides to surprise me with yet another problematic behavior.

Adobe... why do so many of your weird problems require users to reset preferences? Can you just stop rolling out code till it's actually helpful? For example if Metal API is causing weird patterns and type behavior...

https://community.adobe.com/t5/photoshop-ecosystem-discussions/black-screen-when-editing-text/td-p/1...


...then it's NOT READY, no matter how much you're being pressured to push it out to keep some uninvolved exec. happy. I know it's cool that you can just push out updates any ole' time, but where did quality control go? As UI/UX takes over more of the marketing budgets, and people use more free tools for those things, you're going to have a harder time keeping up as it is, without annoying your current customers. You might stop worrying about 3D and animation (wouldn't use Photoshop for that anyway), and focus instead on making the basics work like they're supposed to.

And yes I know Adobe does not officially read these. One gets the impression they do not read any customer input.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 19, 2023 Jan 19, 2023

Copy link to clipboard

Copied

HEllo, @defaultrltiserbcpap I do not think that Adobe staff is able to read each and every message posted here...

But it there is a Bug report concerning many users, it will cast the spotlights, and they might read every message in the thread.

I will convert this thread in a Bug report since you seem to be affected by the same issue (please report that it is the case, but also list the operating system that you are using, and the version of Photoshop (there is an update to 24.1.1 replicating, you might want to check it)

I know that plenty users report issues being fixed by a preference reset (I prefer to drag the entire folder away (*), in order to keep faulty preferences that could be sent to the team.) Buit there are also millions of other users that do not have an issue. But indeed, maybe should there be an auto versioning of the prefs, to revert to the last working version, and this could be part of a feature request.

 

You can use this document to just remove the preference that seems to be the culprit: https://helpx.adobe.com/uk/photoshop/kb/preference-file-names-locations-photoshop.html )

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 19, 2023 Jan 19, 2023

Copy link to clipboard

Copied

LATEST

Hi Pierre,

 

I wonder if the new post from @defaultrltiserbcpap  yesterday should have been branched from the post from three years ago before you converted it from a bug to a discussion since both issues were solved for the OP in 2020?

 

 

@Graphic Squirrel wrote on 12 February 2020

They're back!  Resetting the prefs fixed the situation, though now I have a completely new interface.  Any clue on how to start the new version without the opening screen? 

 

Cheers

 

Jane

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines