Zoom won't anti-alias, except at 100%

Explorer ,
Nov 10, 2020 Nov 10, 2020

Copy link to clipboard

Copied

 

Up until recently, when I opened an image in Photoshop then viewed it at 100%, it was anti-aliased (without jagged edges). And when I zoomed in/out, I had no problem with anti-aliasing.

But now, when I view an image at any magnification -- except 100% (or 50% or 25%) -- it has jagged edges. Obviously, some setting has changed, but I have no idea which one. 

What I find weird is that I can view any image at any magnification, without aliasing,
in Bridge or my web browser! If anyone can help me sort this out I would much appreciate it.

 

a.JPGb.JPG

 

 

TOPICS
Windows

Views

450

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 09, 2021 Jul 09, 2021

Copy link to clipboard

Copied

I have the exact same problem and dont find any solution 😕

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 09, 2021 Jul 09, 2021

Copy link to clipboard

Copied

When you view zoom to 100% you are viewing your Image actual pixels but most likely not at the resolution you will print the image. The displayed image will be different size then the printed image. However, the pixels displayed have the quality you get from your camera and how well your edit  you image pixels to maintain image quality.  When you zoom to any other percentage you are not viewing your image.   You are viewing a  different image that Photoshop  has created by scaling you image to have a different number of Pixels a different size canvas for you to view.   The scaling  Adobe does zooming is not done for best image quality  using some fancy interpolation method it is done as quickly as possible so zooming will be responsive so you will be happy with Photoshop performance.   At some percentages the image quality  can be quite poor.   However, none of the zoomed images is your actual image. When edit at a zoom percentage how Photoshop applies the edits to your actual image is what counts.  You should never judges a book by its cover you should view the actual book at 100% page view and Print it at print resolution you want to judge the image quality at.

 

If you have a High PPI resolution displaye  with a relolution around 300ppi  you can judge print quality on you display  for the image resolution will be nearly the same printed and on your display.

 

Other Photoshop features do similar things for example when you transform a layer size the image displayed  in the Transform bounding box is a quickly scaled preview. When you commit the transform  you will see Photoshop actually perform the actual transform the image quality will improve and be better them the preview you saw when while you were activity using the tool.

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 09, 2021 Jul 09, 2021

Copy link to clipboard

Copied

Could you please post screenshots with the pertinent Panels (Toolbar, Layers, Options Bar, …) visible? 

 

Does turning off »Use Graphics Processor« in the Performance Preferences (Photoshop > Preferences > Performance > Graphic Processor Settings) and restarting Photoshop have any bearing on the issue? 

Does turning on »Deactivate Native Canvas« (Photoshop > Preferences > Technology Previews) and restarting Photoshop have any bearing on the issue? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 23, 2022 Feb 23, 2022

Copy link to clipboard

Copied

Just wanted to chip in, since updating some point last year, zoom levels are no longer antialiased. This makes gross adjustments VERY uncomfortable to look at and evaluate, as if you're trying to make a colour adjustment to a whole scene you can't do that at 100%.

 

I'm fully aware that "The actual image" can only be evaluated at 100% zoom, my issue here is a quality of life one when making global colour of tone adjustments at 25 % / 16 % zoom where I can see the entire picture.

 

This is a problem in 23.x

This is NOT a problem in 22.4.3

 

Denyerpro_0-1645627057827.png

 


--
This area is intentionally left blank

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 23, 2022 Feb 23, 2022

Copy link to clipboard

Copied

(Acceleration options, native canvas, in various combinations, makes no difference)


--
This area is intentionally left blank

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 23, 2022 Feb 23, 2022

Copy link to clipboard

Copied

Is your GPU recognized and enabled? What does it say under Preferences > Performance < Graphics Processor Settings?

gpu.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 23, 2022 Feb 23, 2022

Copy link to clipboard

Copied

Denyerpro_0-1645654849130.png

And yes, I've tried disabling GPU, disabling native canvas, enabling it with native canvas enabled, disabling both of them, resetting my preferences, and upgrading my graphics drivers.

The problem does not exist on my parallel installation of 22.X, only 23.X suffers.


--
This area is intentionally left blank

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 24, 2022 Feb 24, 2022

Copy link to clipboard

Copied

Denyerpro_0-1645710865252.png

Here you can see various versions and permutations. Look at the hair, specifically on the left side where it's most visible. Windows 10, latest nVidia Studio WHQL drivers, reset preferences and driver defaults.

Desired behaviour is as per 22.x which is the leftmost image.


--
This area is intentionally left blank

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 24, 2022 Feb 24, 2022

Copy link to clipboard

Copied

There's something really odd going on here. If anything, the "off-100%" ratios should be soft, not jaggy. That's what I see here, and I can't remember seeing such a harshly pixelated representation anywhere, at any zoom ratio.

 

This is the kind of thing we saw in Photoshop CS3 and earlier, before the GPU entered the picture at all (pre-OpenGL). Back then, "jaggies" were the #1 complaint. CS4 put an end to that when OpenGL was introduced in Photoshop.

 

I'd post this under "Bugs", and include these screenshots as well as all other techical details. Or maybe a moderator could move it?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 24, 2022 Feb 24, 2022

Copy link to clipboard

Copied

I'm seeing others report similar elsewhere and being told "Work at 100%, it's the only real representation of the image anyway!" by people who should know better. I suspect it's connected to the new-ish Native Canvas code which has alredy caused its fair share of headaches.


--
This area is intentionally left blank

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 24, 2022 Feb 24, 2022

Copy link to clipboard

Copied

Well, I'm not seeing it here.

 

Yes, we do say "view at 100%" and that's still valid if you want to assess the pixel structure of the image.

 

But this isn't about the pixel structure of the image. This is about screen scaling that shouldn't behave like this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 24, 2022 Feb 24, 2022

Copy link to clipboard

Copied

Would it be possible to post a sample file?
Want to be sure I am not missing anything important here... or here are some questions that may help us:

  • Dimensions of Doument and resoltuion. 
  • What Color space is it? sRGB, AdobeRGB
  • 8bit image or 16bit ?
  • Does this file have additonal Layers? If so what are they, Masks, Adjustment layers etc or none? Screen shot of Layers would help.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 24, 2022 Feb 24, 2022

Copy link to clipboard

Copied

Hey there,
It exhibits in any image of any dimensions of any colourspace, most prominently at 25% zoom but present at others. I presume it's worst at 25% as that's the exact 50% NN dimensional reduction yeilding maximum aliasing.

You can check this image plucked randomly from Bing Images  for example: (>5000px long edge) but even resampling it to 1000px long edge yeilds the same result:


https://hairstylehub.com/wp-content/uploads/2018/11/alex-perez-570754-unsplash.jpg

All I have to do is open the file and set zoom to 25%. No additional layers or work done.

Sysinfo here: https://pastebin.com/EHMJSkEw

IDK if CC 23.x is still using 8 bit proxies below 66% zoom, so I don't suppose bit depth would be a factor, however the aliasing is exhibited with 8 and 16 bit files, isn't seemingly affected by colourspace or profile, isn't affected by soft proofing, and isn't affected by the "Desaturate Monitor Colours By 0%" workaround for that odd soft proofing bug that's still kicking around since forever.

As you can see from the screenshots I permuted the canvas and GPU settings without luck, updated nVidia to latest Studio WHQL drivers, updated PS to 23.2.1 and moaned on Twitter. Ran out of ideas after that!


--
This area is intentionally left blank

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 24, 2022 Feb 24, 2022

Copy link to clipboard

Copied

LATEST

Well, I screwed up!
Got myself in a mess between versions while testing and had reset 22 not 23 - Replacing the MachinePrefs.psp file with a clean one removes the fault in 23.x

If a copy of the fouled MachinePrefs.psp file would be useful for diagnostics (Diff doesn't reveal much due to the storage format but might be useful for you?)  let me know - or if it's just a case of  "Problem has gone away so move on", so be it!


--
This area is intentionally left blank

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines