• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Elements Organiser 20 showing question marks instead of thumbnails

New Here ,
Mar 28, 2021 Mar 28, 2021

Copy link to clipboard


I am running Photoshop Elements 2020 on an iMac with OS Catalina Version 10.15.7.  I have recently started from scratch with creating a new catalog after losing most links from the previous version of elements.  I had loaded and tagged nearly 1400 photos but had not yet backed up the catalog.  

Last weekend we had a power loss and on restarting my computer, the organiser showed the catalog on the thumbnail grid page but whenever I double clicked on an image to tag the photo it only shows a grey panel with a white question mark in the middle.  I can still edit the photos in Elements, but I prefer adding the tags in the organiser.

After countless hours of searching and reading on this help board, I have tried the following to fix the issue none of which has worked:

1.  Optimise the catalog;

2. Refresh the catalog;

3.  Repair the catalog - cannot find the repair button - possibly because I hadn't backed up the catalog?

4.  Create a new catalog and import the same photos in as a test;

5.  Delete the previous catalogs;

6.  Restarted my computer;

7.  Uninstalled and re-download and reinstall Elements 2020;

8. Renamed the cache file to 5_old;


 I really don't want to spend any more money upgrading to the latest version on the off chance that it will happen in the next version.


Does anyone have any suggestions to fix this issue?


Thanks in Advance



Problem or error







Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation