• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Photoshop and Premier 2023 will not go beyond 'welcome' screen

Community Beginner ,
Jan 28, 2023 Jan 28, 2023

Copy link to clipboard

Copied

I am running WIndows 11, latest version, with Available Physical Memory 9.54 GB and a couple of Tb free on my hard drive.

I just bought and installed the 2023 products and I cannot get past the 'welcome' screen (see attached). In the install guide it says to press the Photo Editor button to continue. All it does is say it is loading the workspace and then nothing happens.
I have gone through the trouble shooting and I have uninstalled my 2018 products and used the Adobe Creative CLoud Cleaner and restarted my machine a couple of times to no avail.
I have switched off my Norton protection and firewall and reinstalled everything, but again I only get as far as the welcome screen and there are no error messages displayed.
Can someone offer some advice? I have never had an issue installing any of my previous Photoshop releases.
Many thanks in advance.
PS I do have an Adobe account and am signed in. Also I bought the download from the Adobe site and not from Amazon or elsewhere.

TOPICS
Download and install

Views

488

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Jan 30, 2023 Jan 30, 2023

OK. My issues are now resolved. It basically involved uninstalling the 2023 components and then deleting all references to them (I used Revo Uninstaller) and also removing all references to my 2018 version in Program Files and AppData, then reinstalling 2023. Everything now works as it should and the suspected Beta Web component is part of 2023 and the other messages I attached earlier no longer occur.
Great piece of software now that I can use it.
Thanks again for all help and hopefully I will no

...

Votes

Translate

Translate
Community Expert ,
Jan 28, 2023 Jan 28, 2023

Copy link to clipboard

Copied

Try opening directly from Adobe Photoshop Elements 2023.exe.

 

I'm not at my computer with PSE 2023 on it right now, so I can't tell you the exact path, but the path for PSE 2018 is 

C:\Program Files\Adobe\Photoshop Elements 2018.0\WelcomeScreen

 

If that works, make a shortcut on your desktop for it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 28, 2023 Jan 28, 2023

Copy link to clipboard

Copied

Many thanks for the response, Bob, but I have already set up the shortcuts and although I can get the Photoshop Elements Organiser to work it first sends two messages (see attachments)) and organiser will not link to the editor and vice versa.

It says it is loading the workspace but never gets further - just like the home screen.
I am happy to work with the shortcuts and not have the home screen but not having the above linking is a pain. The instant fix works OK.
Thanks again for the quick response.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 28, 2023 Jan 28, 2023

Copy link to clipboard

Copied

I have not seen those error messages before.  I suspect that they have something to do with the Elements Web service which is still considered to be in Beta and is not available to all users.  I think Adobe pushes the feature to the "lucky ones" who get this new feature.  Do you see this option in the Organizer and what happens if you try to use it?

Snap_2023.01.28_12h16m13s_001.png

 

You have tried all of the trouble-shooting that I would have done.  I would suggest  contacting Elements support. You can start a chat session by clicking on the blue Contact Us button under the Help & Support menu at Adobe.com. Or you can contact Support by telephone using the numbers listed here: https://helpx.adobe.com/contact/phone.html. Hours of operation outside of the United States are limited. See the phone link for details.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 28, 2023 Jan 28, 2023

Copy link to clipboard

Copied

thanks Greg,

glad to know I am not just doing something dumb. The 'Upload to Cloud' option is not in my Organiser.

Earlier I  got an error with a message number 199, which when I put it into the 'help' came back with Error Number Not Known - I cannot at present remember where that occurred!
I tried all of the Help & Support options but it was a circular event.

I also tried the 'chat option' which, after several questions and suggestions that were of no use, gave me the option to talk to someone, and then told me that they were closed and to come back another time.

So I really appreciate the support here.


After forking out £130, I do expect things to work far better than this.

 

Thanks again. Have a good weekend.

Les

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 28, 2023 Jan 28, 2023

Copy link to clipboard

Copied

Yes, Les, you will have to wait until Monday to get support in the UK.  If you were able to use the Chat at all, it would only have been a bot.  Live chat is also limited to the support hours in the link.

 

Since you seem to be knowledgeable about computers, you may want to look at the log file found at:  C:\Program Files (x86)\Common Files\Adobe\Installers\Install.log.  It may provide some additional clues. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 29, 2023 Jan 29, 2023

Copy link to clipboard

Copied

Thanks again Greg, looking at the log was interesting but showed no fatal errors, or errors, just three warnings, which may or may not relate to the issue. However I received a mail from Global Support this morning offering to organise a call with me tomorrow morning in order to fix the issue. I will include everything I have stated on the forum and also send the log then go from there.
I will let you know what transpires.
Thanks to all who have responded. I am not usually one for forums, but this one is excellent; giving good advice rather than glib opinions.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 29, 2023 Jan 29, 2023

Copy link to clipboard

Copied

Who is Global Support?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 29, 2023 Jan 29, 2023

Copy link to clipboard

Copied

the mail address was customercare-support@adobe.com if that helps?

 

It was actually 'global customer support' if that makes a difference? I just noticed it at the bottom of the mail.
As stated above, I will report on the conversation, hopefully, tomorrow,

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 30, 2023 Jan 30, 2023

Copy link to clipboard

Copied

LATEST

OK. My issues are now resolved. It basically involved uninstalling the 2023 components and then deleting all references to them (I used Revo Uninstaller) and also removing all references to my 2018 version in Program Files and AppData, then reinstalling 2023. Everything now works as it should and the suspected Beta Web component is part of 2023 and the other messages I attached earlier no longer occur.
Great piece of software now that I can use it.
Thanks again for all help and hopefully I will not darken your doorsteps again.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines