PS Elements won't load after updating my OS

New Here ,
Jan 10, 2022 Jan 10, 2022

Copy link to clipboard

Copied

Hi. I bought and was using PS Elements 2019 and then I updated my Mac to MS Montery (12.0.1). Now it won't load, it just hangs and eventually just quits. I have tried various advice I found on the community pages such as uninstalling, reinstalling, changing profiles etc. 

 

Any further advcie please as I now have a programme I paid £80 for and can't use!

 

Thank you. 

TOPICS
Problem or error

Views

58

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 10, 2022 Jan 10, 2022

Copy link to clipboard

Copied

The advice, a bit late perhaps, is to check for compatibility before upgrading your system. Apple break old apps all the time, it's part of the Joy Of Mac. You can now downgrade the system or upgrade Elements.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 18, 2022 Jan 18, 2022

Copy link to clipboard

Copied

LATEST

The only answer is to upgrade. I was offered a discount but it still would cost $80 so ATM I've decided not to and am using Pixlr as a free alternative. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines