Photoshop Elements 2021 not launching

New Here ,
Jan 19, 2021 Jan 19, 2021

Copy link to clipboard

Copied

I have Photoshop Elements 2021 running on Windows 10 Professional.
I installed PSE2021 in December and I've run it several times with no problem.
Now however, it fails to launch. I click on the icon and I see the hourglass for about 5 seconds and then nothing - no spash screen.
I've also gone to the file location of the icon and clicked on the .exe directly, but no difference.
I opened Task Manager and see that it is active and taking approx. 14% CPU, but I never see the application open.
Should I uninstall PSE2021 and reinstall? I see that some others have tried this to no avail.
Cheers

TOPICS
Bug, Performance, Problem or error, Windows

Views

85

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 19, 2021 Jan 19, 2021

Copy link to clipboard

Copied

j'ai exactement le même problème avec une configuration identique

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 19, 2021 Jan 19, 2021

Copy link to clipboard

Copied

Avez-vous désinstallé et réinstallé? ça a fonctionné pour moi et les commentaires que j'ai lus confirment cette solution, contrairement à ce que dit @default1lbfep6d3z32 .

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 19, 2021 Jan 19, 2021

Copy link to clipboard

Copied

Hi,

 

Please try the below steps to see if this fixes your problem

 

For Windows :

  • Go to the location C:\Program Files (x86)\Common Files\Adobe and then rename the folder named SLCache to SLCacheOLD.
  • Then go to the location C:\ProgramData\Adobe and then rename the folder SLStore to SLStoreOLD. (Note: If you are not able to find the ProgramData folder, then probably it's hidden, to unhide it, you may try this)
  • The above steps are going to reset the preferences of the Photoshop Elements and that is the reason Photoshop Elements will ask to enter the serial number for the product again. Now go to the desktop screen and right click on the Photoshop Elements icon and then click on Run as administrator.
  • Then click on “License this software” and enter the serial number for the product again.
  • Check the program now.

Note: If you are not sure what the Serial number is, then go to http://www.adobe.com  and sign in with your Adobe Id and password. Once you are in then go to Manage Your Account. Then Click on Plans on the top, Under My products (left panel) you should be able to see the serial numbers.

 

You can also try troubleshooting from here

 

Still face any issue, would request you to connect to the Support team directly(https://helpx.adobe.com/in/support.html) and get this resolved.

 

Regards,

Nidhi

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines