Pourquoi la sauvegarde du catalogue de PSE 2019 est impossible ?

Explorer ,
Aug 02, 2019

Copy link to clipboard

Copied

Bonjour,

Je suis utilisateur de plusieurs versions successives de PSE depuis de nombreuses années et j'apprécie, en particulier, les fonctions d'Element Organizer pour gérer des catalogues de photos ou de vidéos.

Depuis quelques mois, j'ai migré PSE 2019 et mes ressources de fichier sur une nouvelle machine Win 10 Pro: CPU Intel i7-9800X 3.8 GHz, 32 Go de RAM. Je n'ai pas rencontré de problème pour faire les sauvegardes totales de mes catalogues sur disque externe depuis cette migration.

Depuis la récente mise à jour 1903 de Windows 10, je rencontre un problème lors de ces sauvegardes de catalogue. Alors que Element Organizer 2019 évalue la taille de la sauvegarde à 238 Go et que le disque externe présente 1150 Go d'espace libre, la sauvegarde totale est impossible. J'obtiens le message suivant: "Espace disque insuffisant: Element Organizer ne peut effectuer cette opération. Supprimez des fichiers pour libérer de l'espace libre".

J'ajoute que j'ai examiné ce disque externe en détail et qu'il semble fonctionner correctement. J'ai même hier libéré l'espace libre de ce disque externe en utilisant une des fonctions annexes de CCleaner.

Par avance je vous remercie de vos suggestions pour résoudre ce problème de sauvegarde totale de catalogue de PSE 2019, apparu depuis la mise à jour semestrielle 1903 de Windows 10.

Bien cordialement,

Daniel T

Daniel-T

Views

391

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

Explorer , Aug 05, 2019
meg576 Explorer , Aug 05, 2019
Bonjour Daniel,I suggested removing only the VIDEO files,  not the photo files. In my case, it was the video files and the video analysis feature that were causing the backup problem. Most of my files were photos so reimporting and reconnecting the video files was fairly easy. Once the video analysis feature was unchecked and  deactivated, my problem was solved.Please refer to this earlier forum discussion:Bug in PSE 2019 Organizer Backup: Include same movies multiple times (140GB instead 40GB) ...

Likes

Translate

Translate
Jump to answer Jump to answer
Adobe Employee ,
Aug 02, 2019

Copy link to clipboard

Copied

Hi Daniel,

Sorry that your Photoshop Elements 2019 catalog backup is failing. That shouldn't be happening, let us help make this right,

To start with, could you please take a look at this article Troubleshoot catalog backup, upgrade of Elements Organizer ​and let us know if that helps?

Thanks,

Akash

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Daniel-T AUTHOR
Explorer ,
Aug 04, 2019

Copy link to clipboard

Copied

Hi Akash,

Thanks for your rapid answer and for your proposal of testing several procedures for allowing the total backup of one of my Elements Organizer 17.0.0.0 catalogues on an external hard disk. Unfortunately, sofar, none of the suggested procedures has been successful. Since I have been unable to perform some suggested procedures, let me list them:

  1. Recconnect all missing files: done, no file missing
  2. Repair and optimize catalogue: done, no error found, optimized
  3. Re-create thumnail cache: done
  4. Turnoff Sync Agent: on my Element Organizer 17.0.0.0 version (in French), I have not found any Edit/Preference/Backup/Synchronisation function! Task Manager does not list ElementsOrganizerSyncAgent in active rocesses nor active services.
  5. Turnoff Auto-Analyser: on my Element Organizer 17.0.0.0 version (in French), I have not found any Edit/Preference/Auto-Analyser Options function! Task Manager does not list ElementsAutoAnalyzer in active processes nor active services.
  6. Turnoff People Recognition: done
  7. Close previous versions of Elements Organizer: on this recent Win 10 machine, only 2019 versions of PSE and PrE have been installed.
  8. Close iTunes: iTunes is not installed on this machine.
  9. Verify catalog foler permission: both the catalog folder and the taget folder for backup have no limitation in reading and writing, at list as shown using Windows Properties of the directories and files. I have also vefified that writing is this folder is possible.
  10. Check the conversion log: although I am not attempting any conversion, but a total backup, I have checked the %temp% directory, situated at C:\Users\$$$$\AppData\Local. As shown on the attached capture of the most recent files present in this folder, I have not found any *.temp file which name woulf include the catalog name.

Temp-Files-2019-08-04_114613.jpg

At this point, I have made no significant progress in enabling the total backup of one of my 5 Element Organizer catalogs.

In advance, I thank you for other suggestions which would be more efficient as well as your comments on the procedures listed above which I have not been able to test.

Daniel-T

Daniel-T

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Aug 04, 2019

Copy link to clipboard

Copied

Hi Dan

Had the same problem as have others in the forum. My hardware and O/S is similar to yours. My solution to the problem was to temporally remove all the video files from the catalogue (not from the hard drive)  Go to Preferences (in the Organizer) - open media analysis and uncheck the video analysis box.  Restart the computer and run a full  backup.  This is the solution that worked for me but I can't say it will works for every backup failure problem.

From a previous forum question:

ChristianFromLaatzen

Correct Answer by ChristianFromLaatzen on Mar 2, 2019 4:46 PM

Following was the solution:

  • Deactivate video analysis in the options (German: "Voreinstellungenen" -> "Medienanalyse" -> "Analyse Optionen" -> "Videos"
  • delete the videos from the catalog (not from the hard disk)
  • reimport the videos without video analysis

Nor the videos are not split into scenes and the backup does not include duplicates 🙂

Thank to all for your help!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Daniel-T AUTHOR
Explorer ,
Aug 05, 2019

Copy link to clipboard

Copied

Hi Meg576,

Thanks for your proposal for solving my Adobe Elements Organizer 17 Catalog backup issue. If I understand you correctly, you suggest to remove all files from the catalog, which is going to become empty, restart the computer and Adobe Organizer software. Then using the detect function of the Organizer, reconnect all these files to the catalog.

Such a procedure is equivalent to rebuilding completely the catalog, a task which is especially long when you have a large number of photo and video files (17000 in the catalog that I wish to backup). Such a task becomes extremely long if the folders involved in this catalog are not centralised inside a general folder but spread into a large number of folders (probably more than 100 in my case). I have already performed such a long task when I recently changed my mainframe and transfered all photo and video files, as well as catalogs. It takes several work days to fulfill and I have observed that it creates errors in titles or tags, like geolocalisation ones. Thus, I am not very happy to reiterate such a procedure for all my photo and video catalogs.

Finally, all my Element Organizer catalog backups worked perfectly... till the last semestrial Windows 10 1903 update. I am not willing to reiterate such file general deconnection and reconnection procedure every 6 month... because of some Microsoft added function. I would much prefer that Adobe staff, in charge of Element Organizer 17.0 (the last version), find an alternative to such a catalog recreation procedure.

Please let me know if I understood correctly your suggested proposal and let me know if you have read alternative proposals which solved such a Element Organizer catalog backup issue.

Sincerely,

Daniel-T

Daniel-T

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Aug 05, 2019

Copy link to clipboard

Copied

Bonjour Daniel,

I suggested removing only the VIDEO files,  not the photo files. In my case, it was the video files and the video analysis feature that were causing the backup problem. Most of my files were photos so reimporting and reconnecting the video files was fairly easy. Once the video analysis feature was unchecked and  deactivated, my problem was solved.

Please refer to this earlier forum discussion:

Bug in PSE 2019 Organizer Backup: Include same movies multiple times (140GB instead 40GB)

Correct Answer by ChristianFromLaatzen on Mar 2, 2019 4:46 PM

Following was the solution:

  • Deactivate video analysis in the options (German: "Voreinstellungenen" -> "Medienanalyse" -> "Analyse Optionen" -> "Videos"
  • delete the videos from the catalog (not from the hard disk)
  • reimport the videos without video analysis

Now the videos are not split into scenes and the backup does not include duplicates 🙂

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Daniel-T AUTHOR
Explorer ,
Aug 05, 2019

Copy link to clipboard

Copied

Hi Meg576,

Thanks for your clarification above: obvoiusly disconnecting video files is much more easy and rapid than disconnecting photo files distributed within numerous folders. I shall check your suggestion and let you know the result.

In the meanwhile, I have gone through disccussion threads on this catalog backup issue within this forum, especially a discussion stated by emd490203 Elements Organiser says not enough space on my HDD for backup.​ on 28 May 2019: https://forums.adobe.com/message/11107880#11107880

Within this discussion, I noted suggestion by aaron_vijayan Elements Organiser says not enough space on my HDD for backup.​:

@Hi Ed,

Aaron here, and I'll be happy to help you out with this issue. Could you please attempt the following and share your findings?

1. Please try taking a backup of a smaller catalog (a couple hundred images, few videos) onto the same drive, so that we can identify if you're facing an issue with this catalog or with backup in general.

2. Please take a backup of this catalog onto another drive which has the requisite free space, and then copy this backup onto your "E:\". Is the copy successful or not?

3. Adding to point 2, please attempt to copy general files from other drives to your "E:\" so we can identify if this is an EO issue or an OS issue. perhaps.

Looking forward to your response.

Warm regards,

Aaron

Indeed, I succeeded in acheiving a full backup on the same selected external HDD of a small 17.0 Element Organizer calalog containing mostly photo files: total backup folder size = 6.57 Go, 2126 files (external HDD free space: 1.15 Tb). This indictes that my backup issue may be, as you suggested, due to video files much present in the catalog that I fail to backup.

I have also noted, within the same discussion thread https://forums.adobe.com/message/11107880#11107880 a suggestion by MichelBParis :

@I suspect there may be a catalog AND OS issue with drive E:

In short, it may be a situation like one I had several times while testing backups with USB sticks. The backup process seemed to work well but in fact it did only backup the catalog and tly files and skipped all media files. The needed space shown before the backup reflected the size of the catalog. A backup to a normal USB external hard drive, followed by a copy on the stick was successful.

Recently, I had the same issue with a backup on a normal USB external drive. This led me to have a look at the catalog with an sqlite utility, and I discovered that editing the volume_table to set the external drive as 'builtin_drive' instead of 'removable_drive' solved my problems. Apart from the backup issue, my external drive did work exactly as expected. I don't know how and when this drive got the wrong drive description (probably the result of many experments on catalogs on my part...) but I think it's possible that in this case the E: drive is not correctly labelled when the organizer fetches the drive data from the OS.

Since i am not used to sqlite utility which appears quite complex (https://sqlite.org/index.html), I am unable to chexk the involved external HDD and see if "the volume_table has set the external drive as 'builtin_drive' instead of 'removable_drive' ". Thus, I am ready to receive some instructions from MichelBParisfor making such a check and possibly a modification of the 'volume_table'.

In advance, I thank participants to this PSE discusion forum for valuable help, suggestions and assistance.

Sincerely,

Daniel-T

Daniel-T

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Aug 06, 2019

Copy link to clipboard

Copied

Daniel-T  wrote

Hi Meg576,

I have also noted, within the same discussion thread Re: Elements Organiser says not enough space on my HDD for backup.  a suggestion by MichelBParis  :

@I suspect there may be a catalog AND OS issue with drive E:

In short, it may be a situation like one I had several times while testing backups with USB sticks. The backup process seemed to work well but in fact it did only backup the catalog and tly files and skipped all media files. The needed space shown before the backup reflected the size of the catalog. A backup to a normal USB external hard drive, followed by a copy on the stick was successful.

Recently, I had the same issue with a backup on a normal USB external drive. This led me to have a look at the catalog with an sqlite utility, and I discovered that editing the volume_table to set the external drive as 'builtin_drive' instead of 'removable_drive' solved my problems. Apart from the backup issue, my external drive did work exactly as expected. I don't know how and when this drive got the wrong drive description (probably the result of many experments on catalogs on my part...) but I think it's possible that in this case the E: drive is not correctly labelled when the organizer fetches the drive data from the OS.

Since i am not used to sqlite utility which appears quite complex (https://sqlite.org/index.html), I am unable to chexk the involved external HDD and see if "the volume_table has set the external drive as 'builtin_drive' instead of 'removable_drive' ". Thus, I am ready to receive some instructions from MichelBParis for making such a check and possibly a modification of the 'volume_table'.

In advance, I thank participants to this PSE discusion forum for valuable help, suggestions and assistance.

Sincerely,

Daniel-T

To check if you have the same drive identification issue when you are not at ease with sql, the simplest way would be to share your catalog.pse17db file via a web storage service like dropbox or wetransfer (it does not contain thumbnails).It would be best if an Adobe employee asked you to do so. Even if I could tell you if it's the same issue as I had, I could not help more because I have no insight into the program itself.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Daniel-T AUTHOR LATEST
Explorer ,
Aug 06, 2019

Copy link to clipboard

Copied

Hi Michel,

Thanks for your proposal. As mentioned on the message that I just posted, the suggested procedure made by meg576​ was correct and allowed me to solve my Element Organizer calalog backup issue. Thus, I do not fell the necessity of going further into the attributes of my USB external drive.

Anyhow I greatly appreciate your numerous comments and suggestions within this PSE discussion forum.

Sincerely,

Daniel-T

Daniel-T

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Daniel-T AUTHOR
Explorer ,
Aug 06, 2019

Copy link to clipboard

Copied

Hi Meg576,

Congratulations: your suggestion was the good one! i succeeded in acheiving the full backup of my Element Organizer 17 Catalog on the same external HDD, although I had always the message "not enough space on this (backup) disk". Just a few words of the steps that I followed:

  1. I finally found the French equivalent of deactivate video analysis, within Preference oftions and deactivated this function.
  2. Following your suggestion, I disconnected from the catalog almost all video files and restarted the machine;
  3. I imported all video files back into the catalog and attempted the full backup operation: it worked perfectly on the same HDD than previously tested.

Thus I am very gratefull for your suggestions and clarifications.

At this time, I have still 2 questions for those who either know well Element Organizer 10.0 or have developped its software:

  1. This backup issue appears as a "bug" within Element Organizer sofware version 17.0. Such a "bug" should be first well advertised by Adobe and then solved by Adobe staff, as rapidly as possible.
  2. Why is it that this "bug" appeared after the semestrial Windows 10 update 1903?

Again my warmest thanks to meg576​ as well as to all those who contributed to this discussion thread. This demonstrates clearly the benefits of this discussion forum!

Daniel-T

Daniel-T

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more