Highlighted

Perspective Warp Option greyed out

Explorer ,
Jan 16, 2014

Copy link to clipboard

Copied

I'm eager to try out the new perspective warp feature of the latest Photoshop update but the point is greyed out in the menue and I can't figure out how to activate it ("use graphic processor" is turned on in the preferences). I have tried it with a merged image file, with a seperate layer active, with a selection active - no luck.

Does anyone else have this problem? 

Adobe Community Professional
Correct answer by Jeff Arola | Adobe Community Professional

I had the same problem on my mac, so i looked at the Advanced Settings under Use Graphics Processor

and had to enable Use Graphics Processor to Accelerate Computation and then Perspective Warp worked.

Restart photoshop after changing those settings.

TOPICS
Problem or error

Views

80.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Perspective Warp Option greyed out

Explorer ,
Jan 16, 2014

Copy link to clipboard

Copied

I'm eager to try out the new perspective warp feature of the latest Photoshop update but the point is greyed out in the menue and I can't figure out how to activate it ("use graphic processor" is turned on in the preferences). I have tried it with a merged image file, with a seperate layer active, with a selection active - no luck.

Does anyone else have this problem? 

Adobe Community Professional
Correct answer by Jeff Arola | Adobe Community Professional

I had the same problem on my mac, so i looked at the Advanced Settings under Use Graphics Processor

and had to enable Use Graphics Processor to Accelerate Computation and then Perspective Warp worked.

Restart photoshop after changing those settings.

TOPICS
Problem or error

Views

80.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 16, 2014 1
Adobe Community Professional ,
Jan 16, 2014

Copy link to clipboard

Copied

I had the same problem on my mac, so i looked at the Advanced Settings under Use Graphics Processor

and had to enable Use Graphics Processor to Accelerate Computation and then Perspective Warp worked.

Restart photoshop after changing those settings.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 16, 2014 10
Explorer ,
Jan 16, 2014

Copy link to clipboard

Copied

Thanks man! That worked perfectly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 16, 2014 0
Participant ,
Jan 16, 2014

Copy link to clipboard

Copied

Enabling Use Graphics Processor to Accelerate Computation didn't work for me.  I'm wondering if Perspective Warp is a feature that requires a higher spec graphics card.  I haven't seen any reference to that in any of the release info for 14.2.  (My graphics card has only 256 gb onboard ram)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 16, 2014 1
Adobe Community Professional ,
Jan 16, 2014

Copy link to clipboard

Copied

Yes, i believe you need to have at least 512 mb of vram for all the advanced gpu features like perspective warp to work.

Actually 512 mb of vram has always been the minimium requirement for photoshop cc, although some of the gpu features still work with only 256.

more info:

https://helpx.adobe.com/photoshop/using/perspective-warp.html

https://helpx.adobe.com/photoshop/kb/photoshop-cs6-gpu-faq1.html

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 16, 2014 0
Participant ,
Jan 16, 2014

Copy link to clipboard

Copied

Actually, it turned out the problem I was having related to the image mode.  Evidently, Perspective Warp only works on 8-bit images and the menu option is grayed out for 16-bit images.  Once I changed the images to 8-bit, Perspective Warp works fine. 

Thanks for the input. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 16, 2014 1
Participant ,
Jan 17, 2014

Copy link to clipboard

Copied

As a follow-up to this discussion, I was contacted yesterday by one of the PS engineers.  He confirmed that with my system's 256 mb vram, Perspective Warp will be disabled when working on images in 16/32-bit mode and enabled for images in 8-bit mode.  Users with the recommended 512 mb of vram will be able to use Perspective Warp on 16/32-bit images.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2014 0
Explorer ,
Jan 22, 2014

Copy link to clipboard

Copied

I have an NVIDIA GeForce GT 120 card with 1GB RAM in my MacPro. I can check "Use Graphics Processor," but when I click Advanced Settings, both "Use Graphics Processor to Accelerate Computation" and "Use OpenCL" are grayed out.

Perspective Warp is grayed out even with 8-bit images.

Am I right in assuming that this card simply won't support Perspective Warp because it doesn't support OpenCL?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 22, 2014 0
Jan 22, 2014

Copy link to clipboard

Copied

GT120's got blacklisted for perspective warp due to bugs in that graphics card.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 22, 2014 0
New Here ,
Mar 13, 2014

Copy link to clipboard

Copied

Hi have a Toshiba Windows7 with Intel HD Graphics Card and under the Advanced Settings both "Use Graphics Process to Accelerate Computation" and "Use OpenCL" are greyed out.  Does this graphics card support Perspective Warp?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 13, 2014 0
New Here ,
Jun 26, 2019

Copy link to clipboard

Copied

Rasterize the layer. I found that after trying all these things I also needed to rasterize the Text layer I was attempting to use the Perspective Transformation on.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2019 1
New Here ,
Nov 07, 2019

Copy link to clipboard

Copied

This worked straight away - thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2019 0
New Here ,
Nov 16, 2017

Copy link to clipboard

Copied

Hi, thanks for the input.  However, where do I find Advance Settings?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2017 0
Adobe Community Professional ,
Nov 16, 2017

Copy link to clipboard

Copied

Preferences > Performance > Advanced

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2017 4
New Here ,
Mar 07, 2018

Copy link to clipboard

Copied

YAAAAAAAASSSSS THANK YOU SO MUCH

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2018 0
New Here ,
Sep 15, 2020

Copy link to clipboard

Copied

Yey, Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2020 0
New Here ,
Nov 02, 2014

Copy link to clipboard

Copied

I was only just using it yesterday for the same image types using the exact same laptop, etc. and now today it's greyed out.
In relation to other peoples posts about the graphic processing, I'm wondering if it's because yesterday I had my laptop plugged into mains, and right now it's not (my settings change CPU usage, etc. when running only off battery).
I just tried plugging it back in, but to no avail; restarting PS while plugged in - ditto; then looked back in my preferences and found some of the graphics settings switched off - maybe it turns them off automatically when starting PS whilst unplugged?
Switched them back on, restarted PS and everything's fine again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 02, 2014 0
New Here ,
Jun 10, 2015

Copy link to clipboard

Copied

Someone just gave me another solution that worked. Turn the layer into a smart object. (I tried that and it didn't work.) Then turn the smart object into a smart object. That worked for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2015 3
New Here ,
Dec 07, 2016

Copy link to clipboard

Copied

None of the other solutions worked for me even with more than enough VRAM and settings checked, 8 bit image... but doing the smart object twice WORKED!!! Thank you!!! This is has to be a bug in Photoshop.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 07, 2016 0
Community Beginner ,
Jul 20, 2015

Copy link to clipboard

Copied

Yesterday, perspective warp was functioning. Today it isn't. I've tried every suggestion on this thread but nothing has worked. I'm running PS CC 2015 on a new Dell Inspiron. The OS is Windows 8.1. I've allocated 60% of vram to PS, the Graphics Processor box is checked and my graphics card is Intel HD Graphics 4400. Still nothing. Does anyone have any suggestions? Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 20, 2015 2
New Here ,
Jan 18, 2016

Copy link to clipboard

Copied

If you have any layers LINKED, the WARP option will be grayed out. It took me a long time to figure this out, b/c you can transform layers all the other ways if linked. Hope this helps someone!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 18, 2016 0