Highlighted

Photoshop CC 'Middle Eastern Features' is disabled on Mac

Explorer ,
Jun 21, 2015

Copy link to clipboard

Copied

I just downloaded the trial version of CC on my Mac and when I try Type-->Language options, 'Middle Eastern Features' is disabled.

Any idea how I can enable this? I have to type in Persian.

Thanks a lot!

Views

41.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Photoshop CC 'Middle Eastern Features' is disabled on Mac

Explorer ,
Jun 21, 2015

Copy link to clipboard

Copied

I just downloaded the trial version of CC on my Mac and when I try Type-->Language options, 'Middle Eastern Features' is disabled.

Any idea how I can enable this? I have to type in Persian.

Thanks a lot!

Views

41.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jun 21, 2015

Copy link to clipboard

Copied

Did you first go to Photoshop CC>Preferences>Type and check Middle Eastern and South Asian?

more info:

Photoshop Help | Arabic and Hebrew type | CC, CS6

me.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 21, 2016

Copy link to clipboard

Copied

This doesn't work in Photoshop CC 2015 (MAC). Why is that? It is still disabled. I know this is an old post, but do you have any idea how to make this work? This is frustrating. Photoshop CC 'Middle Eastern Features' is disabled on MacPhotoshop General Discussion

Screen Shot 2016-03-21 at 5.03.36 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Mar 25, 2016

Copy link to clipboard

Copied

After you change the Text Engine Option to Middle Eastern, you should restart photoshop cc 2015 and then open a new document.

Photoshop CC>Preferences>Type



per.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 13, 2019

Copy link to clipboard

Copied

Hi, I am facing a same kind of problem, after selection Arabic font, it is coming in English ever after changing the Type from East Asian to Middle Eastern and South Asian. Unfortunately in all the adobe software it is showing in same way (English text but Arabic fonts). Request you for a quick solution on this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Oct 13, 2019

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 28, 2019

Copy link to clipboard

Copied

برای حل  مشکل فارسی نوشتن در فتوشاپ و ایلوستریتور می توانید مسیر زیر را با دقت انجام دهید یا مشکل خود را بیان کنید

https://danialtaherifar.ir/farsi-type-photoshop-2019-2020/

-------
Danial Taherifar | SEO Consultant & Graphic Lover
My Blog : https://danialtaherifar.ir

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 21, 2020

Copy link to clipboard

Copied

این تو فتوشاپ 2020 جواب نمیده 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 21, 2020

Copy link to clipboard

Copied

had the same problem . these options already in the internet are not working in adobe 2020 . I fixed it by chnging language to world ready layout in the paragraf section . yoy should do it in paragraf section only 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...