Photoshop Preference: "Use Graphics Processor" is greyed out on MacBook Pro

New Here ,
Feb 12, 2020 Feb 12, 2020

Copy link to clipboard

Copied

Adobe Photoshop > Preferences > Performance > Graphic Processor Settings is unable to detect information and the option to Use Graphics Processor is greyed out.

 

I have a brand new 2019 MacBook Pro 16" loaded with every possible option available. This was the fastest laptop a human can buy. I paid extra for the AMD Radeon Pro 5500M 8 GB of GDDR6 memory.

 

Video Cards
AMD Radeon Pro 5500M 8 GB GPU PCIe
Intel UHD Graphics 630 1536 MB GPU Built-In

 

Is this insufficient for Photoshop to enable "Use Graphics Processor"?


I'm just trying to replace the artwork on a layer in a PSD mockup file.

TOPICS
Mac, Problem or error

Views

1.8K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 12, 2020 Feb 12, 2020

Copy link to clipboard

Copied

i have the same  question!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 13, 2020 Feb 13, 2020

Copy link to clipboard

Copied

Hello, which version of Photoshop are you using? 21.0.3?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 13, 2020 Feb 13, 2020

Copy link to clipboard

Copied

(and I did resist posting to send me the laptop for troubleshooting)

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 13, 2020 Feb 13, 2020

Copy link to clipboard

Copied

Yes, I'm using Photoshop version 21.0.3 macOS Catalina Version 10.15.3

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 13, 2020 Feb 13, 2020

Copy link to clipboard

Copied

https://helpx.adobe.com/photoshop/kb/troubleshoot-gpu-graphics-card.html 

You have two conflicting graphics cards.

Disable one of them (see #7 on the page):

"Multiple graphics cards with conflicting drivers can cause problems with GPU-accelerated or enabled features in Photoshop. For best results, connect two (or more) monitors into one graphics card.

If you must use more than one graphics card, remove or disable the less powerful cards. For example, assume that you have two different cards using two different drivers—an NVIDIA graphics card and an AMD graphics card. In this case, ensure that Photoshop has been assigned the High Performance graphics card rather than Integrated Graphics or Power Saving graphics card."

 

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 13, 2020 Feb 13, 2020

Copy link to clipboard

Copied

It sounds like you're MacBook Pro is not automatically switching from integrated graphics to descrete graphics.

 

Check the Automatic Graphics Switching setting in the Energy Saver System Preferences Pane.

 

Set graphics performance on MacBook Pro

https://support.apple.com/en-us/HT202043

 

There's a menu bar app for macOS called gfxCartStatus that I use on my 2013 15-inch Retina MacBook Pro to monitor the which graphics option is in use ("i" shows for integrated GPU and "p" shows for discrete GPU).  I'm not sure if it's updated for macOS 10.15 Catalina or not.

 

gfxCardStatus

https://gfx.io

 

 

 

-Warren

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 16, 2020 Feb 16, 2020

Copy link to clipboard

Copied

Any luck getting this resolved with disabling the Intel graphics?  I saw in othe threads here that switching from Metal to OpenGL works too.  I am looking at this laptop and question Adobe's support of the "M"obile version of the 5500.  I ran into that on an old Intel laptop and couldn't do some of the 3D editing because of it.  I hope to hear you are working.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

Hey Zach,

I have the same computer and am currently running into the same issue. Were you ever able to resolve this and if so, how did you do it?

 

I personally attempted to fix it by disabling automatic switching, but that did not work even after reset. Any ideas anyone? I'm at a loss.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines