Highlighted

Polygon Lasso Tool Closes Selection at Random

Explorer ,
Nov 05, 2013

Copy link to clipboard

Copied

I am experiencing the same Polygon Lasso glitch that has been brought up by several others; however, I haven't seen a solution.  I'm posting again JUST IN CASE someone new sees this and can share how they may have overcome this frustrating issue.

Here’s the problem: Polygon Lasso decides to close the selection FOR NO REASON AT RANDOM.

Let me clarify that I am an advanced Photoshop user (certified expert by Adobe).  I know all Photoshop tools inside and out and this is DEFINITELY not user error. Photoshop CC is glitching and it needs to be fixed.  Thing is, this only started for me very recently; within the last few weeks.  (Kinda close to when I updated to Mavericks on my mac but I’m not sure that has anything to do with it)  

To re-iterate, this is NOT a double-clicking issue or anything done wrong by me. Making lots of small lassos joined by the shift key is also NOT a solution.  Switching to the pen tool is also NOT a solution because my workflow depends on the speed of the lasso tool.

The real reason why I’m bringing this up is mostly because, like I said, this is only a recent problem.  Was there just an update to Photoshop CC that would have caused this? It’s driving me crazy and putting a serious hiccup in my workday since the polygon lasso is such a key tool. 

Views

22.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Polygon Lasso Tool Closes Selection at Random

Explorer ,
Nov 05, 2013

Copy link to clipboard

Copied

I am experiencing the same Polygon Lasso glitch that has been brought up by several others; however, I haven't seen a solution.  I'm posting again JUST IN CASE someone new sees this and can share how they may have overcome this frustrating issue.

Here’s the problem: Polygon Lasso decides to close the selection FOR NO REASON AT RANDOM.

Let me clarify that I am an advanced Photoshop user (certified expert by Adobe).  I know all Photoshop tools inside and out and this is DEFINITELY not user error. Photoshop CC is glitching and it needs to be fixed.  Thing is, this only started for me very recently; within the last few weeks.  (Kinda close to when I updated to Mavericks on my mac but I’m not sure that has anything to do with it)  

To re-iterate, this is NOT a double-clicking issue or anything done wrong by me. Making lots of small lassos joined by the shift key is also NOT a solution.  Switching to the pen tool is also NOT a solution because my workflow depends on the speed of the lasso tool.

The real reason why I’m bringing this up is mostly because, like I said, this is only a recent problem.  Was there just an update to Photoshop CC that would have caused this? It’s driving me crazy and putting a serious hiccup in my workday since the polygon lasso is such a key tool. 

Views

22.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 05, 2013 3
Enthusiast ,
Nov 16, 2013

Copy link to clipboard

Copied

I have the exact same problem and its driving me mad.

I use a Wacom, this is the reason why it occurs. I assume its the same for you ? It doesnt happen with a mouse.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2013 1
New Here ,
Nov 19, 2013

Copy link to clipboard

Copied

I have the same issue as well. I'm also an advanced PS user and architectural illustrator, so the polygon lasso is absolutely essential to my workflow. I use an older Wacom Cintiq - the first 21UX model. I'm wondering if there is a compatibility problem with Maverick and my Cintiq. I've gone through every troubleshooting suggestion posted on Adobe's PS FAQ page, uninstalled and reinstalled the Cintiq driver, and uninstalled and reinstalled PS, made sure my OS and PS are up-to-date...without any change. The lasso tool continues to malfunction.

In addition to the lasso tool bug, I'm also experiencing a strange hotkey lag. I'll increase/decrease brush size, undo, or try to change a tool, and the program won't respond. I have to tap the screen or undo using the history window to make things happen.

Both bugs happen at random. I'll go about my business of selecting and everything will go as planned. Perhaps two or three selections in, the lasso tool quits on me and autoselects. Likewise with my hotkeys, although not as frequent.

Photoshop is an integral part of my livelihood. My work is slowed by about 50-60% because of these bugs and no one seems to have a solution. There is no workaround. There must be a solution out there somewhere. I fear I'm going to have to shell out another $2500 for a new Cintiq. Is anyone using a newer Wacom model and experiencing the same problem?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 19, 2013 0
Enthusiast ,
Nov 19, 2013

Copy link to clipboard

Copied

Yep, that´s another one of the bugs that I also started experiencing after the Mavericks upgrade - that the hotkeys suddenly don´t work and I have to manually click the button. I just haven´t copmplained about it yet, as the Polugonal Lasso and Blank menus are on top of my priority list of NEED-TO-BE-FIXED-ASAP bugs.

I´m guessing everyone with a Mavericks,  Photoshop and a Wacom Tablet have to live through these painful bugs every day And, I haven´t seen any interest from Adobe the last days on any of these threads. As if they gave up trying to fix this.

Mckenziedesign, Don´t go out and buy a new Cintiq hoping to fix any of these bugs. I have a Wacom Cintiq 22HD, and I also have a Intuos 5 - I got the same problems as you have on both. - and I´ve tried every thing you mention here as well.

ADOBE? are you looking into these bugs. How do we get your attention?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 19, 2013 1
New Here ,
Nov 19, 2013

Copy link to clipboard

Copied

Donbarrum, thanks for the quick reply. Sorry to hear I'm not the only one out there with the same issues, especially since they seem to be cross-platform. I've scanned a few Adobe PS forum threads hoping for some answers, and the problems with hotkeys and poly lasso go back to March 2013 [and an outlier from 2012] and have affected both Mac and PC users. Super sorry to hear it's a problem for all Wacom users too. Please let us know if you have any luck resolving this in the future.

Planning on calling Adobe tomorrow. This bug is unacceptable from a service I pay a premium for.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 19, 2013 0
Enthusiast ,
Nov 19, 2013

Copy link to clipboard

Copied

So, you are not using Mavericks ? I thought the polygonal lasso bug was Mavericks only. If it isn´t at least it´s something that isn´t up to Apple to fix (that could take a while, since the disappearing mouse pointer in OSX has been a problem for years and finally gone with Mavericks for some reason).

Anyway, please let me know if you find a solution too, Polygonal Lasso tool is one of the tools I´m quite dependent on, and any tips that could fix it would really make my life easier.

I fear its a wacom driver bug. Because it happens only with the Wacom tablet (though you kinda feel the shortcut bug and the lasso tool is related some how - it´s like the program suddenly refuse to take in input). But since both Adobe and Wacom claims their software is Mavericks tested and approved it´s impossible to know if they even think this is a problem worth looking into.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 19, 2013 0
Enthusiast ,
Nov 24, 2013

Copy link to clipboard

Copied

Hey mckenziedesign, just checking up. Did you call apple? - did they have any tip on how to resolve these issues. The keyboard shortcut lags, the polygonal lasso tool and the white menus in Mavericks are all making it extremely difficult to work. And as it seems Adobe don´t care to read or reply to complaints in these forums.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 24, 2013 0
New Here ,
Dec 19, 2013

Copy link to clipboard

Copied

Hi folks. I have Wacom intuos 3, Mavericks and all of the above problems also. Plus after an hour or so, the lasso stops functioning all together. The button selects but left click is not recognised when trying to select. Fixes on software restart. All becoming a real nuisance.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2013 0
New Here ,
Jan 17, 2014

Copy link to clipboard

Copied

Has anyone here heard anything yet??  My wifes studio updated to CC and have all these problems too.  I'm about to drop the cash for a cintiq myself (working as a consultant) and all these issues make me very nervous.  I pay for CC and I'm hoping I won't have to buy and older copy of Photoshop just to be productive.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2014 0
Explorer ,
Jan 17, 2014

Copy link to clipboard

Copied

Nope, still at a loss.  HOWEVER, Adobe did just put out a fairly big update to cloud apps this week.  Hopefully I'll get to see if this affects the problem at all. 

I'm not sure that using an older Photoshop will actually fix things (though I haven't tried).  Problem seems to completely be in the Wacom drivers.  Whether it's because the drivers don't work perfectly with Mavericks or it's someting else, I don't know. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2014 0
Enthusiast ,
Jan 17, 2014

Copy link to clipboard

Copied

Nope, haven´t heard anything. I´m guessing (hoping) adobe has it on its list of "stuff they are looking into". At least that´s pretty much my only hope - though I´m suspecting this as well as the keyboard problems probably has others to blame. But, contacting Apple for anything like this feels completely hopeless. And Wacom just doesn´t care and just plays the blaming card....So, let´s hope we´ll hear something from Adobe soon, and they can point the others in the right direction.

....................................

Just some personal impressions, a bit off topic:

I have a feeling that Mavericks are full of problems and Apple is only fixing minor stuff and doesn´t seem to understand or are aware of the major stuff (not that I know how to make them care either). Because as it is right now, it seems installing Mavericks gives you a lot less optimized machine - except for battery (if you have a laptop) and apart from that it only gives you a few minor OS features that are barely anything to speak of. But in general, my machine got out of ram more quickly, I noticed hickups all over the place. F.example in games, like League of Legends, there were interwals of stuttering, as if the machine was overloaded or something - and don´t get me started on the problems in Photoshop . And a couple of times my machine crashed because ram usage boiled over. And that is with 32 GB of ram (!!) and a maxed out top of the line late 2012 iMac. After I reverted to Mountain Lion, it felt like installing a new operating system. Everything was smooth and I feel I can throw everything I want at the machine again and it will handle it with ease. I recently worked on an image that had about 100 layers and a resolution of 75.000 pixels width - I can only imagine how Mavericks would completely explode my machines ram on that. Sadly though Mavericks is suppose to be an upgrade and eventually I will have to catch up - as Apple is all ready making new updates to their suites working only on Mavericks...but right now it brings very little to the table except problems and frustration...unless you are dependent on battery lifetime I can´t see what you really gain from it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2014 0
Explorer ,
Jan 23, 2014

Copy link to clipboard

Copied

ok everyone, I can officially confirm that reverting back to Mountain Lion has fixed this problem!! Photoshop CC on Mountain Lion with the Mountian Lion Wacom drivers works perfectly for me. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 23, 2014 1
Community Beginner ,
Jan 23, 2014

Copy link to clipboard

Copied

It is all about Mavericks. I first experienced the lasso tool issue with CS6 after upgrading to Mavericks so I decided to test it in CC, same problem. Im going to downgrade as well!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 23, 2014 1
New Here ,
Jan 24, 2014

Copy link to clipboard

Copied

Good news. Thanks for the follow up guys.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 24, 2014 0
Community Beginner ,
Jan 18, 2020

Copy link to clipboard

Copied

I have the same problem in PSE 19 on brand new WIN 10 fully updated. I've tried all of the suggestions in the forum there is no problem with my computer with 32gb RAM, AMD Ryzen 7 3700x8Core processor, 64 bit. Win 10 up to date, PSE 19 uninstalled and reinstalled a few days ago. All preferences reset today. The polygonal lasso when it starts it starts in some random place, not where I click. Usually it doesn't start at all, but when it does I can only draw two lines before it closes. I have tried double and single clicking, firmly, softly and in between. I have tried doing it the way I have done ever since PSE4 and Photoshop 6 without any problems. I have unplugged my Intuos 5, tried four different mouses.Why now? This problem has been happening for several years according to posts here. It MUST be a programme problem. I know someone just changed their mouse and that worked but I've tried four. Somebody please give me some hope I used this tool as often as I use my brushes. I need it every day.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 18, 2020 0
New Here ,
Feb 24, 2014

Copy link to clipboard

Copied

I've been experiencing this problem for quite some time too, though I can't be completely sure if it's specific to Mavericks.

What I can assertain is that there is some lag happening with the Wacom Driver - it could be that the driver is not optimized for Mavericks. I get the lag when using the Clone Tool as well. I've configured one of the pen buttons to select clone source, but when I select and then start painting too quickly the source is selected a lot closer to where my cursor ends up, not when I originally clicked.

Hence I'm also suspecting that there is a lag when using the polygon lasso, so that Photoshop is registering two clicks closers together than it was done in real-time - hence it thinks you double-clicked to close. I've noticed that if I do this very slowly it tends to not close the selection.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2014 0
Enthusiast ,
Feb 25, 2014

Copy link to clipboard

Copied

I think you are wrong. Because the polygonal lasso tool doesnt close, it just stops adding a new line to your lasso, but it hasnt closed it is still active but you cannot do anything. And then you know that with the next tablet click it will autoclose.

I have a feeling it happens more often when the machine is under some stress. But I could be wrong.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 25, 2014 0
Community Beginner ,
Mar 24, 2014

Copy link to clipboard

Copied

I'm having the same problem with both Photoshop CS6 and CC and and an Intuos Pen. Any news?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 24, 2014 0
Community Beginner ,
Mar 27, 2014

Copy link to clipboard

Copied

Same exact thing happens to me; I even tried switching out a Wacom Intuos 3 for an Intuos 4. This is INCREDIBLY frustrating.

Photoshop CC

OSX Mavericks

Mac Pro 2 x 2.4 GHz Quad-Core Intel Xeon

ATI Radeon HD 5770 1024 MB

22GB 1066 MHz DDR3 RAM

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 27, 2014 0
Explorer ,
Mar 27, 2014

Copy link to clipboard

Copied

Yeah, just revert back to Mountain Lion and your problems will be fixed.  That's all you can do until Wacom fixes the drivers. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 27, 2014 0
Enthusiast ,
Mar 27, 2014

Copy link to clipboard

Copied

No, there´s a fix for all these issues...

http://helpx.adobe.com/photoshop/kb/photoshop-menus-turn-white-mac.html

it fixes lasso problem, lag and white menus all in one. Ive used it for a month and photoshop runs just as good as it did in Mountain Lion

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 27, 2014 6
Explorer ,
Mar 27, 2014

Copy link to clipboard

Copied

When did they release that???!!!!  That's great.   Wish it could've happened way earlier (or if it's actually been around a while; wish I'd known about it earlier)   But now that I've been back on Mountian Lion and everything's perfect I'm not gonna mess with anything or upgrade to Mavericks again since I don't really need it.  Thanks for posting!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 27, 2014 1
Community Beginner ,
Mar 27, 2014

Copy link to clipboard

Copied

UGH! Thank you SO much! That totally worked!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 27, 2014 1
Community Beginner ,
Mar 28, 2014

Copy link to clipboard

Copied

Holy crap, that worked like a charm. Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 28, 2014 0
Explorer ,
May 15, 2014

Copy link to clipboard

Copied

Hate to be a buzz killer here, but the "White Window" work-around plugin will only worked for a while. I installed it when it was first available, it fixed everything, but now not so much. The blanked out popups is still fixed, but over the last couple of weeks anything that involves a selection (lasso, polygon etc) is locking up; then the Patch and Content-Aware selection stopped working. I suspect Apple cares but can't fix it, Adobe could fix it but doesn't care, and Wacom is just flying blind and blaming everybody else. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2014 0
Community Beginner ,
Nov 11, 2014

Copy link to clipboard

Copied

wow.  that's it.   THANK YOU.

reposting on other thread on the subject.   This issue should be listed as ANSWERED.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 11, 2014 0
New Here ,
Mar 03, 2015

Copy link to clipboard

Copied

YOU HERO!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 03, 2015 0