Highlighted

PS 2020 is lagging/freezing LOADS and other gripes

Explorer ,
Nov 06, 2019

Copy link to clipboard

Copied

I downloaded PS 2020 without realising (I just thought it was a bug fix update via CC) and wish I hadn't. 

I work on very large images with many layers with a Wacom and need it to be responsive. I work all day every day of the week in PS on Wacom on my Win10pro laptop with i7 7700 (delidded @4.20), 64gb RAM, GTX1080, PCIe SSDs, 30" Dell (DP) and have noticed numerous lagging/hangs since updating to 2020. I let PS access about 70% of my 64GB RAM (and yes I have tried restarting PS but still occurs).

 

It has happened whilst painting with the brush tool on quite a few occasions. PS essentially freezes for 5-10 seconds then 'catches up' and slaps all the brush strokes down in a second. During this hang, I can move cursor around but the cursor icon doesn't change when rolling over things, and I cannot select anything or access any menus. PS is totally unresponsive during this time. Other apps on my machine work fine during this time so it is defintely PS. This lag has happened when using other tools too. Only since 2020 update. 

 

Why oh why are there always so many bugs when a new version is released? Do you guys QA *at all*? I work in the film industry and this kind of 'seemingly untested' product release is not fair on us who rely on consistent performance and stability with quick turnaround times and deadlines. We're not your QA guinypigs. 

 

I've also noticed a constant lag (with skipping cursor) when using the liquify tool, which worked fine before 2020.

 

Also custom keybindings for brush size do not work in Liquify and the defaults must be used...this has always existed as far as I'm aware. Again, poor QA. It's a simple test for a popular tool.

 

Another gripe I've had since the previous horrid release (2019) - Is that when transforming, the cursor now deactivates the transform function if clicked a short distance away from the transform box!! It should remain as a rotate cursor no matter how far from the tranformation box! This is infuriating and a gripe shared by my industry peers. Why did it change? It makes no sense and doesn't allow for fine-tuning the angle position from a greater distance. 

Lastly, what is with the colour picking sticking upon first click? It sticks, then stays on the same colour until the cursor is moved drastically away? There is no options to change this that I can find so I assume it is a bug. It happens when using a mouse too, so not linked to Wacom or Ink.

I really need this lag fixed though. Is it possible to revert to 2019 if using CC to update?

TOPICS
Bug, Crash or freeze, Performance, Problem or error

Views

3.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

PS 2020 is lagging/freezing LOADS and other gripes

Explorer ,
Nov 06, 2019

Copy link to clipboard

Copied

I downloaded PS 2020 without realising (I just thought it was a bug fix update via CC) and wish I hadn't. 

I work on very large images with many layers with a Wacom and need it to be responsive. I work all day every day of the week in PS on Wacom on my Win10pro laptop with i7 7700 (delidded @4.20), 64gb RAM, GTX1080, PCIe SSDs, 30" Dell (DP) and have noticed numerous lagging/hangs since updating to 2020. I let PS access about 70% of my 64GB RAM (and yes I have tried restarting PS but still occurs).

 

It has happened whilst painting with the brush tool on quite a few occasions. PS essentially freezes for 5-10 seconds then 'catches up' and slaps all the brush strokes down in a second. During this hang, I can move cursor around but the cursor icon doesn't change when rolling over things, and I cannot select anything or access any menus. PS is totally unresponsive during this time. Other apps on my machine work fine during this time so it is defintely PS. This lag has happened when using other tools too. Only since 2020 update. 

 

Why oh why are there always so many bugs when a new version is released? Do you guys QA *at all*? I work in the film industry and this kind of 'seemingly untested' product release is not fair on us who rely on consistent performance and stability with quick turnaround times and deadlines. We're not your QA guinypigs. 

 

I've also noticed a constant lag (with skipping cursor) when using the liquify tool, which worked fine before 2020.

 

Also custom keybindings for brush size do not work in Liquify and the defaults must be used...this has always existed as far as I'm aware. Again, poor QA. It's a simple test for a popular tool.

 

Another gripe I've had since the previous horrid release (2019) - Is that when transforming, the cursor now deactivates the transform function if clicked a short distance away from the transform box!! It should remain as a rotate cursor no matter how far from the tranformation box! This is infuriating and a gripe shared by my industry peers. Why did it change? It makes no sense and doesn't allow for fine-tuning the angle position from a greater distance. 

Lastly, what is with the colour picking sticking upon first click? It sticks, then stays on the same colour until the cursor is moved drastically away? There is no options to change this that I can find so I assume it is a bug. It happens when using a mouse too, so not linked to Wacom or Ink.

I really need this lag fixed though. Is it possible to revert to 2019 if using CC to update?

TOPICS
Bug, Crash or freeze, Performance, Problem or error

Views

3.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 06, 2019 13
Explorer ,
Nov 06, 2019

Copy link to clipboard

Copied

Same problems here, I've reverted to the previous option until this is sorted out (which you can do BTW, thank goodness!)  You could understand these issues if the software was shareware, but when you pay a hefty monthly subscription, such a 'buggy' update is frankly unnacceptable!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2019 3
New Here ,
Nov 11, 2019

Copy link to clipboard

Copied

I've had the same issue too.

It's not just with photoshop, but Animate as well. It's disgusting to use now, and my projects are now taking me way longer to finish because of all this lagging and freezing. 

Not to mention the sudden crashes that I come across WAY to often now with this new update. 

The layout looks much cleaner, but I can't work with all the sudden "Unknown error. Closing application. Save changes?" only for it to crash when I hit "save" and lose all my unsaved work anyway. 

 

Thank god for being able to roll back to a previous version. This is atrocious for a product bundle I pay hundreds for each year. I'll be turning off the "auto update" feature for the future. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 11, 2019 1
Adobe Community Professional ,
Nov 11, 2019

Copy link to clipboard

Copied

The brush delay is most likely the video driver. A buggy driver can do this. Perhaps the Wacom driver. Or both.

 

Try to update, or roll back to a version that worked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 11, 2019 0
Explorer ,
Nov 12, 2019

Copy link to clipboard

Copied

D_Fosse - as far as I'm aware PS doesn't use the GFX card for brush strokes. Pretty sure its CPU driven. I'll try updating my GFX drivers nevertheless, which i do regularly anyway.

 

I just updated PS2020 with the update this morning, but the bug still occurs. It hung for 15 seconds whilst using simple brushstrokes on a PSB that's not even half my usual size. 

 

EDIT - new GFX drivers didn't help. Happens within 5 minutes of opening PS. All other drivers (Wacom etc) are up to date. I mainly use PSB files.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 12, 2019 0
Adobe Community Professional ,
Nov 12, 2019

Copy link to clipboard

Copied

Since this is a laptop, chances are the manufacturer has installed tons of "helpful" apps and utilities beyond the bare operating system. Go through it all and uninstall/disable everything you don't need. Something on your system is causing this. I have a 7700K Win 10 pro desktop with a Quadro P2000 video card, and I'm not seeing this.

 

 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 12, 2019 0
Explorer ,
Nov 12, 2019

Copy link to clipboard

Copied

Its a custom desktop-replacement laptop with a desktop motherboard and desktop delidded CPU inside, made by Schenker. They don't bloat. 

 

PS2019 works fine with the exact same laptop. It's not the laptop. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 12, 2019 1
Explorer ,
Nov 15, 2019

Copy link to clipboard

Copied

Same issue here! I just spent over an hour with an Adobe Professional who took ove rmy screen and tried to "help". The tech support is perfectly nice except there is never any real help. They reset prefrences, clear the cache and poke around for an hour doing all the things that not only I have done tons of times but that other Adobe tech support has done countless times. I sttate this in every tech support conversation - that a previous agent has already done all these things. Yet every time we go through the same pointless, tired, time-wasting excersise to no avail. Still no sdolution. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 15, 2019 3
Contributor ,
Nov 15, 2019

Copy link to clipboard

Copied

When this happens have a look at Resource Monitor in Windows via Task Manager. I had the same thing happen yesterday with catchup strokes and it was Wacoms Touch driver that had maxed out my ram. Had to stop start the service.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 15, 2019 1
Explorer ,
Nov 17, 2019

Copy link to clipboard

Copied

My Wacom works perfectly fine with PS2019 so it would be very strange that it's their driver behaving differently in PS2020. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 17, 2019 0