PS CS6 on CC lags when using mouse after using tablet?

Explorer ,
Jun 08, 2013

Copy link to clipboard

Copied

Noticed that photoshop CS6 on Creative Cloud at least seems to lag when I try to move a layer around or a selection around with my mouse after I have used my tablet.  So what Im trying to say is that I can move selections around with my mouse or with my tablet and they move fine but when I do anything with my tablet and the go back to my mouse thats where I get the lagging movement.  If I then at that point try to move the selection with my tablet it doest lag around.  As I try different things with my mouse after I have used my tablet nothing else seems to lag just moving the selection with my mouse.  Any others having this issue or know what may be the cause?

Views

33.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Participant ,
Dec 04, 2013

Copy link to clipboard

Copied

I asked Wacom if they can or can not reproduce this problem (mouse lag), since they knew about it but they weren't saying whether it was a bug or not, and I wanted them to give a clear answer.

But they did not answer - they just ignored the question.

I also asked them about other problem introduced in recent drivers (the reduced detection height for the pen when using the tablet in mouse mode, an absolute mess that makes the tablet useless except in pen mode).

But they did not answer either - they also ignored the question.

And these are just a few of the ongoing issues with their tablets. For some of their models, they even recommend using older versions of the drivers, but I have an Intuos Pro and I am stuck with the latest drivers. I believe that Wacom's drivers are falling behind the hardware quality of their products for some reason. The product is excellent, but the drivers have a lot of problems.

My perception of Wacom has radically changed over the course of the last few weeks. I started having a great respect for them, now I feel like I bought a crappy product. I hope sooner or later they change for the better, because as much as I hate to admit it, there seems to be no serious alternative to their products (but if anyone has a recommendation, please go ahead).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 26, 2014

Copy link to clipboard

Copied

I'm just now encountering this problem, and I was hoping I could find a solution here. I've been using CS6 for a while now with no issues, and decided to try out CC to see how I'd like it. I installed it and immediately ran into this issue; I can draw and use my mouse fine, then once I start using my pen my mouse lags for one second while Wacom_Tablet.exe shoots up in CPU usage.

I saw how old the thread was and had hoped a solution or a patch had been found, but apparently not. Has anyone made any headway talking to anyone on what could be causing this? CS6 continues working fine for me so I'll just keep using that, but I know it won't be long before I'll have to upgrade to CC and have to face this again.

System Specs:

-Photoshop CS6 x64 13.1.2 (WORKS FINE)

-Photoshop CC x64 14.2 (HAS PROBLEM)

-Win 7 Pro x64

-Core i7 860

-nVidia GTX 770

-16GB DDR3 Ram

-Logitech G700s mouse

-Cintiq 21UX 6.3.7-6 Driver

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 26, 2014

Copy link to clipboard

Copied

No unfortunately with the latest patch this issue has gotten even worse for me.  CC performace just gets more and more delayed the longer it's open "sometimes".  I really have no idea what is causing it anymore.  I'm going to resort to a tech support call next week as the application has become almost unusable for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Jan 26, 2014

Copy link to clipboard

Copied

Same here. Latest Wacom drivers and Adobe PS updates did nothing to improve things.

Thanks to muxtun11 trick, I can get rid of the mouse lag without rebooting PS, but it's not a solution and after so many months, this bug has really hurt my workflow a lot.

The biggest problem, in my opinion, is that by now, Wacom has admitted the main bugs, but this one remains ignored (or at least I have not seen Wacom to acknowledge it). So, there's no way they can fix something that they don't even have on their radar.

If anyone ends up buying a different tablet brand, please let us know whether this issue happens too, or not (I guess it's more Wacom's fault than Adobe's, but who knows...).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 10, 2014

Copy link to clipboard

Copied

*Push.

It's amazing, how bad Adobes and Wacoms support has become.

This is a bug, which hurts the basic functions of most users work and they just don't care about it.

That's what happens when you have no competition.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 26, 2014

Copy link to clipboard

Copied

Just to add another voice to the crowd with this issue with PS CC.

I'm using a Wacom 21UX with latest drivers and the mouse lag gets triggered after using the Tablet. Incredibly frustrating... i'm installing CS6 to see if that is free of the issue because it's driving me mad.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Feb 26, 2014

Copy link to clipboard

Copied

great topic!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 26, 2014

Copy link to clipboard

Copied

Ok, so CS6 doesn't have the problem for me. Not only that but it's just feels like CS6 has an overall performance increase compared to CC (ie, moving UI windows around etc)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Feb 28, 2014

Copy link to clipboard

Copied

I just bought a intuos pen (small) and get really bad lag from my mouse (G500), it happens in all software and all browsers, actually it just happens anywhere I use my mouse and it is really annoying, it got so bad once that after updating my logitech software and having it open on a second monitor, the software reported that no devices were detected when I got a long lag spike of about 5 seconds.

I am still getting the lag after unplugging the tablet, I am going to uninstall all the software etc and see if it gets fixed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 01, 2014

Copy link to clipboard

Copied

I have posted a video on Youtube demonstrating the problem. Please share and make other people aware of it. It would be useful to know how widespread this problem is. Perhaps if enough noise is generated this issue will receive serious attention by Wacom and Adobe.

http://youtu.be/1D51RIIyzSA

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Mar 01, 2014

Copy link to clipboard

Copied

Thanks for making the video, pinkbunkadoo.

Unfortunately, I think we've come this far and there is nothing else we can do. Adobe has said it's not their fault. And Wacom just won't answer anything at all, at least as far as I know (I recently brought up the issue again, but they keep ignoring it for unknown reasons).

I've been able to reproduce the problem in all the computers (with Photoshop CC) I've plugged my Wacom tablet to, so I took it for granted that this was happening to everybody. But, on the other hand, it can't be happening to everybody, or there would be much more people complaining, don't you think so? I don't know what to think.

I will probably end up taking a chance and buying a Huion tablet, it lacks in certain areas but they seem to excel in others. But for now, I will wait until Wacom releases new drivers... maybe they will fix this eventually (although honestly I don't think so, since they haven't even acknowledged the existence of the problem).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 01, 2014

Copy link to clipboard

Copied

I was also able to replicate the problem on another PC at my place of work. This system has a different hardware and software configuration than my home PC with two exceptions: Adobe Photoshop CC and a Wacom Tablet.

It does seem like this isn't going to be solved anytime soon. It is perplexing that more people aren't reporting this. There may just be an unfortunate random cocktail of factors resulting in this happening for all of the people in this thread. We may just have to hang in there until a software/driver update mysteriously fixes it.

If you do buy a Huion tablet let us know how it works out. I've seen a couple of reviews which are mostly positive. More competition in the tablet market can only be a good thing for the end user.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 04, 2014

Copy link to clipboard

Copied

Ok so I uninstalled the drivers etc and everything is working fine, but my setup is maybe different than most peoples, anyway here is my setup in case it might help someone.

My mouse (G500) is connected to the pc using a USB extension cable, when I got the tablet the cable was only a meter or less long so I used the USB extension cable for the tablet and just managed to get the mouse plugged in at the back, then I got lag on my mouse with the tablet plugged in or out.

So I uninstalled all the drivers for the tablet and plugged my mouse back into the USB extension cable and plugged it into the back of the pc and decided to plug the tablet into one of the USB ports at the front of the pc instead and installed everything and all is working fine, no lag from the mouse.

Maybe it had something to do with both devices sharing the same resources or USB hub at the back of the pc or whatever, anyway I hope the info at least helps someone out.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 07, 2014

Copy link to clipboard

Copied

Tried something similar to this, but no luck on my end.  Also using Photoshop CC and a Wacom Pro Medium Tablet...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 20, 2014

Copy link to clipboard

Copied

Bumping to keep in sight.

The more I delve into this issue and the more testing I do the more I am convinced that this is an Adobe problem and not a Wacom problem. Despite the fact that Wacom has a history of glitchy and unreliable drivers I believe that they are not at fault in this instance. The smoking gun really is the fact that I have been unable to replicate this problem in any other program that supports Wacom tablets. So unless Adobe is utilising some unconventional Wacom driver functionality that nobody else supports, it would seem that they have caused this glitch. I think it would be very irresponsible of Adobe to pass this off as a Wacom problem and not seriously investigate why this issue has suddenly reared its head in newer versions of Photoshop CS6 and CC.

Message was edited by: pinkbunkadoo

Message was edited by: pinkbunkadoo

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Mar 21, 2014

Copy link to clipboard

Copied

Good point, pinkbunkadoo. Still, I think more people should be complaining at Wacom's forum as we both have already done. Don't get me wrong, I have also done the same reasoning as you, and yes, I have the feeling that Adobe could fix this, because it's clear that this lag is triggered by something they've changed in the latest versions, as you say.

But it's not too rare that driver developers "cut corners" (or just do wrong things) in their programming, and this weaknesses remain invisible until some program introduces some change or pushes the envelope, and this change triggers the bug in a poorly coded driver. And, if I were to choose, I would take a Photoshop engineer/programmer over a Wacom one any day. I'm sure Wacom staff are also talented people doing their best, but for whatever reason, they (Wacom) have been releasing really really bad and buggy drivers for the last few years, and that's a fact I can't ignore.

But the reason why I think Wacom is more likely to blame, is that Adobe did gave an answer - I don't know if it's the right answer, but they said: "There really isn't a context switch. The OS feeds events to Photoshop, and some of them have tablet info, while others don't.  What you're describing is more of a tablet driver problem. ". Okay. What about Wacom? What have they said? Nothing. Well, maybe they answered something like "delete your prefs" or just generic performance tweaks that have nothing to do with this problem. Nothing else. They have been ignoring complaints about this issue for months now. I even asked them to confirm at least whether they could replicate the bug or not, as simple as that. Again there was no answer, and this stands out strikingly in a forum where they read and answer each and every post. It's a bit suspicious.

On the other hand, let's not forget that the lag goes away if we terminate the driver process. So, it might indeed be something Photoshop is doing, but the lag seems to originate from the tablet driver.

Anyway, I'm not sure at all about whose fault is it. There's no way I can tell for sure. I'm just sharing my thoughts about the issue and acknowledging the validity of yours. In fact, I also admit that it's a bit weird that this is only happening in PS CC (at least for me). I don't know what to think anymore.

Last but not least, on a related note, I insist on something I already said: it's strange that there aren't more people complaining. Maybe this is not 100% an Adobe/Wacom thing, and there's some other hardware or software involved. But I have replicated the bug in different computers with different software and hardware, so I'm at a loss trying to find a common pattern.

All in all, as I said, I've lost hope. I wish I am wrong....

(Btw, I'm still looking into huion tablets, but I think they don't work in mouse mode in PC, and I work in mouse mode, so I'm afraid they are a no-go for me....)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 22, 2014

Copy link to clipboard

Copied

I feel your pain. I too have replicated this bug on another PC with different hardware and software setup. This suggests to me that it has to be something other than my own personal PC configuration. I'm still of the opinion that something Adobe has done in newer versions of Photoshop has caused this problem. Whether or not this is a Wacom driver issue, it is still in Adobe's best interest to work with Wacom to resolve these sorts of problems. Since many Photoshop users are also Wacom users both companies benefit from this hardware/software ecosystem. It would be crazy of them to start playing the blame game.

Another strange behaviour I have noticed which seems to be tied to this mouse delay problem:

1. Using your Wacom pen, draw a stroke on the canvas in Photoshop with the brush tool.

2. Stay in brush tool mode and use the eraser end of your Wacom pen to erase part of the stroke.

3. Put down your pen and use the mouse to draw on the canvas. Particularly draw over the brush stroke you made previously.

    Notice that despite the fact that the brush tool is still selected the mouse will now be in eraser mode.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 22, 2014

Copy link to clipboard

Copied

Something which just occurred to me related to the problem behaviour I described in my last post. It could be that Photoshop is not realising that the user is switching from pen to mouse and continues to behave as if it is receiving pen data from the driver. This is speculative of course but it may be worth Adobe/Wacom looking into.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Mar 22, 2014

Copy link to clipboard

Copied

I have tried the erase-and-switch, and you're right, the mouse is "stuck" in the eraser. It's as if the tablet driver is unable to realise that the mouse driver is taking control. It's really weird. And of course, regardless of who's to blame, I wish one or the other do something to fix this. But I'm not holding my breath...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Apr 03, 2014

Copy link to clipboard

Copied

The strange thing is, that i had this mouse lag even before i installed a wacom tablet. Now with the tablet it's fine, but the mouse laggs, as you point out before... But the months before i even installed a wacom tablet on my windows 8 system i always encountered a mouse lagging (especially when using the pen tool). With the trick mentioned here i finally can get my mouse (Sidewinder x8) working without lags. With CD6 (also from the Cloud) none of this problem exists...

Therefore i really think it's adobe fault. Well, they seem to have changed something that causes this....since it's not the case with cs6 and the sames system/drivers/hardware.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Apr 06, 2014

Copy link to clipboard

Copied

I just want to share some tests I did today, trying to isolate the culprit of this problem. I've tried ArtRage (demo) and SmoothDraw (free). Both of them support tablet pressure, and both of them handle the mouse-pen switch without any issue. Same goes for Lightroom.

I still think Wacom's drivers are very bad, but since this issue happens exclusively with Photoshop CC (more specifically, on the canvas - it does not happen when clicking in the menus or panels), and there's no way to reproduce it in other programs... I must admit it might end up being something that should be fixed by Adobe, after all. Also, let's not forget that we are being ignored by Wacom, so regardless of who's to blame, Adobe might be our only hope.

By the way, I think Wacom will release new drivers soon, or so they said. Let's keep our fingers crossed, just in case.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 06, 2014

Copy link to clipboard

Copied

I am wondering, is it hapening only with wacom tablets? Do somebody know somebody with tablet other than wacom to try it out?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 06, 2014

Copy link to clipboard

Copied

I fixed this on my machine at work by doing the following:

-Uninstall Photoshop.

-Reboot.

-Reinstall Photoshop.

-Test to see if the problem happens before you do any of the updates.

-Do the updates and see if the problem starts occuring again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Apr 06, 2014

Copy link to clipboard

Copied

Had no luck doing this with Photoshop CC. Unfortunately Photoshop CC does not give one the opportunity to select which updates to install. It simply installs the latest available version of the software. This may, however, be effective for Photoshop CS6.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Apr 07, 2014

Copy link to clipboard

Copied

Thanks a lot Malcolm, but that didn't work for me. I've already had my fair share of Photoshop reinstallations and nothing changed. Some months ago I went as far as reinstalling the o.s. on my secondary computer (a laptop). After a fresh install of Windows 7, all I installed was Norton Antivirus 360, Creative Cloud Application (and then Photoshop CC) and Wacom's drivers. And the lag was already there! On the other hand, as Pinkbunkadoo pointed out, the download via Creative Cloud installs the latest version so we cannot choose the version, although I think it happens (the lag) since the very first CC release. But yes, I'm aware that certain people noticed the lag appearing on CS6 after certain updates. In fact, during previous tests I tried another computer with CS5, CS6 and CC, all with the latest updates (all three of them on the same computer, working perfectly). On this computer, CS5 did not show the lag, CS6 did and of course CC did.

But I'm so desperate that I will do a full system reinstall on my main computer during next week. I will report back afterwards, although I am not too optimistic.

Last but not least, if anybody finds this thread but has not posted yet at Wacom's site, please post on this thread and let Wacom know. Yes, it's not been very helpful so far, but I guess we must try... Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Apr 12, 2014

Copy link to clipboard

Copied

Well... I've already done my reinstall. This time I even bought a new ssd disk, and installed Windows 8.1... TWICE. The first time around I decided I would do an "experimental" installation so that I could test things that I wouldn't try normally - as soon as installation was over, I only installed this (besides any driver automatically installed by Win 8.1):

• Creative Cloud application in order to then install Photoshop

• Wacom drivers

Guess what, the lag was already there right after a clean installation. I tried a number of bizarre things to no avail. I even reset my motherboard's bios settings, and experimented with some of them related to keyboard, mouse and usb. Nothing. Then, once my experiments were over, I re-formatted and reinstalled Windows 8.1. This second time I did a regular installation, I first installed more important things as other drivers (not only Wacom's) and other software (not only Photoshop). Then, when I had installed everything, I tried again, and not surprisingly, the lag happens the same.

By the way, new Wacom drivers were released, 6.38-3. They have added a "nice" bloatware welcome screen, but of course, the lag, as I said, is the same as before (or maybe slightly worse).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Apr 25, 2014

Copy link to clipboard

Copied

I've opened a "problem" thread at Photoshop.com. If you suffer from this problem, I guess we will get more attention if affected users click on the "I have this problem too" button at the bottom of the post:

http://feedback.photoshop.com/photoshop_family/topics/after_switching_from_wacom_tablet_to_mouse_eve...

I don't know if anybody else already posted about this issue but I could not find it, so I started this one. Oh how I wish this problem someday goes away

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 27, 2014

Copy link to clipboard

Copied

Having the same issue with CC and an Intuos4 tablet. Considering how long this has been a problem, it's totally unacceptable that there isn't a solution yet. Very frustrated.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
May 07, 2014

Copy link to clipboard

Copied

You won't believe this. I just come from the Wacom forums, and at the same thread about this problem that Wacom has been ignoring most of the time (and it's 4 pages long by now), finally Wacom has posted something which I'm going to copy paste here:

The problem has been verified by Adobe and Wacom engineers. We will try to get this fixed in the next driver.

At least! Not only they admit there's a problem, but they are going to fix it!!!!!!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 07, 2014

Copy link to clipboard

Copied

Thats great! Sounds like it may have been a driver issue after all.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 07, 2014

Copy link to clipboard

Copied

Geezus! They have engineers!! And thay can FIX SOMETHING! Good lord! 0_0

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 18, 2014

Copy link to clipboard

Copied

Wacom drivers are a mess... I know this is a bit off topic, but I can't create an account on the wacom forum (for some reason I never got the confirmation email and all I have is a disabled account) so yeah...

For the last 2 wacom driver releases they have a serious bug for the intuos5/pro series... each time I take my cursor at the bottom or left side of the screen, it jumps a pixel on the other side... this is freaking annoying!

Can't believe that sucks a big company like wacom can't afford to hire some of the best developers to make some decent drivers and to stop screwing with the user experience!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...