Puppet Warp Not Working on 2020

Explorer ,
Nov 20, 2019 Nov 20, 2019

Copy link to clipboard

Copied

Puppet Warp doesn't seem to be working on 2020.

 

I select Puppet Warp, and the layer becomes meshed, but I cannot apply pins.

 

For documents with Puppet Warp Smart Filters (made on 2019), I load the documents into 2020, try to edit the Puppet Warp, but the entire document turns white when I select it.

 

Is this already a known issue, or is someone trying to gaslight me?

 

Thanks!

TOPICS
Problem or error

Views

5.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct Answers

Adobe Community Professional , Nov 21, 2019 Nov 21, 2019
Catalina has so many issue with PS, I'm not surprised that that might be you issue. Hopefully Adobe will fix all the things Apple broke with that OS.

Likes

Translate

Translate
Community Beginner , Nov 28, 2019 Nov 28, 2019
I solved my own problem. Selecting “Use Graphics Process” under the Performance preferences panel enables Puppet Warp and the drag to zoom option.

Likes

Translate

Translate
Adobe Community Professional ,
Nov 20, 2019 Nov 20, 2019

Copy link to clipboard

Copied

Just to confirm, puppet warp does not work as it use to, pins are not visible when adding them, just tested on latest windows with latest Photoshop.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 21, 2019 Nov 21, 2019

Copy link to clipboard

Copied

For what it's worth, this is happening for me on a Mac. Just gopt it about six or eight weeks ago, running Cataliona OS.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 21, 2019 Nov 21, 2019

Copy link to clipboard

Copied

Catalina has so many issue with PS, I'm not surprised that that might be you issue. Hopefully Adobe will fix all the things Apple broke with that OS.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 04, 2019 Dec 04, 2019

Copy link to clipboard

Copied

May one be so bold as to enquire when this bug will be fixed please?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 05, 2019 Dec 05, 2019

Copy link to clipboard

Copied

User trevorpsy said this, and it worked for me:

 

"I solved my own problem. Selecting “Use Graphics Process” under the Performance preferences panel enables Puppet Warp and the drag to zoom option."

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Nov 21, 2019 Nov 21, 2019

Copy link to clipboard

Copied

Hi

Just tested with Photoshop 2020 on Windows 10 and pins are showing fine for me

puppet warp.png

Have you tried resetting your Photoshop preferences

image1.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 21, 2019 Nov 21, 2019

Copy link to clipboard

Copied

Reseting preferences does not work at least for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 21, 2019 Nov 21, 2019

Copy link to clipboard

Copied

Hello, Bojan, and resetting the transform tool?

Which graphic card/driver combo? Is it DirectX12 compatible?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 21, 2019 Nov 21, 2019

Copy link to clipboard

Copied

If you mean use legacy free transform it does not help. Yes, card is DirectX12 compatible.

ge force version.jpggraphic card 1.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 28, 2019 Nov 28, 2019

Copy link to clipboard

Copied

I see that the nVidia card is DirectX 12 compatible...

While the driver for the Intel card are very old.

Is there a way to bypass totally the Intel card, and only use the nVidia one?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 28, 2019 Nov 28, 2019

Copy link to clipboard

Copied

Hi and thanks for getting back to me.

Under the performance preferences I didn’t have Graphic Processor option checked. Taking care of this also enabled drag zooming.

Take care,

Trevor

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 28, 2019 Nov 28, 2019

Copy link to clipboard

Copied

There is a way and that worked, thank you. The trick is to change Preffered Graphic Processor to High Performance Nvidia from Nvidi control panel.

nvidia graphic processor.jpg

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 18, 2021 May 18, 2021

Copy link to clipboard

Copied

LATEST

Thank you. This worked for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 21, 2019 Nov 21, 2019

Copy link to clipboard

Copied

No problem here on Win 10 either. Also tried setting the in 2019 and opening in 2020. No problem there either. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 28, 2019 Nov 28, 2019

Copy link to clipboard

Copied

Same problem with MacPro running Mojave.  I see the mesh, but no pins and the Puppet Work doesn't work.  It's works fine with the 2019 version.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 28, 2019 Nov 28, 2019

Copy link to clipboard

Copied

I solved my own problem. Selecting “Use Graphics Process” under the Performance preferences panel enables Puppet Warp and the drag to zoom option.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 05, 2019 Dec 05, 2019

Copy link to clipboard

Copied

I tried this, and it worked for me, too!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 05, 2019 Dec 05, 2019

Copy link to clipboard

Copied

This now works: many thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 16, 2020 Jan 16, 2020

Copy link to clipboard

Copied

This did not work for me. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 13, 2020 Apr 13, 2020

Copy link to clipboard

Copied

I don't have graphics card in my pc... That means I can't use this feature of Photoshop. Pls reply

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 13, 2020 Apr 13, 2020

Copy link to clipboard

Copied

Hello, you must have something to push the pixels to the screen, I think that the integrated GPU might be compatible, check in help>system info...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 05, 2020 Jul 05, 2020

Copy link to clipboard

Copied

I can't get the expansion to expand so the tool is useless

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines