Quick Export as PNG Moves Layers (Transparency)

Contributor ,
Jan 15, 2019 Jan 15, 2019

Copy link to clipboard

Copied

I have different .psb files with graphics positioned to the right. When I have the colored background layer visible and choose File>Export>Quick Export as PNG, it exports as expected. When I tick the visibility of the background layer off to get the version with transparency and choose Quick Export as PNG, the resulting image has the graphics shifted to the left edge. Same happens if I choose File>Export As and select PNG as the file format.

Why does this happen? Is this a bug or a feature? Is there a preference option to stop it? This is what I mean:

example.jpg

I googled this and others have had this problem, but I never found a reason for it. The closest I came was this thread originally posted 4 years ago with people contributing as recently as a month ago: Photoshop: Quick Export option to disable transparency trimming | Photoshop Family Customer Communit...

They make it sound like trimming out transparent pixels is the normal behavior for Quick Export/Export as PNG but there has to be more to it than that since it doesn't happen for every image with transparency. It's also not "trimming" as I define it because the canvas size stays the same. It just justifies the content as far left as it can go.

Workarounds

The workaround someone mentioned in that thread of adding a rectangular vector mask didn't work for me. I just duplicate the image (to protect the original from slip up) and flatten the layers down to the transparency. Then it works fine.

Testing

I ran some tests with one of the affected images to try to pinpoint (and replicate) what conditions trigger this shift. The file has 4 groups with multiple layers in each. First, I toggled the visibility off for one group at a time to see if that affected export. All groups resulted in the same shift except one. When I turn that group off, the file exports correctly.

  • Tried moving that group up/down in the layer order to see if that had an effect. Nope.
  • Tried dropping that group into another group and the behavior was the same. If turned on (with the parent group on), it exports wrong. If turned off (with the parent group on), it exports fine. If turned on (with the parent group off), it exports fine.

Basically, any setup that results in the contents of that specific group being hidden allows the file to export correctly.

Trouble Group

It has 7 layers. 5 are of a graphic with FX applied. 2 are of graphics with nothing applied. Note that the 5 layers are the same graphic duplicated. Not smart objects. Just the rasterized graphic duplicated then rotated and repositioned.

I did the same test, toggling a different layer's visibility before each export. Only 2 layers resulted in proper export when toggled off. Layer X and Y.

  • Layer X has color overlay, drop shadow and is at 50% opacity.
  • Layer Y has color overlay and is at 75% opacity.

They're not the only layers with these effects or lowered opacity but I tested them anyway. Tried putting them at 100 opacity. Bad export. Removed the effect from Y only. Bad export. Removed the effect from X only. Good export.

Trouble Layers

For Layer X: Tried deleting the effects and adding the same back fresh. Bad export. I tried removing color overlay only. Bad export. Removing drop shadow only. Good export. Tried rasterizing layer effects. Good export. For Layer Y: Tried the same only nothing short of removing effects entirely resulted in a good export. Even rasterizing the layer affects didn't help. I was over it at this point.

Important Note

Since the file is large (14000px), I shrank it down to 1000px and ran the initial group visibility test again. The file exported correctly no matter what so there was never a need to mess with any groups/layers. I also duplicated those two layers to a new file and it had no effect on export.

Second Affected File

I took another affected file and different things worked to get it to export properly. Namely, just deleting a ton of stuff lol

Conclusion

Unless someone can tell me otherwise, it seems Photoshop is trying to reduce the file size based on a combination of factors that differ from file to file, exploiting transparency to do it by attempting to trim out unused pixels. Only in my case, it isn't doing it "right" anyway since all the empty space still remains. It's just on the other side.

Any thoughts? Thanks!

To save time:

I'm using the latest version of Photoshop CC.

Yes I need the graphic to stay exactly where it is on the canvas so this IS an issue.

Views

2.2K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Contributor , Jan 27, 2019 Jan 27, 2019
Okay. received an official response from Adobe to limit PPI for "quick export" and "export as" to 150PPI and that quick export as png has a 9600px limit so dimensions beyond that will cause it to fail.I've just been using "save as" and that works fine regardless of the resolution or dimensions.

Likes

translate

Translate

Translate
Adobe Community Professional ,
Jan 15, 2019 Jan 15, 2019

Copy link to clipboard

Copied

Did you try it on the new update release 20.0.2 which has been released today

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jan 15, 2019 Jan 15, 2019

Copy link to clipboard

Copied

Yes I have 20 since I auto-update but kept the old version. I didn't see another update besides that. If that's it then I'll try reinstalling or deleting the old version later too.

In the meantime, anyone have an answer to my question? Is quick export supposed to attempt to trim transparent pixels like the thread I linked to suggests or is that a bug? Any thoughts on the tests? Anyone else see this issue before?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jan 18, 2019 Jan 18, 2019

Copy link to clipboard

Copied

Just adding an update, I contacted Adobe and they're working on sample files I sent them to figure out the problem since the behavior isn't normal. Will post any information I get for the benefit of anyone else who may have this issue.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jan 27, 2019 Jan 27, 2019

Copy link to clipboard

Copied

Okay. received an official response from Adobe to limit PPI for "quick export" and "export as" to 150PPI and that quick export as png has a 9600px limit so dimensions beyond that will cause it to fail.

I've just been using "save as" and that works fine regardless of the resolution or dimensions.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

March 2021 this still hasn't been fixed.  I use quick export for PNG because the file size is much smaller than "File Save As PNG" and its quick.  However, if there is extra space, transperancy on the side of the canvase the file will be saved in the incorrect size everytime.

 

All the work-arounds are just that, work-arounds.  They don't fix the problem of trusting your Quick Export to be exactly what you expect.

 

 

PLEASE FIX THIS!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

OMG yes this needs to be fixed, literally happening to me right now

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines