Rotate View Tool Not Working

Community Beginner ,
Jan 13, 2010 Jan 13, 2010

Copy link to clipboard

Copied

When I open any type of document in Photoshop CS4, the Rotate View Tool continually tells me that the:

"Could not complete your request because it only works with OpenGL enabled document windows"

I'm not sure what this means and would appreciate any advice. This tool would be very beneficial to me considering the type of work I do.

Thanks,

Views

54.0K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Guru , Jan 13, 2010 Jan 13, 2010
We need more information. What version of PS. OS, Video card and drivers.Look in PS, Edit, prefrences, performance. There should be a opengl box to enable. Check that and see if it works

Likes

translate

Translate

Translate
Guru ,
Jan 13, 2010 Jan 13, 2010

Copy link to clipboard

Copied

We need more information. What version of PS. OS, Video card and drivers.

Look in PS, Edit, prefrences, performance. There should be a opengl box to enable. Check that and see if it works

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 13, 2010 Jan 13, 2010

Copy link to clipboard

Copied

You're suggestions in the preferences area worked perfectly.

Thanks a ton!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guru ,
Jan 13, 2010 Jan 13, 2010

Copy link to clipboard

Copied

Your welcome

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 20, 2018 Aug 20, 2018

Copy link to clipboard

Copied

I have PS 2018 latest one and i don't see the setting in preferences

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jan 13, 2010 Jan 13, 2010

Copy link to clipboard

Copied

NASAphotographer wrote:

"Could not complete your request because it only works with OpenGL enabled document windows"

I'm not sure what this means and would appreciate any advice. ..

The message means that OpenGL has not been enabled, most likely because either your video card does not support the necessary OpenGL functions or the video driver needs to be updated to provide this support.  In PS CS4 look at Edit > Preferences > Performance.  Try to check on Enable OpenGL Drawing.

You might find this Adobe Knowledge Base article of interest:  <http://kb2.adobe.com/cps/404/kb404898.html>  "GPU and OpenGL Features and Limitations in Photoshop CS4"

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 25, 2018 May 25, 2018

Copy link to clipboard

Copied

I have the same problem in PH CC17
I tried open performance and changed few times preferences there but it does not work 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 20, 2019 Oct 20, 2019

Copy link to clipboard

Copied

https://www.youtube.com/watch?v=kGrGVJjZyC0 you could follow this guideline as well, it worked for me 🙂

Getting annoyed with rotating tools that needed an updated GPU's?then here's the solution

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 05, 2020 Aug 05, 2020

Copy link to clipboard

Copied

It works in CC2018 it does not but not CC2020. What's the deal? Adobe wasting alot time AND energy these days with its "newbie" focused approach again? 😐 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 26, 2020 Aug 26, 2020

Copy link to clipboard

Copied

I'm having the same issue. I'm using the newest update (Photoshop 2020, vrs 21.2.2) and when I try to use the Rotate View Tool I get the error message "Could not complete your request because it only works with OpenGL enabled document windows".

I have only experienced this issue recently with the new update, it worked fine in CC 2019.

As far as I know my graphics card is supported (ATI Radeon HD 5770 1024 MB)

Are there any plans to address this bug?

Cheers.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 30, 2020 Aug 30, 2020

Copy link to clipboard

Copied

I was having the same issue after the upgrade.

The route that worked for me was  Photsohop > Preferences > Performance > Checked Use Graphics Processor 

Then restarted photoshop. 

 

Good Luck

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 23, 2020 Nov 23, 2020

Copy link to clipboard

Copied

yes this worked! thank you. At first i thought it wasn't solved but then i just had to restart 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 08, 2020 Sep 08, 2020

Copy link to clipboard

Copied

Same here, running Photoshop 2020 v 21.1.2 on a PC with two NVIDIA RTX 2070 GPUs

Really killing my ability to cel animate in photoshop. Hope they address this soon 😕

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2020 Nov 11, 2020

Copy link to clipboard

Copied

So I tried the Photsohop > Preferences > Performance > Checked Use Graphics Processor but I had it already checked, and when I went into Graphics Processor Advanced Settings it faded out the checkbox for the Use OpenCL. Is there any other solutions? I have Photoshop2020 and the most recent update.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 18, 2020 Nov 18, 2020

Copy link to clipboard

Copied

I'm having the same issues. Never encountered this until recently.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 18, 2020 Nov 18, 2020

Copy link to clipboard

Copied

I still haven't found a solution, so if you do, please let me know.

Thank you!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 27, 2020 Nov 27, 2020

Copy link to clipboard

Copied

It's got me too! As of today, for some reason.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 11, 2021 Feb 11, 2021

Copy link to clipboard

Copied

Came here looking for a solution to this error message in Photoshop v 22.

 

I had the Use Graphics Processor option already checked. The other thing I experienced was that I could rotate some files that I had open in Photoshop, but not the one that I was currently working on.

 

I closed all the files except for the one that I was working on. I was then able to rotate the canvas as expected. 

 

This is not on the most tricked out computer, just a capable older iMac with what must be a stock graphics processor. I had 5 files open. None of them huge, like ~50-60 Mb each.

 

Maybe this will be of help to someone else.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines