• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Echo problem with Snowball mic - how to disable mic sound?

New Here ,
Aug 30, 2020 Aug 30, 2020

Copy link to clipboard

Copied

I am using elements 15. I am trying to record voiceover but I constantly hear myself. How do I disable it? I use a USB snowball microphone. 

TOPICS
Error or problem

Views

286

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 30, 2020 Aug 30, 2020

Copy link to clipboard

Copied

Turn off or mute your speakers while you're recording.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 31, 2020 Aug 31, 2020

Copy link to clipboard

Copied

Thank you very much for answering. If I do it I would not be able to listen to the playback music. I am trying to record voice over music.

I think I need to find a way to mute the sound monitoring or to mute the sound of myself while recording. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 31, 2020 Aug 31, 2020

Copy link to clipboard

Copied

The only other option is to wear headphones when you record your narration.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 05, 2020 Sep 05, 2020

Copy link to clipboard

Copied

Thanks again. I tried to put on the headphones, or without headphones. I still hear myself in delay. I read some threads and I think it relates to a function called Monitor my sound or something like this. I believe it is an issue with the software settings not with how to use the hardware. Could you assist me?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 05, 2020 Sep 05, 2020

Copy link to clipboard

Copied

LATEST

It's just the nature of Premiere Elements, unfortunately. The only solution I've found is to mute my computer completely when I record narration. I know that isn't what you want to do, but there is no way I've found in years of working with this program to play the timeline while recording without getting feedback from your own recording.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines