• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Premiere Elements 2021 running slow on 2019 iMac

New Here ,
Dec 09, 2020 Dec 09, 2020

Copy link to clipboard

Copied

Hello,

Premiere Elements is running extremely slow on my 2019 iMac, even without any media loaded into the project.

 

Specs of my iMac are:

3,7 GHz 6‑Core Intel Core i5

16 GB RAM

Radeon Pro 580X 8 GB

 

I would expect it to not be able to work properly with 4K material, but running slow right from the start seems pretty odd to me. When playing back short HD clips (around 3 mins) while browsing through effects CPU usage jumps over 100%, not to mention export when it hits over 500%.

 

Installed the program twice with no luck. Adobe suggests trying to locate and change the content of the folder "~/Library/Logs/Creative Cloud/Creative Cloud Libraries", but it doesn't exist, so I'm not able to change anything.

 

Any suggestions are highly appreciated. Thank you in advance.

 

 

TOPICS
Error or problem , Freeze or hang , Performance

Views

575

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 09, 2020 Dec 09, 2020

Copy link to clipboard

Copied

That is odd.  I have a PC so can't be sure about Macs.  Can you post a screen shots of the General settings page, the Audio Hardware page and project settings.   Without that and not knowing your machine, it sounds like you have something using RAM or are short of disk space.   Normal is a running well on a healthy machine.   

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 12, 2020 Dec 12, 2020

Copy link to clipboard

Copied

Thanks for the quick reply. Here are my settings. Again, everything is running slow without any media loaded.

Bildschirmfoto 2020-12-12 um 18.02.35.pngBildschirmfoto 2020-12-12 um 18.03.51.pngBildschirmfoto 2020-12-12 um 18.04.59.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 13, 2020 Dec 13, 2020

Copy link to clipboard

Copied

Any advice? I downloaded the test version of Premiere Pro and it seems to run just fine.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 14, 2020 Dec 14, 2020

Copy link to clipboard

Copied

Hi @XTimothyX 

Can you please ellaborate the issue more? When you say the program is slow, are you facing issue with playback, rendering or any other workflow?

Also, can you also try closing other heavy programs running on your machine in background and try relaunching Premiere Elements again? If possible, try restarting the machine once.

Also, you can try turning off the GPU acceleration pipeline by following the below mentioned steps:
1. Go to Preferences>>General.

2. Uncheck the check box "Use GPU accelerated effects, transitions....".

3. Restart the Premiere Elements.

 

Let me know if this makes any difference.

 

Thanks,

Anubhav

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 18, 2020 Dec 18, 2020

Copy link to clipboard

Copied

Hello,

thank you for your answer. None of the recommendations helped, unfortunately. I de-installed and installed the program again. First thing to mention is that the slider under the timeline does not run smoothly, it just stutters. When clicking on effects or other tools, the windows take around 3-5 seconds to open. Again, this behavior shows without any media loaded in, GPU accelaration off (although the program says that my card is supported), audio input set to none. If I play back a HD video at 1080p/25fps the playback starts around 2-4 seconds after pressing the play button, stopping it takes around 5-7 seconds or numerous attemps.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 18, 2020 Dec 18, 2020

Copy link to clipboard

Copied

In addition: I tested the trial version of Premiere Pro and DaVinci Resolve (free version). They both run fine with any kind of media files.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 15, 2020 Dec 15, 2020

Copy link to clipboard

Copied

I am guessing your project settings do not match your footage. Nowadays footage is progressive not interlaced.

Also set Default input for audio to NONE.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 18, 2020 Dec 18, 2020

Copy link to clipboard

Copied

LATEST

Hello,

thank you for your answer. Please see my answer above: tried everything, nothing helped. Premiere Elements runs slow without any media loaded in, GPU accleration off (but card is supported), default input set to none.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines