Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Discuss : AMD Hardware Accelerated Encode for H264/HEVC

Adobe Employee ,
Apr 01, 2020 Apr 01, 2020

Copy link to clipboard

Copied

With the latest Adobe Premiere Pro Beta build we have enabled Hardware Accelerated Encoding through AMD GPU card.


If you have AMD GPU card on your Windows machine, you will be able to use this feature.


To enable this option, select H.264/HEVC from the Format drop-down under Export Settings. Then under the Video tab, go to Encoding Settings and set the Performance to Hardware Encoding. Setting it to Software Encoding will disable hardware encoding and Adobe Premiere Pro won't use AMD HW to encode the media. Please see attached screenshot.

Feature is enabled in Adobe Premiere Pro Beta, Adobe Media Encoder Beta and Adobe Premiere Rush.

 

Please try out the feature and share your feedback.

TOPICS
Feedback, Performance

Views

6.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , May 18, 2020 May 18, 2020
  Hi Everyone, AMD Encode support is now available in the released (non-Beta) versions of: - Media Encoder 14.2 - Premiere Pro 14.2 - Premiere Rush 1.5.12   Thank you to all for your feedback during the Feature Development.    Thanks Brajesh

Likes

Translate

Translate
Participant ,
Apr 01, 2020 Apr 01, 2020

Copy link to clipboard

Copied

This is a wonderful news and it seems to work very well!!!

🙂

Well done!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 02, 2020 Apr 02, 2020

Copy link to clipboard

Copied

Thanks for your feedback! Would be great if you can share the AMD card name that you have on your machine.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 02, 2020 Apr 02, 2020

Copy link to clipboard

Copied

Actually I don't have an AMD card name. I have a NVIDIA 1070 GPU and it has never worked before now.

I had the hardware encoding option greyed out and now it can finally be enabled

and I really love the rendering speed I can reach with the accelerated encoding.

So I guess you unlocked the Hardware acceleration on the NVIDIA GPU as well, at least you did for mine.

I hope this is a good news for you as well.

🙂

Davide

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 02, 2020 Apr 02, 2020

Copy link to clipboard

Copied

There is also a separate discussion thread for NVIDIA support:
https://community.adobe.com/t5/premiere-pro-beta/discuss-nvidia-hardware-accelerated-encode-for-h264...

 

Manish

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 09, 2020 Apr 09, 2020

Copy link to clipboard

Copied

I have found the issue. It is working fine.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 09, 2020 Apr 09, 2020

Copy link to clipboard

Copied

I was able to use this feature with my AMD Radeon Frontier Edition card and it worked great! My card has 16GB of VRAM, but GPU-Z only used just around 4GB of VRAM. Are you using the graphics card VRAM during encoding, and if so, why don't you use more of what the card has available?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 09, 2020 Apr 09, 2020

Copy link to clipboard

Copied

Seems like I spoke to soon!
When I reviewed the exported footage, there were errors. My project was recorded on the Panasonic S1H, and portions of the shoot were in 4K 10-bit H.264 4:2:2 and others were in 5.9K 10-bit H.265 4:2:0. The 4K parts encoded fine, while there is a massive exposure shift on the 5.9K files, to the point the screen looks almost entirely black!

After I reviewed the affected scene in Premiere, that scene had the same issue, so I don't think the problem is specifically GPU Encoder related, but it was how I ran into the problem nonetheless. Attached is a clip of the video playing back with the default Windows video player.Bad video playback in part of the exported file.Bad video playback in part of the exported file.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 13, 2020 Apr 13, 2020

Copy link to clipboard

Copied

We are looking into it. We will let you know if we need any help from you.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 13, 2020 Apr 13, 2020

Copy link to clipboard

Copied

Thanks for your feedback! I would request you to please provide the footage and the project which will help to reproduce the issue via Dropbox or Google Drive. Also, please do let me know if it is H.264 encode or HEVC encode.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 14, 2020 Apr 14, 2020

Copy link to clipboard

Copied

Is there a time estimate of when this will come to MacOS?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 15, 2020 Apr 15, 2020

Copy link to clipboard

Copied

Thanks for the Query. 

MAC already supports HW encode.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 15, 2020 Apr 15, 2020

Copy link to clipboard

Copied

Is this not different from the QuickSync HW acceleration? I was under the impression QuickSync was for using Intel chips to accelerate. This sounded like it was for utilizing the GPU more upon export instead of QuickSync. Did Windows not have Intel HW acceleration before this?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 16, 2020 Apr 16, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

Sorry to chime in, this means that the "non beta" version of Premiere Pro is using the discrete GPU for the encoding in MacOS? The same way the beta is working on Windows?

Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 07, 2020 May 07, 2020

Copy link to clipboard

Copied

Thanks for the Query. In Mac OS, the hardware encoding feature uses VTB technology. For non-beta version of Premiere Pro on Windows is using Intel for encode and decode. Also, to enhance hardware encoding feature on Windows AMD and NVIDIA HW encode is currently available in beta releases.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 11, 2020 May 11, 2020

Copy link to clipboard

Copied

Trying to fully understand here.. So is Mac OS non-beta already supporting HW encoding utilizing the AMD GPU? Or is it utilizing Quick Sync? Will the beta version add any HW encoding featutes to enhance performance on Mac OS? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 12, 2020 May 12, 2020

Copy link to clipboard

Copied

Thanks for your Query. Yes, MAC OS non- beta is already supporting HW encoding using VTB technology which uses Intel or AMD GPU accordingly as per VTB software. Also, the beta version will not add any HW encoding features to enahnce performance on MAC OS, the beta feature is for Windows only.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 17, 2020 Apr 17, 2020

Copy link to clipboard

Copied

My laptop has a 2500U with Vega 8 as well as an RX 560X. After an export, it appears that the hardware encoded video was only using the Vega 8 and not touching the RX 560X. Additionally, it appears to have been still mostly using my CPU; task manager showed CPU sitting at 100% usage on all eight threads with video encode on the Vega iGPU sitting at around 10% (and RX 560X not touched at all). Is this correct? Running driver version 20.4.1.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 20, 2020 Apr 20, 2020

Copy link to clipboard

Copied

Thanks for your Query. Please share the configuration and model of your laptop.

Also, check the following things- 

1. In the export panel, check the tooltip over Hardware Encoding, if it shows AMD HW Encoding message.

2. Is HW encoding taking lesser time than SW encoding?

For HW encode, only one card will be used based on internal configuration of the laptop and one GPU will be used. Moreover, CPU usage depends on the various parameters of the project like media used , audio , effects etc. All formats, non- accelerated effects and audio are not HW accelerated which will lead to high CPU consumption.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 10, 2020 May 10, 2020

Copy link to clipboard

Copied

PLEASE get this Hardware encoding to next main update, it is absolutely amazing and impressive..I had a H.264 timeline of 2 hours and 36min...and it encoded through hardware feature in 35min...and I have a video card with only 4 gigs of VRAM, not bad from a 12 year old Build..GREAT FEATURE PLEASE PORT OVER!!!!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 11, 2020 May 11, 2020

Copy link to clipboard

Copied

Sure, it will be available soon in the main updates

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 18, 2020 May 18, 2020

Copy link to clipboard

Copied

 

Hi Everyone,

AMD Encode support is now available in the released (non-Beta) versions of:
- Media Encoder 14.2
- Premiere Pro 14.2
- Premiere Rush 1.5.12

 

Thank you to all for your feedback during the Feature Development. 

 

Thanks

Brajesh

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 20, 2020 May 20, 2020

Copy link to clipboard

Copied

Are AMD cards on Macs also supposed to enable HW encoding? I cant get it functioning on my iMacPro.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 20, 2020 May 20, 2020

Copy link to clipboard

Copied

Thanks for your Query. The AMD HW encode feature is enabled for Windows only in 14.2 release.

For Mac/iMac Pro, we are using VideoToolbox for HW encoding.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2