Caption/subtitle test vanishes when edited in 15.4.0 build 3

Contributor ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

Today I updated PPro to 15.4.0x3, and now when I click on a Caption (subtitle) to edit it, it turns black. I can still edit the text - by memory and guesswork.

 

Caption panel, not selected:

hellopaul4_0-1621590485105.png

That same caption selected for editing:

hellopaul4_1-1621590510757.png

The caption text is still there - I can move the cursor around (the cursor is visible in real life, just not on the screenshot) and type stuff, but it's all just black on black. When I press Enter, it all reappears.

 

I've been working on this same project for a few days (in previous versions of PPro Beta) with no issues. I just updated my Nvidia drivers to see if that helped, but it made no difference.

 

Very annoying!

 

TOPICS
Bug

Views

153

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Employee , May 26, 2021 May 26, 2021
A fix just got checked in and should show up in the beta build in the next day or two.

Likes

Translate

Translate
Adobe Community Professional ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

It will be a bit before I can update to test. What happens when you edit the same text in the Program Monitor? I would expect it to work, and to make no difference on what you are seeing in the Text Panel.

 

Stan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

I can edit the text perfectly in the program monitor.
One thing I've noticed when editing text in the program monitor - pressing Enter behaves like pressing Return (i.e. it inserts a carriage return) but logically it should behave like elsewhere in Premiere - confirming the edits and exiting the text editing mode.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

I'll test this when I update to beta 15.4.

 

The Enter behavior is the same for 2021 captions in the Text Panel and the Program Monitor.

 

This is also the same behavior as in the Captions Panel in PR 2020 and before.

 

Stan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 22, 2021 May 22, 2021

Copy link to clipboard

Copied

Updated to beta PR 15.4.0 Build 4.

 

I confirm the bug you reported. I can double click a caption in the Text Panel, and it goes into edit mode. But as soon as I click to type, the text disappears, but the cursor shows the characters are still there. Is the font black instead of white?

 

Stan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 23, 2021 May 23, 2021

Copy link to clipboard

Copied

Just installed build 5. Same problem.

 

Stan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 24, 2021 May 24, 2021

Copy link to clipboard

Copied

Thanks for the report. Sorry about that, our developers are investigating this issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
May 24, 2021 May 24, 2021

Copy link to clipboard

Copied

I can confirm the problem is still there on Build 6 (I'm sure you knew that already - but thought it might be helpful to confirm! 👍).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 24, 2021 May 24, 2021

Copy link to clipboard

Copied

Yes, I have the same problem, which makes it difficult to edit the transcript.  Fortunately, I was able to open the project in Premiere Pro 15, which doesn't have this bug.  (I'm uncertain whether I'm creating possible problems by opening in Premiere Pro 15 a project that was previously edited in the Beta...) 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 25, 2021 May 25, 2021

Copy link to clipboard

Copied

Pierre, a real pain.

 

But consider the workaround of editing in the Program Monitor until this is fixed. My post here links to a workflow by Matt Young that makes that work better than editing in the Text Panel.

https://community.adobe.com/t5/premiere-pro/captions-are-extremely-buggy-in-the-15-0-premiere-update...

 

Stan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 26, 2021 May 26, 2021

Copy link to clipboard

Copied

A fix just got checked in and should show up in the beta build in the next day or two.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

Yay! Fixed in Build 8! 😆
(...haven't checked any languages other than English though).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 26, 2021 May 26, 2021

Copy link to clipboard

Copied

Thank you!

Pierre
------------------------------
Pierre Sauvage (sauvage@chambon.org)
*Weapons of the Spirit* and other documentaries

Chambon Foundationand Varian Fry Institute
8033 Sunset Boulevard
Los Angeles, CA 90046-2471
Tel: (323) 650-8986
------------------------------

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

In build 7, it's still black on black.
Also, when I type in Hebrew, the order of the charachters gets reversed in the program monitor. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

LeTron, thanks for reporting on Build 7.

 

Regarding Hebrew, see Mike Berry's post:

https://community.adobe.com/t5/premiere-pro-beta/a-bug-in-importing-hebrew-srt-to-caption/m-p/118987...

 

Stan

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

Thank you! It looks like the black on black issue was resolved in build 8. And also the link to the Hebrew issue gave me the info I needed to resolve the reversed text problem I was having. Much appreciated!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

LATEST

Thank you everyone for the quick verifications! You beat me to it. The text fix was added in 15.4 Beta build 008.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines