Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Adobe Premiere Pro 2021 Freeze PC 4K Editing

New Here ,
Jan 18, 2021 Jan 18, 2021

Copy link to clipboard

Copied

Hello,
First of all, I'm sorry for my bad English

 

So I just editing 4K Footage and downscaled it to 1080p, I also edit it with a proxy so my pc can work faster. But when preview 2-3 minutes of my sequence, my Premiere pro got freeze and I can't move my mouse and operate my keyboard. 

 

Already change my Scratch Disk to SSD, Preview with 1/4 quality, Close other applications that runs on my background pc.

 

Is this a bug from Premiere pro or my specification too low for handling this?

 

Spec :

Ryzen 3 2200G

16 GB Ram 3000MHz

GTX 1060 3GB

Samsung SSD 120GB

4TB Hardisk

TOPICS
Crash, Editing, Error or problem, Freeze or hang, Hardware or GPU, Performance

Views

233

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 18, 2021 Jan 18, 2021

Copy link to clipboard

Copied

I would suggest you to use render in out sequece feature in premierepro to view you content faster. here is video guide exclusive for you

https://youtu.be/mxJ5hhA_OYY

Welcome To 3-Minutes-FixIn this video we going to see How to preview your video faster in premier pro using render in and out feature adobe special guide Su...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 18, 2021 Jan 18, 2021

Copy link to clipboard

Copied

Also, make sure you check the driver for your GPU. If it's a game-ready driver, that could be part of the problem. If so, go to the Nvidia website and download/install the Studio driver. Probably the latest, though some need to go back one on the Studio driver to get reliable operation.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 19, 2021 Jan 19, 2021

Copy link to clipboard

Copied

Will try this because I'm on a deadline, thanks. Hopefully adobe can fix this soon though

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 19, 2021 Jan 19, 2021

Copy link to clipboard

Copied

I also cleared cache but it seems that and installing the studio drivers fixed the issue.

 

If your using GEforce Experience: when you click on the driver tab there's three dots next to "download/check for updates" and you can select studio drivers.

 

The studio drivers haven't affected my games so it seems this is the best way to go even if you game. If you do need to switch repeat above and select game ready drivers, geforce made it really simple.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 19, 2021 Jan 19, 2021

Copy link to clipboard

Copied

Same thing happening to me and I'm not even editing 4k. Never had a problem before with using GEforce drivers. Uninstalling and reinstalling drivers everytime I want to play a game or edit video is not ideal.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 08, 2021 Aug 08, 2021

Copy link to clipboard

Copied

LATEST

Hi,

 

I know it's an older post, but for me file -> preference -> media -> uncheck hardware acceleration AMD did the trick.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines