All fonts missing from Premiere Pro 2021!

Explorer ,
Aug 18, 2021 Aug 18, 2021

Copy link to clipboard

Copied

I recently noticed I can't access any of my fonts in PP 2021. When I use the type tool, it uses a generic font. Then when I try to select a different font, there's nothing there at all.

 

Screenshot 2021-08-19 010507.jpg

 

I click on the pulldown menu and it appears empty.

 

Screenshot 2021-08-19 010626.jpg

All my other Adobe apps have the fonts available.

 

This is my Windows computer:

Processor Intel(R) Core(TM) i9-7900X CPU @ 3.30GHz 3.30 GHz
Installed RAM 64.0 GB (63.7 GB usable)
System type 64-bit operating system, x64-based processor
Edition Windows 10 Pro
Version 21H1
Installed on ‎9/‎27/‎2020
OS build 19043.1165
Experience Windows Feature Experience Pack 120.2212.3530.0

Please help!

TOPICS
Effects and Titles , Error or problem , User interface or workspaces

Views

5.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

New Here , Aug 25, 2021 Aug 25, 2021

I've reverted to version 15.2.0, and all the fonts seem to have come back:

benreeves_0-1629887061474.png

 

Likes

Translate

Translate
Community Beginner , Oct 01, 2021 Oct 01, 2021

Hey, Sumeet! Had the same problem yesterday when I updated to 15.4 and just installed the Beta!

 

Yes - for me, the fonts are back!


Device name Editing-Station
Processor AMD Ryzen 7 2700X Eight-Core Processor 3.70 GHz
Installed RAM 32.0 GB
System type 64-bit operating system, x64-based processor
Edition Windows 10 Pro
Version 21H1
Installed on ‎8/‎17/‎2020
OS build 19043.1237
Experience Windows Feature Experience Pack 120.2212.3530.0


Likes

Translate

Translate
Community Beginner ,
Oct 01, 2021 Oct 01, 2021

Copy link to clipboard

Copied

Hey, Sumeet! Had the same problem yesterday when I updated to 15.4 and just installed the Beta!

 

Yes - for me, the fonts are back!


Device name Editing-Station
Processor AMD Ryzen 7 2700X Eight-Core Processor 3.70 GHz
Installed RAM 32.0 GB
System type 64-bit operating system, x64-based processor
Edition Windows 10 Pro
Version 21H1
Installed on ‎8/‎17/‎2020
OS build 19043.1237
Experience Windows Feature Experience Pack 120.2212.3530.0


Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 01, 2021 Oct 01, 2021

Copy link to clipboard

Copied

Glad to hear that it's working properly. Feel free to reach out if you experience any issues.

 

Thanks,

Sumeet

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 01, 2021 Oct 01, 2021

Copy link to clipboard

Copied

There's a ton of issues i nthe beta version for me - like any video I send to the timeline make the software crash. But I hope that everything will be fixed soon with a new version 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

Just as suggestion for future readers: we had this exact same issue with the last version avalaible as i write (v22.0.0 build 169) and we discovered that the problem was with a missing font that was used already somewhere in some layer (but not available in the current workstation).
Replacing it from Graphics -> Replace fonts in projects... brought back all other fonts in the software.
Cheers,

Federico

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 09, 2022 Apr 09, 2022

Copy link to clipboard

Copied

Thanks! That was exactly the problem in my case!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 05, 2022 Jul 05, 2022

Copy link to clipboard

Copied

LATEST

Same issue in 22.5.0 and this worked. I found it odd that the popup dialog didn't allow for substitution like this and trying to manually change in the layer didn't work either, but thankfully this solved all font issues for the project. Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

Had the exact same problem and read through this thread. Uninstalled 15.4.1 and was going to install 15.2 but decided to just reinstall 15.4.1 again. It worked. Not sure why that simple solution worked on my system and isn't on others. I keep my cache pretty low in cc and throughout my entire system so it doesn't bog down. Maybe a total cleansing of cache would help? I'm not certain, but just throwing it out there.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

Good to know. 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 07, 2021 Nov 07, 2021

Copy link to clipboard

Copied

Just had this issue with version 22.0

- Closed premiere

- Deactivated all the fonts through the Creative Cloud app

- Reactivated each family 

They came back.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 21, 2021 Nov 21, 2021

Copy link to clipboard

Copied

I had the exact same issue and was able to resolve it by making sure the Creative Cloud Desktop app was running while I had Premiere open. On my Windows PC, the Creative Cloud Desktop app doesn't start by default when I boot Windows (I'm sure I manually removed it from my startup programs at some point) so initially when I opened Premiere I wasn't getting any fonts at all. I saw exactly what was shown in your pictures. I then opened the Creative Cloud Desktop app and all the fonts showed up! I think it would be helpful if, in future releases, instead of showing just a blank white screen where the fonts should be there was an error message that said something along the lines of "can't connect to Creative Cloud, make sure the desktop app is running".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 01, 2022 May 01, 2022

Copy link to clipboard

Copied

I was having the same issue with Adobe fonts not showing in Premiere Pro. Following your suggestion, I closed Premiere Pro, opened the Creative Cloud Desktop app and then re-launched Premiere Pro, this resolved the issue for me as well, all my 'active' Adobe fonts are now showing. Thanks

 

Currently using Adobe Premiere Pro version 22.3.1 (Build 2)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 10, 2022 Jun 10, 2022

Copy link to clipboard

Copied

This worked. Tis the secret.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 26, 2022 May 26, 2022

Copy link to clipboard

Copied

Hi Everyone, 

I'm back on this post in 2022 and got the SAME problem. My version of Premiere Pro is the 22.0.0 and I've installed the Poppins fonts family but nothing appears ONLY in Premiere Pro. Illustrator got it, Photoshop also.
So i uninstalled the font family and activated it back with Adobe Fonts this time but it's still the same problem.
I'm currently updating my Premiere version to 22.4. Hope it will solved it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 27, 2022 May 27, 2022

Copy link to clipboard

Copied

Well i've uptaded to 22.4 and nothing change with my trouble. Poppins font family is not showing. I really need some help quickly pls

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 27, 2022 May 27, 2022

Copy link to clipboard

Copied

I suppose you could try to sign out of Creative Cloud and sign back in, if not, perhaps uninstalling and reinstalling Premiere?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 10, 2022 Jun 10, 2022

Copy link to clipboard

Copied

Adobe, how is this still an issue for over a year in new updates of software that is an industry standard? Bugs are fine in betas but you guys really need to get your stuff together. Adding "pro" to the name of software really doesn't do much does it?

 

Anyone find an actual fix yet or is downgrading to an antiquated version the magic?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 26, 2022 Jun 26, 2022

Copy link to clipboard

Copied

I just had this issue with Premiere Pro version 22.5.0 and just opening CC Desktop did not work for me. Even my locally installed system fonts did not show up at first. But I used CC Desktop to enable a **new** font and then all of my fonts showed up. Premiere Pro should have a "refresh" button to have it reload all installed fonts.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines