attach debugger stops at unknown file stack-frame-0.jsx

Explorer ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

I have a extendscript that runs successfully when running with `launch` debugger with ExtendScript Debugger but it fails when running as extendsion, so in order to find out why, I need to attach debugger to the extendsion.

 

However the debugger pause at an unknown file called `stack-frame-0.jsx`, which contains the script execution $._PPP_.importXml("parameters here"), then ends after I click continue and I can't know why my script fails.

 

I'm stuck at this point, please help!

TOPICS
SDK

Views

51

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Participant , Jul 12, 2022 Jul 12, 2022

Yep! Those configuration changes are covered in the extension's info page.

Screen Shot 2022-07-12 at 11.16.08 AM.png

Likes

Translate

Translate
Adobe Employee ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

Confirming: You've updated the ExtendScript debugger extension, yes? If so...

Where does your debugging experience, depart from this description? 

https://extendscript.docsforadobe.dev/vscode-debugger/getting-started-with-vscode-debugger.html

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

Sorry I dont really understand your question. I did update my debug extension and debug script.

 

Here is my updated debug script:

{
"type": "extendscript-debug",
"request": "attach",
"name": "[Attach] CEP ExtendScript",
"hostAppSpecifier": "premierepro-22.0"
}

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

Primary question = "What version of the ExtendScript debugger extension are you using?"

If you follow the directions at the link I sent, are you successful? If not...at what point does your experience, depart from the directions?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

I've just rolled back version from v2.0.2 to v1.1.2 and it's working now. Maybe there are some configuration required for latest version of debugger

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

LATEST

Yep! Those configuration changes are covered in the extension's info page.

Screen Shot 2022-07-12 at 11.16.08 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines