Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


BUG - Audio transition ignores amplify levels from audio ducking

Community Beginner ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

I have a music track that I've cut in order to extend the length of it for my video.  I used Audio Ducking in combination with the VO. However, at the point where the crossfade transition happens, in the exported video, the audio turns back up as if no ducking were applied.  Then when it gets to the point where the next keyframe is, the audio drops back down to that level and matches the keyframe volume as it increases.  It won't always play back that way in the editor, but it always exports out that way.  The one workaround I found is to cut the 2nd clip about a second after the transition, then remove the Amplify effect that was applied from the Ducking, and change the Volume Level to match what the Ducking had applied (in my case, -24db).  I've had this happen on other projects, but it finally got annoying enough to post about it. 

 

I'm glad to provide any info that might be needed.  I'm using PPro 15.4.1 on Windows 10 Pro.  This occured when exporting as H.264 both directly from PPro and Media Encoder.  It also happened when exporting the audio directly as a .wav file.  And this has happened on at least 2 PCs that I've used.  Thanks.

Audio transition bug.png

TOPICS
Audio, Error or problem

Views

41

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

another possible workaround would be to put the incoming audio clip on a different track with appropriate overlap on both clips and apply a audio dissolves to the outgoing and incoming clips.  If that doesn't work, keyframe the audio levels rather than applying audio dissolves.  Make sense?  if not, post back and I'll try and do a better job of explaining after my morning coffee kicks in.   

 

what are the properties of the audio files?  Uncompressed (either .wav or aiff) with a minimum of 48k 16 bit is recommended for professional video.   And another possibility, are any of your clips from a smartphone or screen recording.  If that's the case, the issue could be caused by variable frame rate clips which can have intermittent issues which are impossible to predict.   Here's how to diagnose and remedy


use mediainfo to determine whether your source is variable or constant frame rate
https://mediaarea.net/en/MediaInfo/Download
if it's variable use handbrake to convert to constant frame rate setting the quality slider in the video panel to maximum
https://handbrake.fr
and here's a tutorial on how to use handbrake
https://www.youtube.com/watch?time_continue=34&v=xlvxgVREX-Y

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

That workaround is also a good idea, thanks for that.  But the idea of keyframing the levels, while it would probably work, defeats the whole point of audio ducking.  Or are you saying to keyframe the audio levels in addition to the ducking keyframes?  If so, that might work.  

 

As for the files, they are both .wav files.  One is 48khz 16-bit, the other is 44.1khz 16-bit.  None of the audio is from a smartphone as far as I know.  The VO is from a professional VO artist, and the music is from Envato Elements.

 

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

keyframing on top of the audio ducking...  

 

And although premiere is pretty amazing in the way it can usually deal with almost anything you throw at it, there have been reports of issues when you're mixing sample rates...  (although I don't recall any posts with that issue in the past few years) so I'd try resampling the 44.1 audio to 48k and see if that solves the issue...  and of course make sure your sequence is set to 48k audio...   You might also try creating a new sequence with your desired settings and copying the contents of your original sequence to the new sequence.  Everyonceinawhile, a sequence can get corrupted and cause odd issues...

 

Post back and let us know if any of this helps...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 28, 2021 Oct 28, 2021

Copy link to clipboard

Copied

I resampled the audio to 48khz, and that did not fix anything.  The sequence is set to 48khz also.

I did try keyframing the Levels in addition to the ducking, but what that ended up doing is combining with the ducking and making the music nearly inaudible.  Without only the ducking, the volume is around -30db, and with the levels keyframed, it drops to -57db or so.  So, oddly, when I add in keyframes for levels, it then recognizes the ducking keyframes again.  I wonder if there's a reason the audio ducking needs to use the Amplify effect rather than just creating keyframes on the Volume Level setting?  

 

And creating a new sequence and copying over the clips didn't solve it either.  Actually, the audio is messing up at other areas where there are ducking keyframes now.

 

I guess the workaround right now is to skip audio ducking altogether.

 

Thanks for the help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 04, 2021 Nov 04, 2021

Copy link to clipboard

Copied

I opened the project in PPro 2022 and rendered it out, and so far there's no issue.  Let's hope it stays fixed.  I'll follow up if something changes.  Thanks for all the help.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 04, 2021 Nov 04, 2021

Copy link to clipboard

Copied

LATEST

and thanks for letting us know.    

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines