• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Can't change captions color (Premiere Pro 14.9 and earlier)

Community Beginner ,
Sep 14, 2018 Sep 14, 2018

Copy link to clipboard

Copied

I imported captions from an .srt file. I wanted to change the color, but while the captions preview shows the color change—the change isn't reflected in the Source or Project window. This is driving me bonkers.

 

You'll see I've changed the color from white to red. And while on the captions preview on the left it shows up in red. In the source file, it's not reflected.

 

Screen Shot 2018-09-14 at 6.05.04 PM.png

TOPICS
Editing , Effects and Titles

Views

2.6K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Sep 14, 2018 Sep 14, 2018

I have not been able to discover a pattern as to when these display correctly and when they don't. The more complex the project or use of multiple caption streams are, the more likely to get things out of sync.

Sometimes saving, closing the project, and reopening works. Other times simply changing focus from different panels may work. I also had a recent situation where it required cleaning the media cache and then the correct appearance displayed.

Votes

Translate

Translate
Community Expert ,
Sep 14, 2018 Sep 14, 2018

Copy link to clipboard

Copied

I have not been able to discover a pattern as to when these display correctly and when they don't. The more complex the project or use of multiple caption streams are, the more likely to get things out of sync.

Sometimes saving, closing the project, and reopening works. Other times simply changing focus from different panels may work. I also had a recent situation where it required cleaning the media cache and then the correct appearance displayed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 15, 2018 Sep 15, 2018

Copy link to clipboard

Copied

Another option: reset workspace. But that has not worked for me the last time I tried it.

This morning, for me, the appearance in the Captions Panel, Source Monitor, and Program Monitor are staying in sync. That is the way I think of this, as a sync or display problem. The actual .srt file you have imported does not change. PR keeps track of the caption streams being used in the project in the project panel. It flags a stream as edited by user or not. And sometimes, apparently, PR loses track and does not show the same thing in different places (e.g. caption panel, source monitor, program monitor). It appears to me that the correct information is always in the project file (once saved), and that getting back "in sync" should be as easy as closing and reopening.

Let us know what appears to work for you.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 27, 2018 Sep 27, 2018

Copy link to clipboard

Copied

TravisB,

Still having trouble with captions? Please let us know.

Thanks,
Kevin

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 25, 2019 Nov 25, 2019

Copy link to clipboard

Copied

I can tell you this is still a huge issue with Premiere

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 19, 2023 Feb 19, 2023

Copy link to clipboard

Copied

Still an issue, when I change text color sometimes it doesn't change in the preview display on version 23.1.0Screenshot 2023-02-19 133721.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 19, 2023 Feb 19, 2023

Copy link to clipboard

Copied

LATEST

Jay,

 

This is an old thread with an entirely different captioning system. A new post would be better.

 

But, I agree, what you show does demonstrate that a) the caption is selected and b) the wrong fill color is showing.

 

I would, in this order, reset workspace and reset preferences. If that doesn't do it, give us more information - does this happen intermittently, always, what?

 

Stan

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 28, 2018 Sep 28, 2018

Copy link to clipboard

Copied

Saving, closing, restarting all seem to work — but the main problem I think is with the .srt file. Next time I'll have to convert to another file format. Thank you all!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines