• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Captions not showing in program monitor: Premiere Pro 23.0

Community Beginner ,
Jan 22, 2023 Jan 22, 2023

Copy link to clipboard

Copied

Hi, can anyone help here?

I've created captions, they appear on the timeline and in the Text window.

But they don't show on-screen.

I click the wrench icon in the Program Monitor panel and there's no Captions option.

This used to work without a hitch but it has disappeared; I opened an old file that I created captions for and they're not showing here either. So it's the settings that have changed but I can't see a way to fix it.

And would this be connected to a recent issue where there used to be "Split Captions" and "Merge Captions" buttons in the text panel but now they're only available in a dropdown.

Very frustrated because the speech-to-text is amazingly useful ... but it needs to work !!!

Any help will be greatly appreciated...

TOPICS
Editing , User interface or workspaces

Views

401

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Jan 22, 2023 Jan 22, 2023

Steve,

 

I like this method for the screenshot better, and for an odd problem like this one, I like having this shot that shows the whole workspace. But the resolution doesn't allow me to zoom in as much as I'd like.

 

You appear to have a Subtitle type caption track and the Program Monitor set to "fit." There is no reason the captions should not be visible.

 

What version of PR are you running? What OS?

 

I notice that your timeline has a red render line. It is possible that you need to clear t

...

Votes

Translate

Translate
Community Expert , Jan 23, 2023 Jan 23, 2023

Steve,

 

> not allowing for Premiere to go all "tired" on me

 

Too funny! Many of us have tried that approach, but the usual outcome is that 2AM, "I give up!"

 

Congrats on your persistence and moving ahead. And thanks for the feedback on widening the Text panel. I was convinced there was too much empty space for that to be it!

 

In the pre-PR 2021 caption workflow, there was indeed an Enable Captions button in the Program Monitor wrench icon menu. And it also was in the Source Monitor. In that

...

Votes

Translate

Translate
Community Expert ,
Jan 22, 2023 Jan 22, 2023

Copy link to clipboard

Copied

just want to make sure you're not missing the little eye icon to the left of the caption track...

Screen Shot 2023-01-22 at 8.44.42 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 22, 2023 Jan 22, 2023

Copy link to clipboard

Copied

Screenshot to illustrate: all looks good to me but the captions (sub titles) aren't showing...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 22, 2023 Jan 22, 2023

Copy link to clipboard

Copied

ScreenShot.jpg

Thanks Michael.

As it says, I'm new here; maybe this is a better wat to show a screen shot?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 22, 2023 Jan 22, 2023

Copy link to clipboard

Copied

Steve,

 

I like this method for the screenshot better, and for an odd problem like this one, I like having this shot that shows the whole workspace. But the resolution doesn't allow me to zoom in as much as I'd like.

 

You appear to have a Subtitle type caption track and the Program Monitor set to "fit." There is no reason the captions should not be visible.

 

What version of PR are you running? What OS?

 

I notice that your timeline has a red render line. It is possible that you need to clear the render files/cache.

 

The usual reason that the merge/split icons do not show (and the plus sign - add caption is missing too) is that the Text panel is too narrow. If you drag it wider, they may appear. But your panel is not that narrow, so I'd do the reset preferences Michael suggests.

 

You have a caption track style set, but nothing odd that I can see.

 

I would experiment by restarting PR, do not open any projects, create a new project. Import one video file. Drag it to the new icon. If it is more than 2 or 3 minutes, shorten it in the sequence. then transcribe and create captions.

 

Do they show?

 

Stan

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 23, 2023 Jan 23, 2023

Copy link to clipboard

Copied

Many thanks Stan

I worked till 2am and gave up. Came back this morning, turned on the PC and what do you think ... all good ...

I guess I spent too much time looking for logical solutions and not allowing for Premiere to go all "tired" on me (but I'm really NOT a power user!!!)

Your comment on clearing the render files/cache led me to follow up on improving palyback performance (which can be choppy...) so thank you for that, too.

And your suggestion on widening the Text panel was absolutely correct.  Brilliant!

So I'm out of the woods on this.  SO grateful for your help.

Just one thing left from my original post: I click the wrench icon in the Program Monitor panel and there's no Captions option.  Here's a screen shot (full resolution!) that shows the options I get when I click the wrench icon.  Am I clicking the correct icon?

ScreenShot2.jpg

Thanks again

Steve

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 23, 2023 Jan 23, 2023

Copy link to clipboard

Copied

Steve,

 

> not allowing for Premiere to go all "tired" on me

 

Too funny! Many of us have tried that approach, but the usual outcome is that 2AM, "I give up!"

 

Congrats on your persistence and moving ahead. And thanks for the feedback on widening the Text panel. I was convinced there was too much empty space for that to be it!

 

In the pre-PR 2021 caption workflow, there was indeed an Enable Captions button in the Program Monitor wrench icon menu. And it also was in the Source Monitor. In that captions workflow, captions were Video track items, and they needed a way to turn them on and off. Now, they do it with the visibility/disable caption (eyeball) icon in the caption track. So the button is not there!

 

And you can check that one off your list!

 

Stan

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 23, 2023 Jan 23, 2023

Copy link to clipboard

Copied

LATEST

Thank you for your assistance.

So although the problem was fixed after Premiere had slept off its exertions, I'm marking your response as the Correct Answer because you cleared up all my other questions.

So I have taken another tiny step forward in achieving an almost acceptable level of proficiency...

Best

Steve

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 22, 2023 Jan 22, 2023

Copy link to clipboard

Copied

you might try toggling it off and on and see if that makes a difference.  Also, select a caption in the timeline and go to the clip menu and make sure it's enabled... Unlike video and audio clips, a caption doesn't seem to change it's appearance when it's enabled or unenabled...  And you might try resetting your preferences.    

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 23, 2023 Jan 23, 2023

Copy link to clipboard

Copied

Thanks Michael

As I said in my reply to Stan, I worked till 2am and gave up. Came back this morning, turned on the PC and it had "fixed" itself...

But regardless, your suggestions were much appreciated.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines