• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Captions .srt Export adding <b></b> to every line

New Here ,
Sep 27, 2022 Sep 27, 2022

Copy link to clipboard

Copied

Hi Everyone,

Anyone know why this happens?

I transcribe a sequence, edit text where needed in the transcribe area then I generate captions. This all works really well. But when I export a .srt file for uploading to YouTube each line in the document starts with <b> and ends with </b> as text information. Thought it was a YT thing but when I open the .srt in TextEdit its there too. So whatever Premiere Pro is generating on export is putting that text in there. I've seen it do this in the past a couple times but then not for a bit but now recently. I have changed not settings that I know of that would directly impact this. I have a work around but its cumbersome. Copying out the text, pasting in to a Google Docs, doing find and replace, pasting in then resycing the captions. I don't want to have to do this everytime I generate captions out of Premiere Pro.

 

Premiere Pro 2022 Version 22.6.2 (Build 2)

 

Mac Pro (2019)

3.2ghz 16-core Xeon W

96gb ram

AMD Radeon Pro Vega II Duo 32gb

TOPICS
Editing , Export , Formats , How to

Views

46

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 27, 2022 Sep 27, 2022

Copy link to clipboard

Copied

Hi!

I'm the one who asked the question but replying on my non-work account. I figured it out, well sorta. If you run the File>Export>Captions function then you have the option checkbox of "Include SRT Styling" which, if checked creates the <b></b> tags on each line. (Honestly, not sure where this is even useful, please inlighten me, must be for HTML..) if unchecked then it DOES NOT create those tags on each line. But the other bit to this is that where I typically export .srt from is in the Text panel in the Captions tab (attached image) there is no setting to include SRT formatting, just a typical file save dialog window (other image). It just does it all willy-nilly whatever it feels like doing. Becasue whatever the setting on the File menu export, does not impact the Text panel export option. I suppose this should go to a feature request?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 27, 2022 Sep 27, 2022

Copy link to clipboard

Copied

The bold tags are there because all your caption text is bolded. You may have applied this style or it is the default you are using. (And no, I don't think there is any control over the default style.)

 

Yes, exporting srt without styling is the way to avoid this. It it made no sense to me that they do not allow that option in the srt export from the Text panel.

 

Users may want srt styling to apply italics, bold, or underlining.

 

Stan

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 27, 2022 Sep 27, 2022

Copy link to clipboard

Copied

Ah, got it. Ok makes total sense. But what I have tested when exporting form captions panel is that it only includes the bold tags when faux bold is on, not with a font set to bold. I had the faux bold on becasue the font I was using for brand purposes wasn't behaving right, not changing appearance when bold was selected, but I found a variation we use that works. But for YouTube, font style doesn't matter, only for burning in. Anyway, good to go. Thanks!

Andy

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 27, 2022 Sep 27, 2022

Copy link to clipboard

Copied

LATEST

Correct, the srt styling does NOT carry the font/family, so the faux bold is the only way to get that.

 

Some export sidecars other than srt carry more information.

 

Stan

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines