Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Dynamic link Issue, broken, not working Adobe Premiere Pro 2022 (WITH SOLUTION)

Community Beginner ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Adobe had a new major update of their softwares (Adobe Premiere Pro 2022, AE 2022 and Media Encoder 2022)

 

After this update I got a major problem that freezed Adobe Premiere with After Effects comp (Dynamic Link not working) 

 

You can find some solutions here :
https://community.adobe.com/t5/premiere-pro-discussions/dynamic-link-broken-with-premiere-cc2020-upd...

 

Unfortunately none of them worked for me, probably because I'm on a Mac.

 

So here what I've done that worked for me.

 

First some context. 
Computer : Macbook Pro M1
Adobe Premiere Pro 2021 project with After effects 2021 Animations and sounds integrated with Dynamic Link.

 

After the update to 2022 versions, opening Adobe Premiere will freeze AE animations, will load indefinitely, or simply crash (need to force quit)

 

Solution
1- Quit all the apps

 

2- Kill the Dynamic link manager from Activity Monitor. Search for dynamiclinkmanager, click on it and then on the cross button to close / quit the app (this one is important)

 

3- Open finder then go to documents > Adobe and rename the folder dynamiclinkmediaserver to dynamiclinkmediaserver OLD (this step seems working on windows)

 

4- In finder open libraries (click on GO located on the top menu, click on alt button on keyboard) once in libraires > Application Support > Adobe and rename the folder dynamiclinkmediaserver to dynamiclinkmediaserver OLD

 

5- Turn off your mac and boot it.

 

6- Open Adobe Premiere and create a new project. Do not open the original project!

 

7- Click on file > import > entire project (choose your old project 2021, 2019 whatever)


The loading process may take longer than usual, it seems there's a conversion process from old to 2022

For me I had to do all these steps. I tried without step 3, 4 or 7 it didn't work. Not my first battle with buggy Adobe stuff.

 

Hopes it will help. Sorry for the mistakes, English is not my native language.

 

Wish you all the best from the Alps 🙂

 

Adam

TOPICS
Crash, Error or problem, Freeze or hang, How to

Views

2.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Nov 05, 2021 Nov 05, 2021
My original solution was a little off, but it looks like you guys are finding it. You neeed to go to AE Preferences, Memory & Perfromance tab, an UNCHECK "Enable Multi-Frame Rendering". I misstated it earlier. 

Likes

Translate

Translate
Explorer ,
Oct 28, 2021 Oct 28, 2021

Copy link to clipboard

Copied

Having EXACTLY the same isssues with the 2022 update. Premiere, AE and AMC have various dynamic link problems. PP needs to be forced quit every time. None of the AE comps relink in any Premeire project. I've followed your process above, done the cleaner tool routine; eveyrthing I know to try. I've cleared out as much old stuff as possible. Anyone have any answers please?

 

 Model Name: iMac
Model Identifier: iMac18,3
Processor Name: Quad-Core Intel Core i7
Processor Speed: 4.2 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Hyper-Threading Technology: Enabled
Memory: 64 GB

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 05, 2021 Nov 05, 2021

Copy link to clipboard

Copied

My original solution was a little off, but it looks like you guys are finding it. You neeed to go to AE Preferences, Memory & Perfromance tab, an UNCHECK "Enable Multi-Frame Rendering". I misstated it earlier. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 05, 2021 Nov 05, 2021

Copy link to clipboard

Copied

Thank you Jon, 

 

This is definitely the correct and much easier solution.

I made a test and worked like a charm 🙂

 

The "solution" I gave was really too complicated !

 

Thanks again

 

Adobe need to fix it.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 08, 2021 Nov 08, 2021

Copy link to clipboard

Copied

Jon - thank you for posting this!

 

I found the checkbox but wasn't able to get a successful export out of Media Encoder until I restarted my computer. For those of you who have been riding the struggle bus like me (for 10 stinking days, brooding over this issue), don't forget to quit everything and restart after you uncheck the box!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

Thanks for that solution (as I see it helped quite some people already).
Is there anything else I should be aware of or any other steps I have to concider?
The "Enable Multi-Frame Rendering" I did uncheck, closed everything and restarted the computer.
But the issue still exists. When I load a Motion Graphics Template into the timeline the progress bar is stuck at 15%.

Best, Mathias

Machine: Lenovo P520, Intel Xeon E-2125 4.00GHz, 32 GB AM, NVIDIA Quadro P400 / Sofware: Adobe Premiere Pro v14.5, Afer Effects v17.6

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

anyone realize we WANT multi-frame rendering on for AE? Thats the big news with the new AE update and if you're mostly a AE user this solution isn't the best, although it works. So basically, everytime I have a non-dynamic link project I have to remember to turn it back on. Hopefully adobe fixes this crap soon.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

That is just a joke. 

Adobe, you have to fix this asap, it's always the same when I update your products.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 08, 2021 Nov 08, 2021

Copy link to clipboard

Copied

Agreed, I'm up at 4am still trying to render a project cos of this issue, does anyone do product testing anymore or are we all just unpaid Adobe beta testers?

 

Thanks for the solution though guys, finally can go to bed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 04, 2021 Nov 04, 2021

Copy link to clipboard

Copied

This is so painfully annoying and is costing me half a working day. I left a project last nght, complete. Adobe updates on it's own accord over night, I need to do two minor tweaks and now can't access my project and my client is waiting.  I've tried a million things and have the latest Mac Book Pro. No luck. Adobe, sort it out. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 04, 2021 Nov 04, 2021

Copy link to clipboard

Copied

Yesterday I spent time with Adobe support. They had me uncheck a preference in AE that seems to have solved all my dynamic link issues. It is AE preferences and I beleive it is new. Uncheck the "multithread render" box I think in General pref tab. I'm going by memory but that miraculously solved my issuses. Good luck!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 04, 2021 Nov 04, 2021

Copy link to clipboard

Copied

Not finding that checkbox anywhere in the preferences tabs. Any chance you can point me to the right spot?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 04, 2021 Nov 04, 2021

Copy link to clipboard

Copied

here a page about this feature from Adobe :

https://helpx.adobe.com/after-effects/using/multi-frame-rendering.html

Good luck

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 04, 2021 Nov 04, 2021

Copy link to clipboard

Copied


@AdamSoufi wrote:

here a page about this feature from Adobe :

https://helpx.adobe.com/after-effects/using/multi-frame-rendering.html

Good luck


That's the one!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 04, 2021 Nov 04, 2021

Copy link to clipboard

Copied

This is the tip that will save my life with a client this week. Ae and Pr both totally opened up after unchecking this. Thank you for sharing!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 05, 2021 Nov 05, 2021

Copy link to clipboard

Copied

Worked. Well done and thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 05, 2021 Nov 05, 2021

Copy link to clipboard

Copied

That worked! Thank you!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

Today I see that Adobe released v22.0.1 which mention "multi-frame rendering". Has anyone downloaded and installed to see if it fixes the problem. Honestly I don't want to yet since it was so difficult to reslove the original issue and lost work hours. Anyone give it a shot yet?? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

I've updated it. It was like the heavens parted when I saw AE pop up on the update list. I still don't have the multi-frame rendering checked BUT the latest update has made it so I can actually export my dynamically linked graphics in my Premiere project out of Media Encoder.

 

That has been the worst part since the first update almost 2 weeks ago, and it seems they have resolved it (so far). I probably don't use these programs as intensely as some here, but the basic functionality seems to be back (for me).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

Thanks so much, this helped me a bunch! Had no idea!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 04, 2021 Nov 04, 2021

Copy link to clipboard

Copied

I used this to downgrade my Premiere File, maybe it can help? 

 

http://downgrader.elements.tv/ 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 05, 2021 Nov 05, 2021

Copy link to clipboard

Copied

Guys you need to check Jon Grimson's solution underneath... it's the only one that work without all the manipulations I shared !!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

There is an easy workaround while waiting Adobe fix this issue.

 

I render direcly from After Effects.

File - Export - Add to Render Queue

I change the Quicktime settings to Apple Prores.

I open AME and convert the MOV file to MP4, it takes a few seconds.

Don't forget to delete the MOV files, they can fill your drive really fast.

 

The solution of turning off multi frame rendering... not a solution since it cuts rendering time so much.

Why skipping this new feature when  I've been whinning about the lack of it for so many years 🙂

 

I've been able to render a project that took previoulsy 3 hours in half the time.

 

Jean 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

Just to note for people the whole multiframe rendering solution - doesn't work. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 17, 2021 Nov 17, 2021

Copy link to clipboard

Copied

LATEST

Thank you so much! this worked for me!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines