Locked

Export media way overexposed in H.264

Explorer ,
Jan 24, 2021 Jan 24, 2021

Copy link to clipboard

Copied

I work with iPhone footage a lot.  My workflow in the past has been converting the variable frame rate footage to a constant frame rate H.264 footage using Handbrake.  Then I would edit that H.264 footage in Premiere CC 2018, export it as a H.264 mp4 file,and everything was fine.

 

This month I upgraded from a 2014 MBP (16GB, OS Mojave) to a 2018 MBP (32 GB, OS Catalina) and from CC 2018 to CC 2020.  Even though I had upgraded to a faster processor with twice the RAM, I quickly discovered that my new system could not deal as well with the H.264 footage as my old system could.  I've still not figured out why that is that case.

 

Since I can no longer work with H.264 footage, I switched from Handbrake to Shutter Encoder to convert my VFR footage to CFR.  While Handbrake forced me to convert to H.264, Shutter Encoder allows me to convert to ProRes 422 LT (as well as tons of other codecs).  So I imported my CFR footage in ProRes, and everything cut together fine.  

 

But then when I went to output the finished product in H.264 (for viewing over YouTube, Insta, etc), I saw in both the Premiere export window and Media Encoder that the footage was WAY overexposed (pic atached).  However, if I clicked the "Match Sequence Settings" box at the top under Export Settings, it would output correctly.  

 

I cannot understand what is going on.  My workaround for now is to export as a Prores Quicktime, and then convert the QT file to H.64 MP4 so the file size is more manageable for internet disribution.  But I cannot understand why this is happening, and it's a pain to have to go throug that extra conversion process.  Anyone have any ideas?  Screenshots attached.

 

System:  

- MBP 2018

- OS Catalina 10.15.7

- 2.2 GHz 6-Core Intel core i7

- 32 GB 2400 MHz DDR4

- Radeon Pro 555X 4 GB, Intel UHD Graphics 630 1536 MB

- Premiere CC 2020 v14.8.0

 

 

 

 

TOPICS
Editing , Error or problem , Export , Formats , Performance

Views

16.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Feb 09, 2022 Feb 09, 2022

Flyline Prods has not returned to the post, and there is a FAQ out that solves the issue here: FAQ: How to fix saturated/over exposed HLG clips PPro v22 - Adobe Support Community

 

This is quickly becoming a catch-all post. Before that takes off, we are locking the post. If the FAQ does not solve your issue, create a new post.

 

Thanks,
Kevin

Likes

Translate

Translate
New Here ,
Oct 30, 2021 Oct 30, 2021

Copy link to clipboard

Copied

Did you ever figure this out? Having this issue! 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Oct 31, 2021 Oct 31, 2021

Copy link to clipboard

Copied

OBS, Quicktime and YouTube will display things a tad bit different. You can compensate by using a lut at export or by using a adjustment layer. The video below might be helpful. 

https://www.youtube.com/watch?v=K7EGNJop_HE

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Oct 31, 2021 Oct 31, 2021

Copy link to clipboard

Copied

If you have problems with incorrect color display in clips on the timeline, please pay attention to the new feature - interpretation of the material before editing. It works.

Screenshot 2021-10-29 111607.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 18, 2022 Jan 18, 2022

Copy link to clipboard

Copied

I also have exactly the same problem. I import the video's from my iphone 12 pro. Everthinig is fine exept the export. Still didn't find a proper solution to export in H.264

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 18, 2022 Jan 18, 2022

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 18, 2022 Jan 18, 2022

Copy link to clipboard

Copied

For starters, set the iPhone default so it doesn't shoot HLG for now. There isn't much use of HDR at this time. So leave it at SDR/Rec.709, and life is easier.

 

Next ... for HLG clips, in the bin ... right-click/Modify/Interpret Footage and set the CM section at the bottom to Override to Rec.709. Now click on your timeline panel, go to the Sequence Settings, and make sure the timeline is set to Rec.709.

 

Then you should be able to export with any of the standard presets.

 

Yea, the underlying color system of Premiere 2022 is totally different. Default behaviors have changed. And some things aren't working as the engineers expected, but though they've acknowledged and are working on things, we haven't a clue when the next step of changes will be dropped.

 

I've got a couple FAQs that go into more detail on what's changed, how to work within the new system, and where it's broken at the moment ... including proxies from HLG clips. Plus one on the new monitoring setup for HDR media if you are working an HDR timeline.

 

Neil

 

FAQ:PremierePro 2022 Color Management for Log/RAW Media



How to Set Monitors for HDR work in Premiere Pro 2022?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 18, 2022 Jan 18, 2022

Copy link to clipboard

Copied

The problem is that the iPhone 12 shoots in HDR by default while the H.264 encoder that Premiere Pro uses supports only SDR. And beginning with version 22.0, Adobe changed the way Premiere Pro handles HDR footage by default. Previous versions of Premiere Pro did not support HDR at all, and thus automatically converted all HDR footage to SDR on import/ingest regardless. You will need to conform your H.264 exports from HDR footage manually in the Export settings by checking the box marked "SDR Conform" in the Effects tab within the Export window.

 

The same thing happens when you insert that iPhone HDR footage into an SDR timeline. In this situation, you will need to apply the SDR Conform video effect to any HDR clips in that SDR timeline.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Jan 18, 2022 Jan 18, 2022

Copy link to clipboard

Copied

hey, Fly Line Prods

1. if indeed, your footage is HDR, you can tell shutter encoder to process it as SDR rec. 709 16-235 in various dropdowns, then premiere will think its SDR. You can then grade it out like log footage. 

2. shoot SDR

3. sdr conform effect like legend says

4. export HDR compatible codecs in export and upload HDR metadata to youtube for full HDR experience

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 09, 2022 Feb 09, 2022

Copy link to clipboard

Copied

I,ve just hit the same problem - after shooting on an iPhone 13 HD/30, the video looks ok in the Premier Pro 2022 sequence timeline but looks terrible on export when I'm trying to convert it to Mpeg4 for a client (its natively shot in quicktime so it looks ok as an MOV file).

So after finding SDR conform in video settings and reducing the soft knee to 25%, and also adjustign the gamma down to 11 (11 what I don't know), then rendered the sequence, and then in the export menu I...

exported it to Mpeg4  I've just found that by clicking on:

- Export settings,

- Format (choosing H264),

- Preset (Custom),

and in the Video section I clicked:

-  HDR Graphics White (Nits) 

- 300 (81% HLG,62% PQ) 

and that brought the exposure back down to where it should be.

What a palaver just to export to H.264 !

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 09, 2022 Feb 09, 2022

Copy link to clipboard

Copied

Had you tried to use the "normal" color management process, of going to the clip in the bin, right-click/Modify/Interpret Footage, Override to Rec.709?

 

And I put "normal" in quotes because it's only been with the 2022 version we've needed to worry about that phone HLG media actually being displayed as Rec.2100/HLG within Premeire. And if you simply darken the file within a Rec.709 timelne, without the override, Pr doesn't apply the corrections at export ... an acknowledged issue.

 

"Natively shot in quicktime" is actually irrelevant ... any clip should work exported to any format/codec with appropriate settings for the expected use.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 09, 2022 Feb 09, 2022

Copy link to clipboard

Copied

LATEST

Flyline Prods has not returned to the post, and there is a FAQ out that solves the issue here: FAQ: How to fix saturated/over exposed HLG clips PPro v22 - Adobe Support Community

 

This is quickly becoming a catch-all post. Before that takes off, we are locking the post. If the FAQ does not solve your issue, create a new post.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines