FAQ: Fix Hanging With After Effects 22.0 Compositions in Premiere Pro 22.0 or Media Encoder 22.0

Adobe Employee ,
Nov 05, 2021 Nov 05, 2021

Copy link to clipboard

Copied

Hi,
Edit: The current solution is to update After Effects to 22.0.1. The update is available on the Creative Cloud desktop app. 

 

Thanks,
Kevin

TOPICS
FAQ

Views

3.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Nov 11, 2021 Nov 11, 2021
Hi, The current solution is to update After Effects to 22.0.1. The update is available on the Creative Cloud desktop app. If you do not see the update, please log out of Creative Cloud application, then log back in. I had to do that. After updating, please make sure all other applications are updated to v.22, including Media Encoder. Then, restart your computer. Note: if you are on macOS, and the update doesn't appear to be working, please try the following:  Reboot the system.With Premier...

Likes

Translate

Translate
Adobe Community Professional ,
Nov 05, 2021 Nov 05, 2021

Copy link to clipboard

Copied

Dang ... multiframe rendering is SUCH a huge speedbooster in Ae. Very frustrating issue.

 

Hope this gets sorted soonest of course ... and thanks for posting!

 

Neil

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 06, 2021 Nov 06, 2021

Copy link to clipboard

Copied

Nop. It doesn't work.... I need to open PP22 with 2 diferent proyects of AE22 and doesn't work any thing I've read in the threads about this issue...

Windows 11 Pro 21H2 every Adobe App Updated 2022

Pablo

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 06, 2021 Nov 06, 2021

Copy link to clipboard

Copied

Sorry ... this is nasty for those affected. For some, turning off the multi-frame rendering is a fix, for others, no help at all. For some, opening Ae and the comps first means when they open and work in PrPro it all works. For others, nope, no help at all.

 

What the hay?

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 07, 2021 Nov 07, 2021

Copy link to clipboard

Copied

This is how the application is developed, since it is crooked. It should work stably on all operating systems. That's the main question!!! We need to think about it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 07, 2021 Nov 07, 2021

Copy link to clipboard

Copied

Yep that's fixed it thanks so much >> respect

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

Random Cat,

Thanks so much for your feedback. Helpful!

Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 07, 2021 Nov 07, 2021

Copy link to clipboard

Copied

Kevin, I hope this won't affect users on the Win platform. I have no problems with dynamic communication. Leave Win for users. It works faster

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

Baffy,

I found it works OK in new projects. Updated ones are the ones most affected by the bug. If I'm wrong about that, please correct me.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

Maybe Kevin. I think it works. I would like stability

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 07, 2021 Nov 07, 2021

Copy link to clipboard

Copied

Multi-frame rendering has nothing to do with it. It does not affect dynamic communication. The problem is deeper. Missed a moment in the update. After all, Win users HAVE NO PROBLEMS. The only problem is PLAYBACK.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 08, 2021 Nov 08, 2021

Copy link to clipboard

Copied

not true. i've updated and worked through 3 different projects. suddenly the hell started at night. i am on a windows workstation. Now, i have 3 defect projects and can't roll back without loosing 12 hours of work with a deadline in a couple of hours. Ok, one can say, why do you update?! it's dumb. that's sadly right. But it's criminal to release a piece of crap like this. I use a lot of professional software: no developer can do worse work that Adobe. All those tipps from their stuff ist like playing lotto with customers, insulting them while earning my money.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

schnudiesounds,

Sorry about that. What a bad experience. From my testing, brand new projects do not have this issue, only updated ones, and only ones using dynamic link compositions. I'm a little surprised that our Beta didn't expose this issue more readily.

 

No excuses for such problems with an update, because in a perfect world, updating software and any project should be inconsequential. That said, and speaking as an editor, it's not that way in the real world. The advice is to avoid updating any projects that are already in progress. Remain on the current version until you output.

Let us know if rolling back to the previous version helps you restore your projects and workflows. Let us also know if brand new projects are working OK.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 10, 2021 Nov 10, 2021

Copy link to clipboard

Copied

Hi Kevin, i apologize for my harsh words as it was so frustatring, that the main feature with dynamic link is so buggy. I use your software since 2005 and know that updating is always a danger. I've seen the developement of dynamic link in real work life and know that it was a long way untill it ran stable enough for professional use. In reality it's never possible to upgrade when a project ends as i am working on multiple projects all the time sometimes for moths 😉 I have tested it with other projects, but the issue didn't appear in the first couple of hours. This way i made the work with 3 projects incompatible to older versions. No going back to a previous version without loosing the work i've done. May a good implementation would be a kind of backwards compatibility.  I've tried with beta versions and got stuck in the same hassle, yesterday. I am excited for the update, that hopefully will fix the dynamic link issues. best, Sebastian

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

btw.: the update didn't fix anything. back in frustration :-))

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 08, 2021 Nov 08, 2021

Copy link to clipboard

Copied

Dynamic Link has been a buggy mess for awhile now. It was (and is) a core selling point of premiere but a lot of the functionaliy has been broken on and off over the years and this is just the latest. 

 

Heres just a small list of things that are broken:

  • Previews are lost depending on wether or not your renders were rendered with AE open or AE closed. 
  • Previews are lost in general after closing / opening the program. 
  • Tabbing back and forth with dyanmic link takes too long to update changes from AE to PR. It used to be instant now it can take up to 30s to clear a preview.
  • background AE crashes when you use "edit original" sometimes freezing even the bug reporting dialog box. 
  • There's more but overall this area of Premiere / AE needs a LOT of TLC. 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

Scrozier,

Sorry for the frustration on dynamic link. About your D/L issues, it is a way better idea to take each of these bullet points and make them into separate bug reports over in User Voice. We cannot really address any feedback directly as we are not devs here. Just support folks trying to solve problems via troubleshooting. Sorry about that.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

Kevin, the frustration is real! Dynamic Link is THE feature that I pay for as far as I'm concerned. If it wasn't for the tight integration of motion graphics and NLE I would have left Premiere for greener pastures years ago. I pretty sure I have voted on or submitted these as user voice requests but outside of the multi-frame project I find that there is little interaction from the devs on dynamic link issues or any of the other major feature requests on the AE user voice. The Premiere team responds to many of the requests but then go silent for three or more years and give us no updates on things like background rendering (last update 3 plus years ago) or background auto-save (last update nearly 3 years ago)  

 

It's telling that David Fincher gets to have Adobe software devs on speed dial to get his projects compelted, but the rest of us are left on hold for three years! People get software degrees in the amount of time it takes to implement very popular feature requests. So when people on this forum tells us to submit feedback to devs its actually quite frustrating because the development team doesn't seem to have the adequate resources to do anything about it. Correct me if I'm wrong, but I was under the impression that Adobe is a software company! Develop the software! 

 

I would say the reason so many of us are so vocal and so upset is because we do love the software and use it every day, but that also makes us more critical of the slow pace of development! Not to mention the $600 a year we pay for the privledge.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

Agree with others, turning off Multiframe Rendering in AE did not fix dynamic comms for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

Sorry about that, RNC. We'll have an update addressing this issue coming out shortly and can be previewed in the Beta version. 

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 10, 2021 Nov 10, 2021

Copy link to clipboard

Copied

I've tested the BETA versions of AE/PP and the dynamic links seems fixed there so good job on them!

What I don't understand however is why this doesn't get priority over pushing the total update with whatever else they were working on. 


I understand that from now on they want versioning uniformity across AE/PP/ME but this bug is so breaking that it should be an exclusion to this. We have about 13 workstations at our office with both Windows and iMacs from 2017 up till current date and they ALL exhibit these issues. Nobody can render projects at the moment without prerendering their AE comps to bypass dynamic link. 

 

Hope it releases soon.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 10, 2021 Nov 10, 2021

Copy link to clipboard

Copied

everyone was waiting for an update

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 10, 2021 Nov 10, 2021

Copy link to clipboard

Copied

Thanks this has worked however I now have another issue where I am unable to export my media? This update seems to have multiple issues and is affecting my workflow.

Both cmd+m and file > export > media are unresponsive and ultimately cause Premiere Pro to crash?

Any advice would be much appreciated.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

Hi,

The current solution is to update After Effects to 22.0.1. The update is available on the Creative Cloud desktop app. If you do not see the update, please log out of Creative Cloud application, then log back in. I had to do that.

 

After updating, please make sure all other applications are updated to v.22, including Media Encoder. Then, restart your computer.

 

Note: if you are on macOS, and the update doesn't appear to be working, please try the following: 

 

  • Reboot the system.
  • With Premiere Pro or After Effects + Media Encoder open while trying to render/export a project, open the Activity Monitor in the Utilities panel. Select the process "aerendercore" and force quit it with the Stop [x] button at the top of the window.
  • If you are on a Windows computer, according to engineering, you probably have a different dynamic link issue.

 

I hope one of the steps here solves your issues with dynamic link in updated projects. Let me know if you have any trouble with the update. 

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

Thanks Kevin - Updating now and will look forward to testing in the morning 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2