Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


huge performance drop since update to Premiere 2022

Community Beginner ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

Hi all, I recently upgraded to v22.0 (2022) and working on my timelines has became really slow and studdering. I feels like back in the days when I was working with a slow computer where the sound is running on but pictures drop and lag a lot when playing back the timeline. Editing is super painful and slow like that.

 

I was suprprised and also installed the former version v15.4.1 (2021) again. In this version everything is still running as smoothyl as I remember. I am working on 4K 10bit Footage without proxies but my computer is set up to handle that. I have a i7-9700K 3.60GHz with 64 GB RAM and a Geforce RTX 2060 Super. Like I wrote in 15.4.1 it works very smoothly but in v22.0 it's really not useable at all. I payed a lot of money for the hardware in order to be able to edit 4K 10bit directly without proxies for professional work.

 

I have to stay with 15.4.1 or hope for an update with a fix. Anybody having the same issues?

TOPICS
Editing, Hardware or GPU, Performance

Views

206

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Nov 09, 2021 Nov 09, 2021
have seen, in the other thread, that changing the playback quality to Full resolves the issue, works for me too

Likes

Translate

Translate
Community Beginner ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

Yes, I am facing the same issue, worked fine yesterday, having the troubles now. Works on 15.4.1 too. Working on 4k 10 Bit Slog3 footage, also without proxies .. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

I forgot to add that I am running on Windows 10 Pro.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

Thanks. I must have missed that thread when I check the search function to find similiar issues.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

have seen, in the other thread, that changing the playback quality to Full resolves the issue, works for me too

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

Yes, worked for me, too! Strange, but works.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 13, 2021 Nov 13, 2021

Copy link to clipboard

Copied

LATEST

Worked for me. Have only ever been able to get decent playback on my machine at 1/2 or 1/4 playback quality. Now get the best playback at Full quality. Windows 10 v22.0

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

The solution I have found is to import the contents of your existing project into a new project.

 

It seems to me like CUDA has been disabled when converting to CC2022. Despite  disabling/enabling CUDA in the options CPU was pinned at 100% and GPU idling.

 

After re-importing, it's back to working how it was in the previous version. Phew! Hopefully someone finds this workaround useful.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines