Mercury engine (Metal) GPU acceleration on Apple Mac M1pro 2021

Community Beginner ,
Feb 03, 2022 Feb 03, 2022

Copy link to clipboard

Copied

Using the latest version of Adobe Premiere on Apple M1pro 2021 14'', there is a bug that occurs when exporting, with Media Encoder using "Mercury engine (Metal) GPU acceleration".
The bug is a
glitch effect derived from sub graphics.
When I open Premiere 2022 "intel version" with "Rosetta2" the program works properly but is slower.

 

If I export directly on premiere software says that hardware acceleration is not supported.
On Media Encoder is possible export with Mercury engine (Metal) GPU acceleration but glitches!

The solution only software on Media Encoder is very very slowly.
I tried open the same project with last version of Premiere 2021 and I feedback the same problem.

I find the editing is too slow for a machine that promises great performances like this 😞

TOPICS
Export , Hardware or GPU , Performance

Views

142

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 03, 2022 Feb 03, 2022

Copy link to clipboard

Copied

Try this:

DisableAutoGraphicsSwitching.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 04, 2022 Feb 04, 2022

Copy link to clipboard

Copied

Hello Jeff,
Thank you for reply.
Last OS (Monterey 12.2) hasn't graphic options in battery settings.

Today I tried to export the same video 5 times and the the same error always occurs.

Everything is okay only when I export in "only software" mode. But the time difference is 45 seconds vs 9 minutes!

I hope that the Adobe developers can find a solution as soon as possible

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 04, 2022 Feb 04, 2022

Copy link to clipboard

Copied

these are the characteristics of video card

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 04, 2022 Feb 04, 2022

Copy link to clipboard

Copied

Sorry but in one of the previous posts I gave an incorrect information.

Video exports gets the same errors even if I use the intel version of Premiere Pro (22.1.2) translated with Rosetta2 together with the hardware accelerator.

I am very disappointed with an expensive program that slows down my productivity

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 04, 2022 Apr 04, 2022

Copy link to clipboard

Copied

LATEST

I am having a similar problem with a graphics intensive edit on the new Mac Studio (M1 Max). Whenever I try to export with "GPU Acceleration (Metal)" the videos glitches consistantly throughout. When I export with "Software Only" intead the export is fine, but, of course, it takes longer. Is there a fix coming?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines