No Hardware Encoding on M1 Pro

Community Beginner ,
Oct 30, 2021 Oct 30, 2021

Copy link to clipboard

Copied

Hello all, I am putting my new 14" Macbook Pro (base configuration 8-core M1 Pro) through its paces and noticed that I only have access to Software Encoding in Premiere and Media Encoder when using H.264 (Match source, high bitrate -- and I did try changing it to CBR rather than VBR per some other forum suggestions; that made no difference)

 

1. Is this an issue with the Apple Silicon chips that is yet to be updated? The GPU is a major draw for this computer to me and I'd love to be able to use it to encode more quickly.

2. Are there other codecs I should try? I tend to use H.264 for maximum cross-compatibility and have not dabbled with ProRes or any of the other multitude of options.

 

I am getting the "Your system's hardware does not support hardware acceleration for the current settings" message.

 

Thank you!

TOPICS
Export , Formats , Hardware or GPU

Views

2.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Jan 25, 2022 Jan 25, 2022
For me, it was hitting "Match Source"  which apparently enabled settings from my camera's source that my GPU could not support. Thanks,Eric

Likes

Translate

Translate
Community Beginner ,
Nov 01, 2021 Nov 01, 2021

Copy link to clipboard

Copied

For anyone who comes across this later -- it seems this issue was in my Memory settings. "Optimize rendering for:" was set to Performance, rather than Memory -- once I set it to Memory, Hardware Encoding became available.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 26, 2021 Nov 26, 2021

Copy link to clipboard

Copied

Hmm, that's really odd. I'm experiencing the same issue, but the switch to "memory" didn't fix it.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 27, 2021 Nov 27, 2021

Copy link to clipboard

Copied

Yeah, you know, going further with this I’ve found more exceptions. I’m not
sure exactly what is the cause anymore, but hardware encoding is working
for me now on ordinary MP4s.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 30, 2021 Dec 30, 2021

Copy link to clipboard

Copied

As someone who came across this later, this weirdly worked (even though, as you say below, it doesn't seem to be the actual root issue). Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 30, 2021 Dec 30, 2021

Copy link to clipboard

Copied

"Hardware" versus "Software" encoding for H.264/265 or "HEVC" exports is limited by your CPU, not your GPU.

 

It is only about whether your CPU has the extra hardware bits specifically used for 'hardware' long-GOP encoding. It has nothing whatever to do with your GPU or GPU accelerated effects within Premiere.

 

And the controls for long-GOP "Hardware" versus "Software" encoding are found in the Preferences dialog, and also in the Export dialog if you have chosen a long-GOP preset for H.264/265 HEVC.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 25, 2022 Jan 25, 2022

Copy link to clipboard

Copied

For me, it was hitting "Match Source"  which apparently enabled settings from my camera's source that my GPU could not support. 

Thanks,

Eric

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 18, 2022 Apr 18, 2022

Copy link to clipboard

Copied

LATEST

For me, it was unchecking "Export Audio" that causes Hardware acceleration to grey out.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 18, 2022 Apr 18, 2022

Copy link to clipboard

Copied

Having the same issue. But I don't see "Optimize rendering for" in Memory settings (ver 22.3.0). The only customizable adjustment is the amount of memory allocated for non-Adobe CS apps. Any ideas?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 07, 2022 Feb 07, 2022

Copy link to clipboard

Copied

I have also found that CBR encoding does not work for Hardware Encoding for h.264 or h.265. It has to be VBR it seems.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines