Nvidia G-Sync causing intermittent stuttering in Premiere (and After Effects)

Community Beginner ,
May 14, 2021 May 14, 2021

Copy link to clipboard

Copied

Just ran into this issue recently, but I have a hunch it's been around for a little while. It's an annoyance more than anything, but it seems like something that could be fixed.

 

I have a monitor that supports G-sync (Nvidia's adaptive sync technology) that I use for games. By default, G-sync will remain "on" globally (even on the desktop) unless you force it off. I've noticed that, when it's on, if I'm in Premiere then (about 50-75% of the time) whenever I start/stop playback, move a clip on the timeline, or open something in the source monitor there is a brief half-second or so where the mouse cursor skips around like the program is hanging or freezing. It makes the program feel a lot more sluggish than it actually is.

 

It took a bit of troubleshooting to realize that G-sync is the issue, but it definetely is. If I turn it off the weird stuttering goes away (and everything is nice and smooth). If I just move the Premiere window fully over to to my second non-gsync monitor, it goes away. If I just move the playback window to the second monitor, but leave everything else behind, it goes away. 

 

Seeing all this, I turned the "G-sync indictator" on in the nvidia drivers. This shows when G-sync is on or off, and it pretty clearly revealed what was happening.  As you start and stop playback, or make any other big "change" to the program or source monitor, it switches G-sync off and then back on for some reason. This seems like either a bug in Premiere or in the Nvidia drivers, I'm not sure which. I've had a g-sync monitor and used Premiere for quite some time, so I know this hasn't always been the case.

 

I should mention that this happens in After Effects as well, but not any other programs on my computer as far as I can tell (or at least am able to notice).

 

Right now I'm just turning off g-sync whenever I'm editing, but I feel like there has to be a better solution to this. Does anyone else have experience with this weird behavior?

TOPICS
Error or problem , Freeze or hang , Hardware or GPU , Performance

Views

1.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 14, 2021 May 14, 2021

Copy link to clipboard

Copied

I might rush to the assumption you're using the game-ready drivers? As you mention gaming on that rig.

 

Unfortunately, the game-ready drivers are a constant source of troubles in PrPro. The studio drivers are far more solid. For whatever reasons.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 14, 2021 May 14, 2021

Copy link to clipboard

Copied

Ah, that is a very good point. Currently I'm using the newest 466.27 game-ready driver. I'll be able to test out the studio driver later and will post the result.

 

Yes, this computer is used for games as well so that it would certainly be annoying to have to pick between performance in games and stability in Premiere, but that may just be the way it is!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 23, 2021 May 23, 2021

Copy link to clipboard

Copied

Finally got around to testing this and I've learned a few things!

 

I went to the most recent studio-driver (462.59) only to discover that the weird stuttering with g-sync was still present. I even went so far as to do a full clean install with DDU just to see if that was the issue, but it wasn't.

 

This triggered the tedious process of going back in time one driver version at a time to find when it went away. Eventually I got impatient (after getting to around 461.92) and just skipped straight to the oldest one available on the nvidia website: game-ready driver 457.09 from October of last year. And it was here that the problem completely went away.

 

I haven't narrowed it down any further than that yet, but this confirms that it is driver related. Somewhere between 457.09 and 461.92, nvidia introduced a bug that falsely enables/disables g-sync within Premiere Pro and After Effects. It's not a game-ready vs studio-driver thing per say, but it definetely is something happen in the driver.

 

I'll try and figure out exactly when it happens, but if anyone else has any thoughts on this issue that would be appreciated! I'll probably go post on the nvidia forums as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 02, 2022 Jul 02, 2022

Copy link to clipboard

Copied

I'm very thankful for your post and your follow-up. I just finished building a new PC and I've been running into a lot of challenges. Noticed a weird stuttering when using Adobe products (while scrubbing in Premiere Pro, also while zooming in/out in Photoshop) and I was worried something serious was wrong, like something with my CPU. Thankfully turning off G Sync fixed it and everything runs smoothly! 

It is disappointing, though. I want to use G Sync and I don't want to have to disable it every time I open Premiere. 

The weird thing is I never had this issue on my old rig. I had the same monitor but I had a GTX 1080 Ti. I guess the drivers for that don't cause the bug. 

I'm using an RTX 3090 Ti now and I'm encountering the issue. Maybe it has something to do with RTX cards. 

I'm going to see if there's a way to disable G Sync per app. I guess I could also try NOT running Adobe apps in full screen. Maybe if I run them windowed it won't be an issue. Worth a shot I guess. I'll report back after some testing. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jul 02, 2022 Jul 02, 2022

Copy link to clipboard

Copied

I have this issue too (both on PR and AE). I recently upgraded to a 3060 Ti and G Sync would constantly crash some effects. For me though, I don't find G Sync useful anyways, since I don't do a whole lot of gaming. 

 

I presume that this is something that will eventually get fixed. A lot people use G Sync so I could've  imagine this being an issue.

 

Dont know of any way to disable G sync on some apps. Best bet is to turn it off when using Premiere.


~Jake

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 02, 2022 Jul 02, 2022

Copy link to clipboard

Copied

I went into the G Sync Program Settings in the NVIDIA Control Panel and changed the Monitor Technology from GSYNC to Fixed Refresh for Adobe Premiere Pro. Unfortunately, the screen just kept flickering black (I assume this is where the stuttering was happening with GSYNC on, but instead of the screen turning black, GSYNC "fixed" it).

 

This is really a shame. I'll keep searching for solutions and report back here if I find any. I've seen posts about this dating all the way back to 2020, so I'm not very hopeful that it's a bug that will be fixed any time soon...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 02, 2022 Jul 02, 2022

Copy link to clipboard

Copied

Same with me...had a 1080ti and no problems.. changed to a 3070 and this
problem started

Nothing works...tried everything..only thing works is turning off Gsync

Anyway wish you all the best in trying to find another solution....hope you
do

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 02, 2022 Jul 02, 2022

Copy link to clipboard

Copied

I actually DID end up finding a solution that worked for me! (Well, a solution that isn't just toggling g-sync on and off whenever I needed to edit video vs. playing games.) Thanks for making these recent posts since it slipped my mind and I definetely wanted to update you guys here!

 

I found a totally unrelated set of forums posts about "flickering" happening in certain applications since nvidia driver 461.09 (so I was right on the money with my earlier tests!). You can find the official nvidia support post about it here:
https://nvidia.custhelp.com/app/answers/detail/a_id/5157

 

Here is a reddit thread about the same issue in the Unreal Engine editor:
https://www.reddit.com/r/unrealengine/comments/r18jjh/nvidia_bug_help_please_im_having_this_issue_si...

 

There is a windows feature called "multiplane overlay" which, in certain specific configurations of software, hardware, and drivers causes random flickering whenever the applications are resized or updated in a signifigant way. My understanding is that, most of the time, the purpose of multiplane overrlay is to give applications the freedom to control and ovveride certain video settings (like V-sync) where they couldn't before. It seems to have created some additional complications as a result, however.

 

For me it was night and day. I went to that official nvidia page (linked above), downloaded the registry patch and applied it, turning off multiplane overlay. After a reboot the flickering in adobe apps was gone completely, regardless of my g-sync setting. If I re-enabled multiplane overlay the flickering came back instantly, and didn't go away until I disabled mpo again. So it's very clear that multiplane overlay is the culprit here.

 

It's possible that nvidia has fixed this issue natively in newer driver updates, and I've also upgraded my GPU since I originally had this issue, so I can't comment on how universal this fix is. But it definetely worked for me, and seems to have worked for a lot of other people too. It only seems to crop up with specific combinations of hardware and software, so its possible this issue will haunt us for a while.

 

If any of you are able to test out disabling MPO, let me know the results!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 02, 2022 Jul 02, 2022

Copy link to clipboard

Copied

LATEST

Thanks for posting, that's incredibly useful information ...

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
May 14, 2021 May 14, 2021

Copy link to clipboard

Copied

That is good to know.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 07, 2021 Jul 07, 2021

Copy link to clipboard

Copied

I have the same problem. I think I managed to solve it by going to the Nvidia control panel and under "Set up G-sync" I checked the Enable for full screen mode. Hope it works for you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines