Premiere Pro 2022 glitching and lagging

Community Beginner ,
Mar 04, 2022 Mar 04, 2022

Copy link to clipboard

Copied

For the past month or so, my Premiere Pro has been glitching and lagging to the point I can't even use it. This happened out of nowhere and I have not been able to edit my projects whatsoever since. I was on the phone with customer support at least 6 times this week, and no matter how many troubleshoots or fixes they tried to do, nothing worked no matter how many times they tried and no matter how many times I tried to explain that this is a problem others seem to be experiencing. The senior technician even said we tried every possible fix to no avail. I was told today that completely factory resetting my Mac would be a surefire fix, and after a 30 minute trip to the Apple store, and after an hour and a half long wait for the reset, I reinstalled Premiere on my computer only for it to still not work. I tried to be patient but at this point, I'm completely aggravated that a product I pay hundreds of dollars for each year is virtually unsuable. I think it's safe to say this is in Adobe's or Apple's hands now, because clearly other people have been having the same problem. Hopefully this gets fixed soon so until then I'll have to switch to another product. 

TOPICS
Error or problem , Freeze or hang , Performance , User interface or workspaces

Views

384

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 05, 2022 Mar 05, 2022

Copy link to clipboard

Copied

Hi there,

 

We're sorry about the poor experience. We can get this checked. Are you experiencing the lag during playback, or is it with the UI? Also, let us know the type of media files you are working with (format/codec, frame rate & frame size) & the system specs.  We're here to help, just need more info.

 

Thanks,

Sumeet

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 05, 2022 Mar 05, 2022

Copy link to clipboard

Copied

I'm experiencing a lag with legitimately everything I do, I can't perform any basic task. It's already been confirmed the files aren't the problem, although I use .mov files filmed from my iPad. The Apple employee who helped me reset my computer even said that if the hard reboot didn't work, it might have to do with something on Adobe's end or Apple's end.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 05, 2022 Mar 05, 2022

Copy link to clipboard

Copied

Clearly, many others working away without troubles, on Macs. Some users are having varied issues. So we need to sort out what is causing such behavior on yours. Which is always a troubleshooting process. And we don't know what's been tried, so ...

 

Which Mac, what's the full hardware setup for that? What are you using for drives for media, cache, and project storage? What media are you working with, what effects are used? Any third-party plugins?

 

If we can get an understanding of what you're working on, with what media and effects, we can start divining what the hay is causing such awful behavior.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 07, 2022 Mar 07, 2022

Copy link to clipboard

Copied

Pretty much everything has been tried at this point from clearing media cache to changing preferences, and to factory-resetting my Mac, as I said. I have a MacBook Pro, the processor is 2.4 GHz 8-Core Intel Core i9. The only drive I use is my backup drive to save stuff occasionally. I'm using .mov files from my iPad, not really any effects. No plugins. I have 1TB on my computer and there's still 700GB left. Premiere slowly started to get buggier and buggier until eventually it got to where it is now. It was fine up until mid-January maybe. I'm expecting a follow-up call tomorrow from customer care, so we'll see what they have to say.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 07, 2022 Mar 07, 2022

Copy link to clipboard

Copied

That's rough, really. You do have my sympathy.

 

But with the media only from your iPad, I'm wondering what it performs like with 'normal' camera produced media?

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 07, 2022 Mar 07, 2022

Copy link to clipboard

Copied

I have projects that're just color mattes with text, and they still don't work. My entire Premiere Pro is not working up to par, but everything else on my Mac is perfectly fine. Customer care thinks it might have to do with the permissions on my main user since Premiere was smoother in a root user.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 10, 2022 Jun 10, 2022

Copy link to clipboard

Copied

LATEST

I have the same problem, I thought it was my laptop, Macbook Pro 2017-2.9Ghz Quad Intel Core i7, 16GB 2133 Mhz ram. All camera footage plays back with lag! Drone footage or gopros are unusable, have to review eveything real time, if i try to scan faster, everything locks up, sometimes 20-30seconds before image updates. 

Collegueas overseas I share projects with were still on 2021, then they updated to 2022 and all complained of same issue, that's when I realized it is fault of 2022. 

I have tried all the fixes, nothing fixes it. It is frustrating beyond belief, and I want to throw the whole the entire program in the garbage. Very sad to see such an essential aspect of editing get ruined.

Please FIX NOW!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines