Premiere Pro CC 2018 using 98% Memory

Community Beginner ,
Oct 18, 2017 Oct 18, 2017

Copy link to clipboard

Copied

2018 update came out; very excited, updated my Premiere Pro, started it up only to have it chew through my memory and sit at 98%.

I have 8Gb's installed RAM and around 6Gb's is allocated for Premiere Pro.

Anyone else having this problem?

Cheers

Oh and Adobe removed version 2017 which is very annoying as I have due projects. The older versions is 2013 or CS6, haha no.

Views

14.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 18, 2017 Oct 18, 2017

Copy link to clipboard

Copied

Hello.

The same is happening to me. I tried to open a project with about 9 hours of video..

Since the project is not compatible with this new version, I had to save it as another name, and Premiere started to do his usual stuff (I forgot the name now, sorry) but basically it is working on each video and you can see it happening on the bottom right.

My computer crashed at first since it wasn't taking care of my memory preferences, it was using mostly ALL of my memory (32 GB).

So I opened the task manager to see the memory used in total, open Premiere Pro, opened my project, and every time the memory was 90% full, I save the project, and quit Premiere Pro. And I relaunched PPro again, loaded my project, and did the same, as many times PPro needed to process my videos.

Now it is working, so if you have to work on a big project and this is happening to you, that is a "workaround", but this is not a normal behaviour...

Good luck!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 18, 2017 Oct 18, 2017

Copy link to clipboard

Copied

Spot on!

Due to having a big project and premiere reloading all the footage again cause this high memory.

But after many restarts and fully loaded the footage it's sitting fine now.

I agree that this is not normal behaviour; still not happy that they removed version 2017.

Cheers~

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 31, 2022 May 31, 2022

Copy link to clipboard

Copied

LATEST

This is beyond normal. A project which only has 3 layers, one sound track and lasts 30 seconds uses 30GB of my memory. I suspect it's because of the video format of one of the layers - *.mov

But the posts are from 2017 and we are in 2022 and the problem still exists. I'm of the same opinion as CORRIDOR CREW that this program needs to be rewritten because it's already too much.

30 seconds.
3 layers
1 soundtrack
30GB RAM.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 06, 2017 Nov 06, 2017

Copy link to clipboard

Copied

I have the same problem. Every day I expect an update but nothing happens.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 03, 2017 Dec 03, 2017

Copy link to clipboard

Copied

For me the problem isn't fixable by saving, closing and opening again.  Mine is happening during rendering.  I have 3 hours of video.  Numerous adjustment layers with Lumetri color.  When I say numerous, they are all on the same second layer, just multiple because I have had to color correct different parts of the video differently.  Plus a separate adjustment layer with unsharp.  Tried with Cuda without cuda on software, memory setting to performance or memory priority.  Adjusted down the memory premiere could use.  About 2/3 of the way thru it runs out of memory, app crashes.  In a lot of cases, the computer becomes unresponsive and have to hard reset it.  This is horrible.  And I already saved the project as a 2018 version so can't go back to 2017 as 2017 won't open it anymore.  Only thing I could think of similar to the editing suggestion.  To break the video into segments and encode each one separately, and perhaps try to splice them together afterwards?

Note content is a single AVI file with Lagarith codec.  Have run this thru many time with 2017 so know it's not a file problem.  Also have 16GB of RAM and nothing else running.

JR

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 04, 2017 Dec 04, 2017

Copy link to clipboard

Copied

Some more info.  Dug into this more and saw a second message from premiere on rendering that it ran out of drive space.  Thought that was odd.  So moved 100GB to another drive.  Ran it thru again and noticed more closely that the two error messages that come up, first a pop-up, second a message within Premiere, was one out of memory, which I can see as my task manager shows it maxed out.  The second out of drive space.  But I still have 160GB free and the file rendered to date is about 77GB.  Same as it failing last time.  I can not it makes a reference to Lumetri Color in the error message.  For whatever that's worth.

JR

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 04, 2017 Dec 04, 2017

Copy link to clipboard

Copied

Are you rendering (creating previews) or exporting?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 04, 2017 Dec 04, 2017

Copy link to clipboard

Copied

My iMac is 32GB ram. I have the same problem. I can't edit any more. Alway force to quit.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 04, 2017 Dec 04, 2017

Copy link to clipboard

Copied

Jim, in my case exporting.  Tried both thru Premiere Pro and thru Media Encoder.  With Cuda, Software Only, changing memory available to Premiere.  Right now staring at task manager at 17% CPU utilization and 12GB RAM at 96% of system ram.  Disk is running at 1% usage right now.

JR

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 06, 2017 Dec 06, 2017

Copy link to clipboard

Copied

OK.

Have you tested other export formats?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 01, 2019 Feb 01, 2019

Copy link to clipboard

Copied

I had the very same problem with the 13.0.2 version. 59 of 64 GB ram where used, working was almost impossible! I then realized that I imported some M2TS (and Mp4 and movs) that day. I guess it had been the MTS clips, they suck big time since the invention of comsumer-Cams. So I decoded them (into dnxhd) -  and, fingers crossed, problem solved (I hope;-)

Just say NO to M2TS!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

I started PrPro today, it stuck with 98% again. So now what, Adobe ??? All M2Ts files are gone, but still. Are there any solutions as I cannot work on this project anymore? Cache had been deleted before, but maybe I should give that another try... 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 21, 2019 Apr 21, 2019

Copy link to clipboard

Copied

You have 9 hours of video, what do you expect

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 03, 2017 Nov 03, 2017

Copy link to clipboard

Copied

This is totally incorrect. And its a shame you have marked it correct.

Denying others possible help from experts.

The Software freezes uses up RAM even at startup with no media added to the project yet.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 05, 2017 Nov 05, 2017

Copy link to clipboard

Copied

Interesting because that doesn't happen to me. It opens up fine with memory sitting below 30%.

The only time it causes high end memory and freezing is when I open up old projects that need to process the footage again; seems fine with just importing new footage.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 25, 2019 Dec 25, 2019

Copy link to clipboard

Copied

%Has anyone found a solution to this?

I have the same problem all of a sudden on Premiere Pro 2018 for windows, memory goes up to 98% use. My RAM is 8 GB. And I've been editing larger projects before without a problem.

Please help, I'm losing second day of work on this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 15, 2020 Apr 15, 2020

Copy link to clipboard

Copied

Hey there, I am not sure if you found a solution or not. But I am also facing the same issue. I just purchased an iMac 2019 and it arrived this wee. It is a substantial investment for me to be able to edit and work from home since I don't have access to my university's suits during the pandemic.

 

This is exactly what happens: When rendering a 50-minute film, which is only HD footage, the Activity Monitor shows that the premiere suddenly shoots up the memory usage.  All of a sudden from using 6-7 GB it goes all the way to 20, then 40, and then to 60GB, at which point the computer gives the message "there is not enough application memory."! 

I have to force quit premiere and repeat the process which so far has resulted in no success.

 

This iMac is brand new; it has a 3.6 8- core 1-9 processor, Radeon Pro Vega GPU, and 1TB SSD Storage, and 8GB RAM. I invested in the CPU and GPU and decided to upgrade the RAM later to 32 GB. I am in shock about this and very stressed, to be honest. The storage is basically empty as I always work from Hard Drives and since it is brand new I literally have nothing on the desktop yet. 

 

Is this a premiere problem or the new macOS?

 

Please help!!!

 

Thank you from NY! 

 

 

Anyone has 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines