• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

"Replace With Clip" not working

Explorer ,
Apr 26, 2017 Apr 26, 2017

Copy link to clipboard

Copied

I just upgraded to Premiere Pro CC 2017. Much to my dismay, the "Replace With Clip" functionality is not working.

I've restarted Premiere and restarted my computer with no results. I'm certain I have the clip selected in the bin and the clip selected in the timeline.

I'm working on a PC running Windows 7 with plenty of RAM (16GB). I've never had this problem until I upgraded to 2017.

Here's a screenshot. The "Replace With Clip" item is greyed out in the contextual menu. My keyboard shortcut to "Replace With Clip from Bin" does not work either.

I use this function all the time and need to find a solution pronto!

Premiere Pro 2017 - replace clip unavailable.jpg

Views

45.3K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jan 24, 2022 Jan 24, 2022

Joe,

Sorry. I tested the issue and it works as it used to in previous versions. That is, I have a floating bin and the command is no longer disabled.

 

Thanks,
Kevin

Votes

Translate

Translate
LEGEND ,
Apr 26, 2017 Apr 26, 2017

Copy link to clipboard

Copied

I can't recreate this problem. also tried Ai files. have you tested if this happens with all clips? video? other?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 26, 2017 Apr 26, 2017

Copy link to clipboard

Copied

It happens on all types of clips.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 26, 2017 Apr 26, 2017

Copy link to clipboard

Copied

could be corrupted preferences? try resetting it: FAQ: How to reset preferences in Premiere Pro? in the meantime you can Alt drag the new over the old I suppose.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 26, 2017 Apr 26, 2017

Copy link to clipboard

Copied

Alt-drag works. I never knew about that method.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 26, 2019 Jul 26, 2019

Copy link to clipboard

Copied

thank you thank you! Alt(Option)-Drag is the only thing that worked for me!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 16, 2021 Sep 16, 2021

Copy link to clipboard

Copied

THANK YOU THIS WORKS SO WELL!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 13, 2022 Apr 13, 2022

Copy link to clipboard

Copied

Sorry about that, Derek. Looks like the bug is persisting. Can you add your voice by upvoting this bug report? I'll see what I can do to advocate for a fix: https://adobe-video.uservoice.com/forums/911233-premiere-pro/suggestions/34906672-bug-replace-with-c...

 

Thanks,
Kevin

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 13, 2022 Apr 13, 2022

Copy link to clipboard

Copied

Will do, Thanks Kevin. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 02, 2024 Feb 02, 2024

Copy link to clipboard

Copied

Alt+drag is AMAZING. Still works in 2024. Thank you SO much for coming back to comment about that. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 05, 2024 Jun 05, 2024

Copy link to clipboard

Copied

LATEST

Thank you! Awesome tip, and I, too, was having this issue! 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 01, 2017 May 01, 2017

Copy link to clipboard

Copied

Got 3 hours into my template for work, only to realize this function no longer works with the latest update. Please, Pretty Please Adobe, fix this RIGHT NOW

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 02, 2017 May 02, 2017

Copy link to clipboard

Copied

patricke23597635  wrote

Got 3 hours into my template for work, only to realize this function no longer works with the latest update. Please, Pretty Please Adobe, fix this RIGHT NOW

what exactly does not work? what kind of clip do you have there? what assets are you trying to replace? I have not being able to reproduce Op's issue and Ai files can be replace as expected. please specify the exact nature of the problem with screenshots/video capture if possible

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 02, 2017 May 02, 2017

Copy link to clipboard

Copied

The whole "Replace Clip" drop down and tooltip options are grayed out. I'm trying to replace a png, with another png from my bin. The issue is across the board with all types of content and clips affected (stills, audio, video). It's like the latest update completely broke the coding for this kind of behavior. The Alt Drag method works (and bailed me out yesterday, thanks) but is tedious. Screenshots of the Greyed out tooltips attached. Nuking all of my preferences just to MAYBE fix this issue isnt really an option either.

Screen Shot 2017-05-02 at 8.56.52 AM.png

Screen Shot 2017-05-02 at 8.58.51 AM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 09, 2017 May 09, 2017

Copy link to clipboard

Copied

I'm having the exact problem.  I can't access the Replace from Bin option because Replace With Clip is greyed out. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 12, 2017 May 12, 2017

Copy link to clipboard

Copied

Exactly the same synthoms.  Have used this function since day one on all other versions through time, but after last update (may 2017) this option is "grayed out" but not the other options.  (Replace With Clip --> From Bin)

0000aaaa.jpg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 13, 2017 May 13, 2017

Copy link to clipboard

Copied

Can you upload a file that does this problem? Maybe a project file too? If we cab reproduce it we might find a workaround or accurately report it

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 13, 2017 May 13, 2017

Copy link to clipboard

Copied

Make new project, import old one and try again.

See how that will work.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 15, 2017 May 15, 2017

Copy link to clipboard

Copied

The Plot thickens, I managed to get Replace with Clip from Bin functionality working again by closing out ALL Project panel tabs except for one. I have a dual monitor setup, and Premiere was sneakily opening up another project tab, causing there to be two project tabs open (one on each monitor). Premiere get's extremely confused trying to figure out with project pane get's priority when two are open.

TLDR; Make sure only ONE instance of the Project Pane is open, that seemed to fix the issue for me.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 03, 2021 Jun 03, 2021

Copy link to clipboard

Copied

This worked for me closing all the other project panels. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 15, 2022 Jun 15, 2022

Copy link to clipboard

Copied

This worked for me as well.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 28, 2023 Oct 28, 2023

Copy link to clipboard

Copied

2023, this worked for me.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 24, 2017 May 24, 2017

Copy link to clipboard

Copied

I'm having the same issue with all my projects both old (prior to update) and new (created after update). It is very frustrating as I have several weekly clients that require simply the replacement of pics and fonts on the timeline with other pre-made  pics and fonts stored in the bins. Alt-drag works but the point is that there has been a heavily used "Replace Clip" option in the past and that there is still a tease of it being there.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 24, 2017 May 24, 2017

Copy link to clipboard

Copied

Did you try my fix by Hunting down and closing any copies of your project bin?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 19, 2017 Jun 19, 2017

Copy link to clipboard

Copied

I've been experiencing the same issue. Here's my write-up:

Description of Bug: When multiple bin panels are open, PPro 2017 will only allow the “Replace Clip from Bin” command from the most recent open bin. Previous versions allowed this command from any bin panel.

Steps to reproduce bug:

  • Open project.
  • Open a second bin panel.
  • Select a clip in the original bin panel.
  • Select a clip in an open sequence.
  • Right click the selected clip and navigate to the “Replace With Clip” menu. Observe the submenu, the “From Bin” option is not selectable.

Expected behavior: In previous versions of PPro, the replace with clip from bin command was available from any open bin panel. This made for simple navigation for large projects with multiple replaceable elements. In it’s current state in 2017, one can only have one bin panel open, which requires a LOT of scrolling to locate replaceable elements.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines