Subtitles timing off upon export (Premiere Pro 14.9 and earlier)

Community Beginner ,
Apr 04, 2020 Apr 04, 2020

Copy link to clipboard

Copied

Premiere captions timing does not match with the exported .srt timing. What to do?

Within Premiere, I have created subtitles that sync with my 30fps sequence. Everything syncs up fine within Premiere.

However, when I export the file to .srt, all of the timings change.

Screen-Shot-2020-04-04-at-1.25.23-AM.jpg

The image shows the difference in timestamps for the captions within premiere and in the exported .srt file.

 

I tried fixing this by changing framerates in Subtitle Edit and by using the Point Sync feature, but to no avail. Any ideas?

TOPICS
Error or problem , Export , How to , User interface or workspaces

Views

3.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Apr 04, 2020 Apr 04, 2020

The timecode in your second example appears to be different.

 

The 1,935 corresponds to 01:23 (i.e. 935 milliseconds is 23 frames in 29.97).

 

When I created the test with your first timings (1:29 and 6:24), the SE source was 1,968 and 6,806. 

 

So, as I say, are you sure the timings are off when played with your exported video?

 

You can test this further by burning in the captions and playing back with the srt on/off.

 

Stan

 

Likes

Translate

Translate
Adobe Community Professional ,
Apr 04, 2020 Apr 04, 2020

Copy link to clipboard

Copied

They actually appear to be correct - except that the display of the timecodes in your export is cutting off the end of the milliseconds. Look at the "Source view" in Subtitle Edit. Are they actually out of sync with the video?

 

SRT files are often written with the frames converted to milliseconds. You'll see in PR that the option for milliseconds vs frames is now greyed out, and you only have the option for milliseconds.

 

Your 1:29 and 6:24 convert to 1.968 and 6.806

 

How did you change the framerate in SE? I thought I knew how and couldn't find it doing a recent test.

 

Stan

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 04, 2020 Apr 04, 2020

Copy link to clipboard

Copied

Hi Stan,

These are the source views for the exported .srt file. Is there something that I am missing?

 

1

00:00:00,000 --> 00:00:01,935

 

2

00:00:01,935 --> 00:00:06,773

 

As for changing the framerate in Subtitle Edit, click Synchronization > Change frame rate, then select the options for input/output frame rate.

 

If you can give me some guidance as to syncing the exported .srt, I will be eternally grateful.

 

Cheers,

hellomister

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 04, 2020 Apr 04, 2020

Copy link to clipboard

Copied

The timecode in your second example appears to be different.

 

The 1,935 corresponds to 01:23 (i.e. 935 milliseconds is 23 frames in 29.97).

 

When I created the test with your first timings (1:29 and 6:24), the SE source was 1,968 and 6,806. 

 

So, as I say, are you sure the timings are off when played with your exported video?

 

You can test this further by burning in the captions and playing back with the srt on/off.

 

Stan

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 04, 2020 Apr 04, 2020

Copy link to clipboard

Copied

You indeed are a life saver. I can't believe I spent six hours trying to figure this out.

 

Working between Premiere, Subtitle Edit, Aegisub and YouTube got me confused. Thanks again, Stan.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 04, 2020 Apr 04, 2020

Copy link to clipboard

Copied

Excellent! Glad you got it sorted. Yes, some of my knowledge is also the product of those long, frustrating sojourns into what turns out to be simplicity.

 

Stan

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 10, 2020 Dec 10, 2020

Copy link to clipboard

Copied

Here the same problem, but then on a frame rate of 23,976... 

I am struggling for 24 hours now on a subbed clip of 1 hr 10 mins.

I do not understand what your solution is, Stan. What must I do step-by-step in Premiere to resolve this problem?

I'm getting crazy down here...

 

Greetings from The Netherlands,

Maurice

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 10, 2020 Dec 10, 2020

Copy link to clipboard

Copied

Please provide a screenshot example of the differences you are seeing.

 

Stan

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 06, 2022 Jul 06, 2022

Copy link to clipboard

Copied

Hello all!

I'm having a similar issue, I think... Everything times fine in the timeline but I export my .srt from Premiere Pro (2022) and import into my existing Vimeo page for the video and the subs are about 3 seconds early throughout. I've double checked the frame rate on both the Vimeo file and the Premiere file exporting the .srt and they match. Any ideas?

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 06, 2022 Jul 06, 2022

Copy link to clipboard

Copied

In the srt, what is the timecode of the first sub? Is that correct with the start of the spoken word?

 

> about 3 seconds early throughout

 

From start to finish, the same?

 

Stan

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 06, 2022 Jul 06, 2022

Copy link to clipboard

Copied

Well, I’m not sure how to read the .srt. The timeline TC is 00:00:11:16 and the .srt code reads: 00:00:11,678

Thanks




Michael J. Saul
Producer/Director
818.231.1027
www.MichaelSaul.com
moonspinnerprod@gmail.com

MESMERICA 360° Fulldome Experience
Returning to Theatres this Summer!
www.jameshood.com/mesmerica360

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 06, 2022 Jul 06, 2022

Copy link to clipboard

Copied

LATEST

That appears correct. The ,678 is milliseconds, so about half a second. So, since the times are correct, caption one should appear on the screen at 11 seconds. If it is 3 seconds early, that would be at 8 seconds? If this start time is okay, look ahead 15 minutes or so and check there.

 

We're looking to rule out a start time problem, a single edit problem (e.g. the subtitles jump at some point out of sync, and stay out of sync by the same amount), or a problem where the amount of time out of sync gets longer over time.

 

(When responding by email, be sure to turn off you auto signature. A moderator will probably remove that for you. Look at the end of your post for the "... More" to try to edit it out yourself.)

 

Stan

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines