Track targeting broken?

Explorer ,
Jun 22, 2022 Jun 22, 2022

Copy link to clipboard

Copied

I might be crazy, but in the latest release if I copy a clip from one sequence to another, the pasted clip shows up on a non-targted track. That is if the clip is on track 1 of the source sequence and the target sequence has track 4 selected as the target, the clip pastes to track 1 instead. It's entirely possible that I'm doing something wrong, but I seem to remember that the clip should paste to the target track regardless of the source track number. Help??? TIA

TOPICS
Editing , Error or problem , User interface or workspaces

Views

1.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Jun 24, 2022 Jun 24, 2022

I can't decide whether I should feel stupid, or wait to see if I am missing something.

 

I knew the Beta had a new set of shortcuts for pasting/track targeting, but I now see this was implemented in 22.5:

https://helpx.adobe.com/premiere-pro/using/whats-new/2022-5.html#paste-same-track

 

This does change the DEFAULT behavior.

 

Because I am using a custom keyboard setup, it did not affect me. I changed to the "Adobe Premiere Pro Default," and voila, I see the same behavior being described.

 

The

...

Likes

Translate

Translate
Community Expert , Jul 08, 2022 Jul 08, 2022

They changed the DEFAULT paste result in 22.5:

https://helpx.adobe.com/premiere-pro/using/whats-new/2022-5.html#paste-same-track

 

The change adds a keyboard shortcut to paste to the targeted track, but it is unassigned.

 

Or to go back to the "old" way, just delete the shortcuts in the Panel -> Timeline section of the Keyboard customization: "Paste Insert To Same Track" -> Ctrl+Shift+V and Paste [Overwrite] To Same Track -> Ctrl+V.

 

Stan

 

Likes

Translate

Translate
Explorer ,
Jun 29, 2022 Jun 29, 2022

Copy link to clipboard

Copied

Thanks...got it! I actually might try this...for now I have alt-Q as paste to target. My hand likes it more : )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 26, 2022 Jul 26, 2022

Copy link to clipboard

Copied

Very good and helpful post Stan, thanks very much. 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 09, 2022 Jul 09, 2022

Copy link to clipboard

Copied

As someone else pointed out on this thread, you can go into Keyboard shortcuts and set 'paste to target track' as command-V and set 'paste to same track number' as command-shift-V. That should do it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 08, 2022 Jul 08, 2022

Copy link to clipboard

Copied

Having the exact same problem since recent upgrade.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 08, 2022 Jul 08, 2022

Copy link to clipboard

Copied

They changed the DEFAULT paste result in 22.5:

https://helpx.adobe.com/premiere-pro/using/whats-new/2022-5.html#paste-same-track

 

The change adds a keyboard shortcut to paste to the targeted track, but it is unassigned.

 

Or to go back to the "old" way, just delete the shortcuts in the Panel -> Timeline section of the Keyboard customization: "Paste Insert To Same Track" -> Ctrl+Shift+V and Paste [Overwrite] To Same Track -> Ctrl+V.

 

Stan

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 08, 2022 Sep 08, 2022

Copy link to clipboard

Copied

Thanks, very helpful - this had me scratching my head when I switched to a fresh computer.

To clarify: Paste To Target Track (which is unassigned by default) seems to be the setting under the Timeline Panel shortcuts which has the old behaviour. My updated shortcuts:


richardh38606576_1-1662639814198.png

 

 

How does PP determine which track the "Paste To Same Track" command works on? What does "same" refer to? (Seems arbitrary).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 08, 2022 Sep 08, 2022

Copy link to clipboard

Copied

LATEST

The "same" track is the one you copied from.

 

The "old" method had no options under the timeline. And the shortcuts applied to the application (PR) as a whole. So whether in the timeline or some other panel, you got the paste [overwrite]/paste insert behaviors.

 

With the options added under the timeline panel, shortcuts there override the shortcuts for application.And to get the paste "to same [track]" behavior, you must use a shortcut: the options in the Edit drop down still only have the paste to target track behavior.

 

What you have now is (which is what you may want), when in the Timeline Panel, Ctrl+V will paste [overwrite] to the targeted track and Ctrl+Shift+V will paste [overwrite] to the same track you copied from. If you are not in the Timeline Panel, you'll get the "old" shortcut behavior.

 

Stan

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines