Video editing help! Lagging issues, slow performance!

New Here ,
Jul 08, 2022 Jul 08, 2022

Copy link to clipboard

Copied

Hey everyone. I'm at my wit's end! I'm a YouTuber and part of my job is to make tutorials, but as of late Adobe Premiere Pro is incredibly difficult to use. Yesterday it took me 4-5 hours to edit 20 minutes of video. This is very, very simple video - just a screen recording of me using Adobe Photoshop and a video of my talking. No crazy edits or effects being used. 4-5 hours!

 

I've added a screen recording here so you can see what I'm talking about: https://www.dropbox.com/s/7gom8vq4o8pqck0/PremiereProIssue.mov?dl=0

 

I can play the beginning of the video just fine, but it seems like as soon as I add another video into the mix it becomes nearly impossible to edit. At times the videos don't even play, it's just a black screen and audio.

 

Screenshots showing specs of my computer are attached. Any help would be greatly appreciated, because at this point I can't possibly do any more tutorials in Adobe Premiere Pro. Thank you!

 

Fuller

TOPICS
Editing , Freeze or hang , Performance

Views

98

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 08, 2022 Jul 08, 2022

Copy link to clipboard

Copied

Is that USB disk an HDD or SSD?

If HDD, that could be your issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 08, 2022 Jul 08, 2022

Copy link to clipboard

Copied

All of the media used in the video I'm editing is just on my desktop, it's not on the USB disk.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 08, 2022 Jul 08, 2022

Copy link to clipboard

Copied

Also, please use the free MediaInfo and post a screenshot of the properties of your media in tree view:
https://mediaarea.net/en/MediaInfo

Many users are having issues with VFR. If the file is variable frame rate, use Handbrake to convert to constant frame rate:
https://handbrake.fr/downloads.php
Here is a tutorial:
https://www.youtube.com/watch?time_continue=34&v=xlvxgVREX-Y

Shutter Encoder may also be used to convert to Constant Frame Rate:
https://www.shutterencoder.com/en/


Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 08, 2022 Jul 08, 2022

Copy link to clipboard

Copied

What this most commonly comes down to is workflow and understanding media.  

 

Premiere has a low barrier to entry and will accept all different kinds of media, whether or not they are very easy to work with in post production. Your "very, very simple video," is most likely not simple at all. It may actually be terrible to work with.  

 

You've got some resources from Peru Bob already related to figuring out some of the issues with your media. We can assume you're editing H264, which is a delivery codec and not optimized video for post production. Because it's a screen recording it may also have Variable Framerate, which is like poison for editing software. If they are high framerate that is going to add to the difficulty in decoding. You're also trying to use multiple streams of that difficult media, so you may have a video codec that's barely playable when you're using a single stream, and then you're doubling the work for the computer with the multiple streams.

 

Using editing codecs would help. A proxy workflow would help (but if your clips are VFR then you'd probably need to correct that first.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 08, 2022 Jul 08, 2022

Copy link to clipboard

Copied

I guess I'm most frustrated because I've done a lot of videos before with very few problems. It's a little slow sometimes, but this is a whole new level. At this point, I'm just listening to the audio and blindly editing the video hoping I'm right.

 

I'll look into all of the above. The reason I said "very, very simple" was just to emphasis that I'm not doing anything other than splicing clips. Feel like it should be pretty straight forward, but I guess I'm wrong. 

 

Thanks everyone.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 08, 2022 Jul 08, 2022

Copy link to clipboard

Copied

Yeah, nothing wrong with the actions you’re doing. They are unrelated to the playback issues. Learning about video codecs and what makes them perform and behave differently will change your whole editing experience. You won’t be confused about why things happen the way they do. It won’t be this big mystery that you can only assume is Adobe’s fault - and I’m not saying this in an Adobe fan-boy kind of way, it’s just honestly all people can do when they have no idea what’s going on.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 08, 2022 Jul 08, 2022

Copy link to clipboard

Copied

LATEST

If you're doing cuts only editing (that is "not doing anything other than splicing clips") and you see yellow above the clips in the Timeline, yes, you're doing it wrong.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 08, 2022 Jul 08, 2022

Copy link to clipboard

Copied

AL parecer viendo el video es que tus archivos photoshop son demasiado grandes (quizas de 6000px para arriba o quizas la reso,ucion de dichas imagenes sea por encima de 72ppp ) y eso traba la maquina para que pueda reproducir fluidamente, lo que sugiero es verificar ese dato y ver si el problema persiste.
espero sea de ayuda.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines