Hey Adobe, Premiere Pro has no control for ligatures...

New Here ,
Aug 27, 2018 Aug 27, 2018

Copy link to clipboard

Copied

... and in addition to this each of the text tools do things differently.  See attached screengrab.

The caption tool has ligatures turned on and no option to toggle.

The new title tools has ligatures turned on and no option to toggle.

The Legacy Title tool has ligatures turned off and no way option to toggle.

Here's a use case scenario:

The Foundry Sterling font is a part of my organisations branding so must be used in this scenario, but it won't be particular to this font.

SRT file is imported as for use in the Caption tool, but ligatures are on and some of the text instances need changing.

The sections of text where ligatures appear must be identified amongst all the captions and deleted from the Caption tool.  Legacy title tool objects must be made to replace those instances matching size and spacing.  It starts to make the Caption tool redundant for the whole process.

It may not be that many out of a whole video, but it's also a workaround and extra steps for something that could have the same amount of font control as say, Photoshop already has.

ligatures_PPro.jpg

Views

1.9K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 29, 2018 Aug 29, 2018

Copy link to clipboard

Copied

Bottom line: make a feature request:

Premiere Pro: Hot (2250 ideas) – Adobe video & audio apps

Currently, nothing with "ligature." In Photoshop, Type Layer Properties, Advanced there is an icon/toggle for "Standard Ligatures." Very cool; never knew.

I used Adobe Garamond Pro for testing, and I get your results for Legacy (default off) and new graphics panel (default on), but on Open Captions, adding a new caption, I get default Off.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 30, 2018 Aug 30, 2018

Copy link to clipboard

Copied

A fair call Stan, thanks for the link.  Feature request submitted.

Interesting discovery about entering new captions as opposed to importing a file.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 31, 2018 Aug 31, 2018

Copy link to clipboard

Copied

Voted for it.

The direct link is:

ligature – Adobe video & audio apps

Are you setting the font in the .srt you import? Not sure of the srt format for that. The default for me is Arial, and when I change to a ligature font, ligature is off.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 01, 2018 Oct 01, 2018

Copy link to clipboard

Copied

This is the most frustrating issue in premiere. How is there no toggle for ligatures for this yet, as the toggle feature exists in virtually every other Adobe program.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 10, 2020 Jul 10, 2020

Copy link to clipboard

Copied

How do I turn off ligatures in Premiere Pro 14? I can't use the desired font unless I can turn it off.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 25, 2021 Feb 25, 2021

Copy link to clipboard

Copied

Go to Edit > Preferences > Graphics.
Under Text Engine select "South Asian and Middle Eastern"
Under Text Styling, remove the checkmark next to "Ligatures"
Now this will be your default for all Essential Graphics text boxes going forward. I'm curious if changing the Text Engine from "European and East Asian" will weirdly affect something else with text in Essential Graphics, hopefully not...

 

I haven't poked around too much with the settings lately but this seems like a new thing that just became available via the Adobe CC updates. FYI, my current PrePro version is v14.0 (Build 52)

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 09, 2021 Apr 09, 2021

Copy link to clipboard

Copied

This^. Thanks payday0023 – that solved it for me! 👍

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines