Highlighted

Premiere pro does not use GPU

Community Beginner ,
Jul 09, 2019

Copy link to clipboard

Copied

Hello!

I have Microsoft Surface Book 2 laptop:
CPU - 8650U
GPU1 - Intel620
GPU2- Nvidia 1060GTX 6 Mb
RAM - 16Mb

Windows 10 1903 Build 18362.207

Premiere pro - 13.1.2

Nvidia driver - 430.86 (last)

When i'm using Premiere pro all video are freezing. GPU2 (Nvidia) does not working.

What i have tried:

1. Run as Administrator

2. Maximum performance (battery)

3. Choose CUDA in new project
4. Run apps with Nvidia card
5. Re-Install:
     5.1. Windows
     5.2. Adobe Premiere Pro
     5.3. Nvidia drivers

6. Change the laptop (yes, i have thought that laptop is broken)

Nothing helps ... I'm trying to solve this problem last four months.

Impossible to work in Premiere pro.

Nvidia Driver.PNG

Battery max perfomance.png

Adobe Cuda.png

It seems to me that Intel hw-decoder does not support h264 422 10bit format, that's why it's so sluggish

Views

20.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Premiere pro does not use GPU

Community Beginner ,
Jul 09, 2019

Copy link to clipboard

Copied

Hello!

I have Microsoft Surface Book 2 laptop:
CPU - 8650U
GPU1 - Intel620
GPU2- Nvidia 1060GTX 6 Mb
RAM - 16Mb

Windows 10 1903 Build 18362.207

Premiere pro - 13.1.2

Nvidia driver - 430.86 (last)

When i'm using Premiere pro all video are freezing. GPU2 (Nvidia) does not working.

What i have tried:

1. Run as Administrator

2. Maximum performance (battery)

3. Choose CUDA in new project
4. Run apps with Nvidia card
5. Re-Install:
     5.1. Windows
     5.2. Adobe Premiere Pro
     5.3. Nvidia drivers

6. Change the laptop (yes, i have thought that laptop is broken)

Nothing helps ... I'm trying to solve this problem last four months.

Impossible to work in Premiere pro.

Nvidia Driver.PNG

Battery max perfomance.png

Adobe Cuda.png

It seems to me that Intel hw-decoder does not support h264 422 10bit format, that's why it's so sluggish

Views

20.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jul 09, 2019

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 09, 2019

Copy link to clipboard

Copied

Thank you for the link. And may case is different. I have modern hardware , last windows update and etc. I don't use any filter or effect.

I'm trying just mix and play some video. I think that 1060Gtx with 6Gb is enough for simple editing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 09, 2019

Copy link to clipboard

Copied

Might want to read the article again on what cuda does and does NOT do.

What we are seeing in your YT movie is perfectly normal.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 09, 2019

Copy link to clipboard

Copied

I think it is unnormal when you see slide show in Premier Pro with premium video card.

In edit mode (just mix and play) 1060Gtx does not work. For example, same video on desktop computer (with 1080Gtx) perfectly play with video card acceleration. My video shoes that you is editing video 1060 does not help CPU.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 09, 2019

Copy link to clipboard

Copied

Your laptop has a limiting factor: on board gpu.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Jul 09, 2019

Copy link to clipboard

Copied

Ann is correct.

If you disable your on-board Intel graphics, it will allow your Nvidia GPU to perform as expected. There are different ways to disable the Intel GPU temporarily; a Google search can help you find the proper method.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 09, 2019

Copy link to clipboard

Copied

If i have integrate GPU and discrete GPU than Premiere Pro does not work correct ?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 09, 2019

Copy link to clipboard

Copied

I have tried this but still nothing.

I can disable on board GPU only via Device Manager.

Surface Book 2 does not have option in BIOS.  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Guide ,
Jul 10, 2019

Copy link to clipboard

Copied

JEFF !  So good to see you !  It's me, the infamous trouble maker ROBODOG !

Saw your website recently and glad you're shooting and editing etc. Hope you and family are well !

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Guide ,
Jul 10, 2019

Copy link to clipboard

Copied

poster ..  what is the source material you are using to make your video ???

Is it 4K mov H264  ?

If I was you I'd try to make the source material as friendly to the computer as possible... a video source that is easy for the computer to work with.   Your computer might not end up being super happy if you use cineform proxy, but I bet it will be a lot happier than using H264

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jul 10, 2019

Copy link to clipboard

Copied

Adobe Premiere does not use dedicated/external GPU to decode h.264 videos. Only Intel's iGPU can be used for that. So don't expect butter smooth playback if iGPU is disabled. Another possibility is iGPU driver issue, when it's enabled but doesn't work for some reason.

Consider updating it manually from Intel site:

Downloads for Intel® Core™ i7-8650U Processor (8M Cache, up to 4.20 GHz)

and when removing DCH-drivers remember this:

Learn How to Roll Back Your Driver to a Previous Version

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 10, 2019

Copy link to clipboard

Copied

rodneyb56060189  wrote

poster ..  what is the source material you are using to make your video ???

Is it 4K mov H264  ?

If I was you I'd try to make the source material as friendly to the computer as possible... a video source that is easy for the computer to work with.   Your computer might not end up being super happy if you use cineform proxy, but I bet it will be a lot happier than using H264

I use mp4 container with H.264 codec

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 10, 2019

Copy link to clipboard

Copied

basil1891  wrote

Adobe Premiere does not use dedicated/external GPU to decode h.264 videos. Only Intel's iGPU can be used for that. So don't expect butter smooth playback if iGPU is disabled. Another possibility is iGPU driver issue, when it's enabled but doesn't work for some reason.

Consider updating it manually from Intel site:

Downloads for Intel® Core™ i7-8650U Processor (8M Cache, up to 4.20 GHz)

and when removing DCH-drivers remember this:

Learn How to Roll Back Your Driver to a Previous Version

Thank you for the advise. I will try this.

I have just tried to edit 4k movie from my GoPro - it works correct.

Pr uses both GPU.

GoPro h.264 Adobe.PNG

GoPro h.264 file information.PNG

Now problem only with mp4 files from my Panasonic GH5. Pr does not use Nvidia.

GH5 h.264 Adobe.PNG

GH5 h.264 file information.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jul 10, 2019

Copy link to clipboard

Copied

It seems to me that Intel hw-decoder does not support h264 422 10bit format, that's why it's so sluggish

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 11, 2019

Copy link to clipboard

Copied

basil1891  wrote

It seems to me that Intel hw-decoder does not support h264 422 10bit format, that's why it's so sluggish

It is very fresh idea.

I was trying to check the idea and did not findany information about supporting hardware acceleration by Intel.

Although i was trying to convert my h264 422 10 bit video to same h265 and did not find any vedeo convector.

In Adobe Encoder i have not found setting to set up 10 bit...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 13, 2019

Copy link to clipboard

Copied

basil1891  написал(а)

It seems to me that Intel hw-decoder does not support h264 422 10bit format, that's why it's so sluggish

I think you are right. I have problem only with 10bit file from my GH5 camera... I have found a similar problem. 
GH5 4K All-I H.264 10-bit 400Mbps files import problem

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 13, 2019

Copy link to clipboard

Copied

basil1891  написал(а)

It seems to me that Intel hw-decoder does not support h264 422 10bit format, that's why it's so sluggish

I have converted a video to h.265 10bit. And it still freezing in Pr13.

I have used FFMPEG for converting:

ffmpeg.exe -hwaccel cuvid -i Boewn1.mp4 -c:v hevc_nvenc -profile main10 -preset slow -rc vbr_hq -b:v 130M -maxrate:v 160M -c:a aac -b:a 320k Boewn265main10.mp4


It looks like Pr 13 does not use hardware acceleration for 10bit video.It means i can't edit 10bit video on my laptop or desktop with 2xNvidia Geforce 1080Gtx video card.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jul 13, 2019

Copy link to clipboard

Copied

Since you are already familiar with FFmpeg perhaps the best option for you is to convert the sources to Prores format. But be sure you have enough free space for it. Your GTX1080's will be used for effects anyways, regardless of input format. But beware of this bug:

Re: Order of filters/effects and drop in CUDA-rendering speed, is it a bug or a feature?

Also you can use NVENC during final export. I prefer constant quality mode (cq18 .. cq16) instead of VBR.

p.s I've heard that ffmpeg 'cuvid' decoding mode is rather buggy and that 'dxva2' is more forgiving, so beware.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 13, 2019

Copy link to clipboard

Copied

basil1891  написал(а)

Since you are already familiar with FFmpeg perhaps the best option for you is to convert the sources to Prores format. But be sure you have enough free space for it. Your GTX1080's will be used for effects anyways, regardless of input format. But beware of this bug:

Re: Order of filters/effects and drop in CUDA-rendering speed, is it a bug or a feature? 

Also you can use NVENC during final export. I prefer constant quality mode (cq18 .. cq16) instead of VBR.

p.s I've heard that ffmpeg 'cuvid' decoding mode is rather buggy and that 'dxva2' is more forgiving, so beware.

I have tried to compare H.264/H.265 10 bit in Pr13. 

I'm hoping that Intel QuickSync hardware acceleration should work with H.265 10bit but still nothing.

Now it is only one choice - convert to H.264/H.264 8bit. It works correct.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 10, 2019

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 10, 2019

Copy link to clipboard

Copied

It seams afaik with many laptops you cannot disable the on board gpu

and you have to be plugged into the wall all the time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 10, 2019

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 10, 2019

Copy link to clipboard

Copied

What i have just noticed:
when Premier Pro works i starts GPUSniffer.exe it helps for next 2-3 seconds (Nvidia cards loads 25-30%) but after that performance Nvidia Cards downs to 0.
GPUSniffer - YouTube

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 10, 2019

Copy link to clipboard

Copied

I have tested my laptop in 3dMark (stress test DX12) - system perfect full loaded for 13 minutes. Nvidia perfectly works.

3DMark Stress Test SB2 Full Load GPU.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 10, 2019

Copy link to clipboard

Copied

Of course it works perfectly, but Pr is a different ballgame.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 10, 2019

Copy link to clipboard

Copied

https://forums.adobe.com/people/Ann+Bens  wrote

Of course it works perfectly, but Pr is a different ballgame.

I understand this and i think that Pr uses hardware acceleration via DirectX.

I just want to understand why Pr does not work correct  on my laptop.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 23, 2019

Copy link to clipboard

Copied

Does anyone have any updates?

Although CUDA is selected in the project's settings, the GTXs RAM is not used while editing more than 3 to 5 % (When I play a video file with VLC its 20-25 %!). In addition, HardwareACC is not possible to select when exporting to H.264. I am not an expert but in my understanding Premiere should at least use a bit of the 6GB while editing, right?

I use Windows 10, GeForce GTX1660 with 6GB RAM and 16GB general RAM. Newest NVIDIA Driver installed (maybe I should try Studio instead of Gaming?).

In general setting I chose "Optimize for: Storae" than Performance.

Does anyone have any ideas?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 09, 2020

Copy link to clipboard

Copied

I have same problem :(((((

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 23, 2020

Copy link to clipboard

Copied

Same here (Windows 10 Pro / Gigabyte X570 AORUS ELITE / AMD Ryzen 9 3950X /  Nvidia GeForce RTX 2060 SUPER / 32 Go ram). Nothing (2% max) on the GPU when displaying in Premiere (fluidity not perfect), and around  25-35% when displaying in VLC (where fluidity is perfect).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 23, 2020

Copy link to clipboard

Copied

Not all h.264 is created equal. Some variations are very hard to playback. I imagine Intel's Quick Sync will get revamped soon. That being siad I have a video that may or may not be helpful.

https://youtu.be/pE6t1ryanO4

This video shows how to enable and disable Intel's Quick Sync for playback and rendering.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...