Highlighted

"Your system's hardware does not support hardware acceleration for the current settings" on export

New Here ,
Apr 09, 2018

Copy link to clipboard

Copied

There is a new option to select "Hardware Accelerated" on export.

I have a iMac (Retina 5K, 27-inch, Late 2014), Processor:  4 GHz Intel Core i7,  32 GB 1600 MHz DDR3, and a  AMD Radeon R9 M295X 4 GB graphic card.

I can use hardware acceleration in the timeline for render but no on export? What's up?

Thanks!

The MPE renderer and the Intel H.264 encoder are two completely separate things. In your case, the Radeon R9 M295x, AFAIK, does not support hardware H.264 encoding at all. And the H.264 encoder in Premiere Pro CC 2018.1 only supports 6th- or later generation Intel I series CPUs with only the integrated, on-CPU Intel HD or UHD Graphics 500- or later series enabled. Unfortunately, Apple configured all of its systems with discrete GPUs to always automatically switch the GPU to the discrete one when Premiere is launched, and makes it very difficult, if not impossible, to override that behavior. And Adobe does not currently support hardware acceleration of H.264 encodes through a discrete GPU.

By the way, your iMac is too old to even support Adobe's implementation of the Intel H.264 hardware encoder in any event: It has only a 4th-generation i5 or i7 CPU. And even its integrated graphics is only an HD Graphics 4600 – too old to be supported.

Views

14.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

"Your system's hardware does not support hardware acceleration for the current settings" on export

New Here ,
Apr 09, 2018

Copy link to clipboard

Copied

There is a new option to select "Hardware Accelerated" on export.

I have a iMac (Retina 5K, 27-inch, Late 2014), Processor:  4 GHz Intel Core i7,  32 GB 1600 MHz DDR3, and a  AMD Radeon R9 M295X 4 GB graphic card.

I can use hardware acceleration in the timeline for render but no on export? What's up?

Thanks!

The MPE renderer and the Intel H.264 encoder are two completely separate things. In your case, the Radeon R9 M295x, AFAIK, does not support hardware H.264 encoding at all. And the H.264 encoder in Premiere Pro CC 2018.1 only supports 6th- or later generation Intel I series CPUs with only the integrated, on-CPU Intel HD or UHD Graphics 500- or later series enabled. Unfortunately, Apple configured all of its systems with discrete GPUs to always automatically switch the GPU to the discrete one when Premiere is launched, and makes it very difficult, if not impossible, to override that behavior. And Adobe does not currently support hardware acceleration of H.264 encodes through a discrete GPU.

By the way, your iMac is too old to even support Adobe's implementation of the Intel H.264 hardware encoder in any event: It has only a 4th-generation i5 or i7 CPU. And even its integrated graphics is only an HD Graphics 4600 – too old to be supported.

Views

14.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 09, 2018 0
LEGEND ,
Apr 09, 2018

Copy link to clipboard

Copied

The MPE renderer and the Intel H.264 encoder are two completely separate things. In your case, the Radeon R9 M295x, AFAIK, does not support hardware H.264 encoding at all. And the H.264 encoder in Premiere Pro CC 2018.1 only supports 6th- or later generation Intel I series CPUs with only the integrated, on-CPU Intel HD or UHD Graphics 500- or later series enabled. Unfortunately, Apple configured all of its systems with discrete GPUs to always automatically switch the GPU to the discrete one when Premiere is launched, and makes it very difficult, if not impossible, to override that behavior. And Adobe does not currently support hardware acceleration of H.264 encodes through a discrete GPU.

By the way, your iMac is too old to even support Adobe's implementation of the Intel H.264 hardware encoder in any event: It has only a 4th-generation i5 or i7 CPU. And even its integrated graphics is only an HD Graphics 4600 – too old to be supported.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 09, 2018 3
New Here ,
Apr 09, 2018

Copy link to clipboard

Copied

Thanks, much appreciated!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 09, 2018 0
New Here ,
Jun 13, 2018

Copy link to clipboard

Copied

I'm having this same issue, but on a Windows based desktop. The GPU in question is the AMD Radeon Pro WX 3100.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 13, 2018 0
LEGEND ,
Jun 13, 2018

Copy link to clipboard

Copied

Read my response above. The hardware H.264 encoder described in this discussion does not support CUDA or OpenCL at all. It supports only Intel QuickSync, which currently only the integrated Intel on-CPU graphics processors support. It has absolutely nothing at all to do whatsoever with the MPE GPU acceleration for pre-renders.

So, if you're using an AMD CPU, you cannot have hardware H.264 acceleration at all. Nor can you have hardware H.264 acceleration at all if you're using an Intel CPU that requires a discrete GPU just to even work at all (such as a CPU that uses the X299 chipset on the motherboard).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 13, 2018 0
New Here ,
Jun 13, 2018

Copy link to clipboard

Copied

I think I understand now. I believe my confusion was between Hardware Acceleration in Premiere vs using OpenCL when rendering out the project in Media Encoder. I've never worked with an AMD or OpenCL card before (only Nvidia CUDA) but I believe this makes more sense now. Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 13, 2018 0
New Here ,
Sep 06, 2018

Copy link to clipboard

Copied

I had this error with Premiere Pro CC. Got the error saying "Your system's hardware does not support hardware acceleration". Picked H.264, but had to change the preset, then the GPU on my Predator started working for encoding/export. The preset on the export menu was the problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 06, 2018 4
New Here ,
Aug 17, 2019

Copy link to clipboard

Copied

Had the same issue. Both GPUs were enabled but the export preset was the problem.

VBR, 2 Pass removes the Hardware Acceleration option. 1 Pass and CBR keeps it available.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 17, 2019 0
New Here ,
Sep 07, 2020

Copy link to clipboard

Copied

So on VBR, 2 Pass it's impossible to have the Hardware Acceleration?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2020 0
LEGEND ,
Sep 07, 2020

Copy link to clipboard

Copied

Yes. None of the hardware encoders currently available support 2-pass at all.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2020 0
Community Beginner ,
Jan 30, 2020

Copy link to clipboard

Copied

hi i have macbook pro 16" i9 cpu 9th but i have a same problem too why?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 30, 2020 0
New Here ,
Apr 17, 2019

Copy link to clipboard

Copied

i hae 2018 macbook pro 15" i9

Radeon Pro Vega 20 4 GB

Intel UHD Graphics 630 1536 MB

and i get the same error message.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 17, 2019 2
New Here ,
Mar 22, 2020

Copy link to clipboard

Copied

Replying with my same issue, different solution: my video was recorded in a weird profile, not high-4.2. So in export at 'match sequence settings' it was trying to export that same weird way and not giving me the option for hardware encoding. Switching the export to Main 4.2 fixed it for me.  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 22, 2020 0