• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Blue Lagoon Skin with Orange component errors

Participant ,
Nov 04, 2022 Nov 04, 2022

Copy link to clipboard

Copied

Hello,

I am just trying to figure out if this is how adobe does its templates/skins or if its just an issue with the template i tested. 

 

Before I start - RH2022 mac, fresh new project, new content, new styles etc.  Nothing converted - all from scratch created within RH2022.

 

In testing out the Blue Lagoon template, I am getting 404 errors where it is looking for the orange.css.map.  When I dug into the build, i found the welcome page and other things were really the orange template with the userstyles.css used to convert it to the blue lagoon look.  In developer view in my browser, i can turn off the userstyles file and the site essentially becomes the orange site.  I even found the orange template files and images inside the blue lagoon's directory.  These files are not even called in the blue lagoon template at all so they serve no function.  It looks like they just built over the template opposed to building blue lagoon as a new template.

 

I want to customize a few things but i don't want to have to fight two separate templates when making my tweaks in a user asset style sheet. 

 bluelagoonerror.pngbluelagoon copy.png

  

Views

111

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 05, 2022 Nov 05, 2022

Copy link to clipboard

Copied

I think it is the case that some templates are built from scratch and some are modifications of others but I don't see in a problem in that alone as long as they work. They may still use parts of the base template but again, as long as that works it doesn't matter to the end user.

 

In testing out the Blue Lagoon template, I am getting 404 errors where it is looking for the orange.css.map. 

Obviously that should not happen but you haven't said how you invoke that error. Let me know that and I will see what I can find out. In a simple project with an untouched version of the template it is working OK.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 05, 2022 Nov 05, 2022

Copy link to clipboard

Copied

Hi @Peter Grainge ,

My management does not like any of the templates so I know i will have to heavily customize the template.  I will just start with orange since its the base of the blue lagoon and do what they did with blue lagoon to create my own. 

 

For the 404 errors, I am getting them in my local builds and on my staging server.  I am finding them in Firefox when i enter the developer mode (f12).  It is categoriezed as a warning in the tool.  warning.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 05, 2022 Nov 05, 2022

Copy link to clipboard

Copied

So you are seeing 404 errors when you use the output and using developer tools you are finding what you have reported, correct?

 

Check the About RoboHelp sample project to see if that has the same issues using an uncustomised Blue Lagoon template. You will find it in Documents > My RoboHelp Projects.

 

I am not getting any 404s using Blue Lagoon with About RoboHelp.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 07, 2022 Nov 07, 2022

Copy link to clipboard

Copied

I tested a few of their sample projects - same error.  i think i found the issue.  in the default layout.css, the orange.css. map is not properly commented out.

 

Line 5116, out of the box, has

/*# sourceMappingURL=orange.css.map */

 

Removing the # and commenting it out properly for css fixes the error.

/* sourceMappingURL=orange.css.map */

 Now i need to find where this is in the source so i don't have to manually fix it with every build.  I only see the layoutdiff.css in the skin folder for each skin but not the layout.css. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 07, 2022 Nov 07, 2022

Copy link to clipboard

Copied

You might want to look at writing a script to update the css and add it to the Post Generation Script field in the output preset. That would update it each time you generate. Otherwise I think you need to dig around in the installation folder, and those files might be overwritten with updates. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 14, 2022 Nov 14, 2022

Copy link to clipboard

Copied

LATEST

yeah, you are right, future updates are what i am afraid of as others on my team will be using this.  for the time being, i tink i am going to manually fix the css in the build, push it out and then make the server copy a read-only so future pushes will not override it.  its a css file so there shouldnt be any changes until i change the design. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp