Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Broken links created by Robohelp2019 conversion

Explorer ,
Jan 16, 2019 Jan 16, 2019

Copy link to clipboard

Copied

I am running Robohelp 2019.0.4.

Converting a Robohelp Classic project to Robohelp 2019 breaks links in my TOCs.

There are NO broken links in the Classic project, yet the 2019 broken now shows many broken links.

Why is this happening and how can I rectify this without touching every single one of these links?

TOPICS
HTML, New UI

Views

2.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 19, 2019 Feb 19, 2019

Copy link to clipboard

Copied

Thanks for your advice. I have a question please for the upgrade, should I do the upgrade in a different path of the original 2015 project?

I have done a trial to locate the upgraded project in a different drive, I have broken links in output presets, and when I remove it from the folder and got all the broken links empty, I had the same error (broken links) while generating PDF.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 19, 2019 Feb 19, 2019

Copy link to clipboard

Copied

The upgrade does not have to be to a different drive. When you browse to the XPJ to upgrade, RoboHelp initially creates another folder with the same name plus it appends _2019. You can change that but it will not allow you to upgrade to the original folder.

From what you say, it sounds as if the issues is resolved by deleting the existing presets and creating new ones. However, I can't be sure without the answers to what I have already posted.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 19, 2019 Feb 19, 2019

Copy link to clipboard

Copied

I have upgraded different project, and fixed all broken links as in the below image. However, I still get the same error.  with projects that are upgraded. It only works with new projects created with 2019.

broken.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 19, 2019 Feb 19, 2019

Copy link to clipboard

Copied

Sorry, that's the missing part "Unfortunately, it seems PDF output doesn't work with upgraded project"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 18, 2019 Feb 18, 2019

Copy link to clipboard

Copied

Eman, can you select the listed files and reapply the CSS?

-Matt

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 05, 2019 Aug 05, 2019

Copy link to clipboard

Copied

LATEST

I was checking Robohelp update 8, and good news is I just found that Broken links issue is now fixed, and managed to generate PDF normally.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2
Resources
RoboHelp Documentation
Download Adobe RoboHelp