Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Custom fonts wont work on homepage (index.htm)

Explorer ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

Hi guys, I'm using RH2020 2020.3.32. 
I added custom font like in Peter's guide using the "@font-face" feature. 
It works for me in topics, but in homepage they are not displaying correctly in PC's without this font installed locally. 
This is how it shoud be (when font is applied correctly or when ran from pc with font installed)

defaultv667u7s1tnd8_0-1615389293558.png

This is how it looks on another pc (font enabled)

defaultv667u7s1tnd8_1-1615389495728.png

 



Interesting fact: if I disable font in web console, the font will be changed to a different. 
This is how it looks in another pc (font disabled in web console)

defaultv667u7s1tnd8_2-1615389506317.png


This is how font is specified for a title

defaultv667u7s1tnd8_3-1615389652841.png

This is css:

defaultv667u7s1tnd8_4-1615389704993.png

 

 

 

TOPICS
New UI, Output presets

Views

119

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Mar 12, 2021 Mar 12, 2021
Fixed with specifying @Font-face directly in custom css that in User Assets

Likes

Translate

Translate
Adobe Community Professional ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

Are you actually packaging the custom font with the output? I think that part is what is required to make the reference in the css work on machines that don't have the font installed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

Custom font placed in same folder as css and present in final output in css folder

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

defaultv667u7s1tnd8_0-1615391150143.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

See if Item 15 helps. Snippets (grainge.org)

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

Hi Peter, 
Unfortunatelly, nothing changed. 

defaultv667u7s1tnd8_0-1615456006189.png

Here you can see, that font from User Assets css is applied, but do not work as expected. 
Below you can see how it is added in robo and file:

defaultv667u7s1tnd8_1-1615456133866.png

font.css file:

defaultv667u7s1tnd8_2-1615456155148.png

 



Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

  1. Create a new project leaving just First Topic in it.
  2. Add your CSS and skin.
  3. Set things up so that it should apply the font to your skin. Double check my instructions.
  4. Generate an output to prove it doesn't work.

 

See the Contact page on my site and send the project as instructed there. Do make sure you include a link to this thread and please do not email the project direct.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

LATEST

Fixed with specifying @Font-face directly in custom css that in User Assets

 

defaultv667u7s1tnd8_0-1615544303390.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation